aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2010-10-21 22:03:23 +0800
committersem <sem@FreeBSD.org>2010-10-21 22:03:23 +0800
commitb68ec252574ff2106207188283e56161eebe2d9f (patch)
tree3a6dec313a0b22b082740ce6f9aa051bdc3ba6cd /net
parent788c18c41715f3dc5695c951a1a65acdf24e7782 (diff)
downloadfreebsd-ports-gnome-b68ec252574ff2106207188283e56161eebe2d9f.tar.gz
freebsd-ports-gnome-b68ec252574ff2106207188283e56161eebe2d9f.tar.zst
freebsd-ports-gnome-b68ec252574ff2106207188283e56161eebe2d9f.zip
- A patch from quagga git to fix time in statistic output.
Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-git-114
2 files changed, 15 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 9e3212ed1e56..ab64de39830a 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-git-1 b/net/quagga/files/patch-git-1
new file mode 100644
index 000000000000..0de3b0b0235e
--- /dev/null
+++ b/net/quagga/files/patch-git-1
@@ -0,0 +1,14 @@
+diff --git bgpd/bgp_route.c bgpd/bgp_route.c
+index 2391f74..1cfc451 100644
+--- bgpd/bgp_route.c
++++ bgpd/bgp_route.c
+@@ -6145,7 +6145,8 @@ route_vty_out_detail (struct vty *vty, struct bgp *bgp, struct prefix *p,
+ bgp_damp_info_vty (vty, binfo);
+
+ /* Line 7 display Uptime */
+- vty_out (vty, " Last update: %s", ctime (&binfo->uptime));
++ time_t tbuf = time(NULL) - (bgp_clock() - binfo->uptime);
++ vty_out (vty, " Last update: %s", ctime(&tbuf));
+ }
+ vty_out (vty, "%s", VTY_NEWLINE);
+ }