aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-05-25 03:38:10 +0800
committerflo <flo@FreeBSD.org>2011-05-25 03:38:10 +0800
commitb7582bce4e89905dc787b362abc0b10c55459479 (patch)
tree4914d14989316631c80dacfb5bdf5516fcf601a7 /net
parent57e05c26edf1632327f0cd251596115d2a56e9ce (diff)
downloadfreebsd-ports-gnome-b7582bce4e89905dc787b362abc0b10c55459479.tar.gz
freebsd-ports-gnome-b7582bce4e89905dc787b362abc0b10c55459479.tar.zst
freebsd-ports-gnome-b7582bce4e89905dc787b362abc0b10c55459479.zip
- update to 1.8.4.1
- remove CPPFLAGS from CONFIGURE_ENV we already set it explicitly - fix WITH_LUA case LDFLAGS was not set correctly [1] - use tabs instead of spaces in WITH_SRTP part Reported by: Victor Timonin <victor@timonin.su> [1]
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile17
-rw-r--r--net/asterisk/distinfo4
-rw-r--r--net/asterisk10/Makefile17
-rw-r--r--net/asterisk10/distinfo4
4 files changed, 20 insertions, 22 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index be8a1b20fdcf..552235ee2a29 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.4
-PORTREVISION= 1
+PORTVERSION= 1.8.4.1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -24,9 +23,9 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
+LDFLAGS= -L${LOCALBASE}/lib
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_GNOME= libxml2
@@ -261,12 +260,12 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
.endif
.if !defined(WITH_SRTP)
-PLIST_SUB+= WITH_SRTP="@comment "
-CONFIGURE_ARGS+= --without-srtp
+PLIST_SUB+= WITH_SRTP="@comment "
+CONFIGURE_ARGS+= --without-srtp
.else
-PLIST_SUB+= WITH_SRTP=""
-BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
-CONFIGURE_ARGS+= --with-srtp
+PLIST_SUB+= WITH_SRTP=""
+BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
+CONFIGURE_ARGS+= --with-srtp
.endif
.if defined(WITH_LUA)
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index 302d8bc1b6da..d96846f2b1bf 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.4.tar.gz) = 474404e0c85eac7e425d796936758aee9e959166dbdc15c9f391a1543deb205e
-SIZE (asterisk-1.8.4.tar.gz) = 27021108
+SHA256 (asterisk-1.8.4.1.tar.gz) = 7c45d666b3d8c31638d3f98078d50a503a35bb88b23a59baf4de6b2fa7cf0c60
+SIZE (asterisk-1.8.4.1.tar.gz) = 27026105
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index be8a1b20fdcf..552235ee2a29 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.4
-PORTREVISION= 1
+PORTVERSION= 1.8.4.1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -24,9 +23,9 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
+LDFLAGS= -L${LOCALBASE}/lib
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_GNOME= libxml2
@@ -261,12 +260,12 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
.endif
.if !defined(WITH_SRTP)
-PLIST_SUB+= WITH_SRTP="@comment "
-CONFIGURE_ARGS+= --without-srtp
+PLIST_SUB+= WITH_SRTP="@comment "
+CONFIGURE_ARGS+= --without-srtp
.else
-PLIST_SUB+= WITH_SRTP=""
-BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
-CONFIGURE_ARGS+= --with-srtp
+PLIST_SUB+= WITH_SRTP=""
+BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
+CONFIGURE_ARGS+= --with-srtp
.endif
.if defined(WITH_LUA)
diff --git a/net/asterisk10/distinfo b/net/asterisk10/distinfo
index 302d8bc1b6da..d96846f2b1bf 100644
--- a/net/asterisk10/distinfo
+++ b/net/asterisk10/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.4.tar.gz) = 474404e0c85eac7e425d796936758aee9e959166dbdc15c9f391a1543deb205e
-SIZE (asterisk-1.8.4.tar.gz) = 27021108
+SHA256 (asterisk-1.8.4.1.tar.gz) = 7c45d666b3d8c31638d3f98078d50a503a35bb88b23a59baf4de6b2fa7cf0c60
+SIZE (asterisk-1.8.4.1.tar.gz) = 27026105