aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-12 23:14:36 +0800
committerswills <swills@FreeBSD.org>2014-03-12 23:14:36 +0800
commitb7cbe809b528aa601b3eac22919162ea34e6889e (patch)
treed07b3a32b3e522cae616e028a0ef0632222b4e7d /net
parentcbe05f45a0b6439b9ca1a64d1a30ec7067f648c7 (diff)
downloadfreebsd-ports-gnome-b7cbe809b528aa601b3eac22919162ea34e6889e.tar.gz
freebsd-ports-gnome-b7cbe809b528aa601b3eac22919162ea34e6889e.tar.zst
freebsd-ports-gnome-b7cbe809b528aa601b3eac22919162ea34e6889e.zip
- Fix disabling VIEWER option didn't work (obtained from upstream [1])
- Add missing dependency on ImageMagick required to generate icons during the build and use these icons for DESKTOP_ENTRIES - Fix paths in CONFIGURE_ARGS which refer files from other ports - Support stage - Bump PORTREVISION for package change PR: ports/187007 Submitted by: Koichiro IWAO <meta+ports@vmeta.jp> (maintainer) Obtained from: http://sourceforge.net/p/tigervnc/code/5161/ [1]
Diffstat (limited to 'net')
-rw-r--r--net/tigervnc/Makefile36
-rw-r--r--net/tigervnc/files/patch-vncviewer-always-built19
-rw-r--r--net/tigervnc/pkg-plist30
3 files changed, 57 insertions, 28 deletions
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index 8623a6f57ab5..6129ebeb1308 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tigervnc
PORTVERSION= 1.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net x11-servers
MASTER_SITES= SF:tigervnc
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}/:tigervnc
@@ -38,11 +38,6 @@ USE_XORG+= bigreqsproto compositeproto damageproto fixesproto fontsproto glproto
scrnsaverproto videoproto xau xdmcp xext xkbfile xcmiscproto xextproto \
xfont xproto xrandr xtrans xtst xorg-macros
-MAN1+= vncpasswd.1 \
- x0vncserver.1 \
- vncserver.1 \
- vncconfig.1 \
- Xvnc.1
CFLAGS+= -fPIC
OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER HPJPG
@@ -50,10 +45,9 @@ OPTIONS_DEFAULT= GNUTLS NLS PAM VIEWER
VIEWER_DESC= Build vncviewer
HPJPG_DESC= Build with High-Performance JPEG support
-NO_STAGE= yes
.include <bsd.port.options.mk>
-CMAKE_ARGS= -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=${PREFIX}
+CMAKE_ARGS= -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=${STAGE}${PREFIX}
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= libtasn1.so:${PORTSDIR}/security/libtasn1 \
@@ -82,17 +76,18 @@ CMAKE_ARGS+= -DENABLE_PAM=0
.endif
.if ${PORT_OPTIONS:MVIEWER}
-CMAKE_ARGS+= -DENABLE_VIEWER=1
+CMAKE_ARGS+= -DBUILD_VIEWER=1
LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
libfltk.so:${PORTSDIR}/x11-toolkits/fltk
+# ImageMagick is required to generate icons during build process
+BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
USE_XORG+= xcursor xfixes xft xinerama
-MAN1+= vncviewer.1
PLIST_SUB+= VIEWER=""
INSTALLS_ICONS= yes
DESKTOP_ENTRIES= "TigerVNC viewer" "Connect to VNC server and display remote desktop" \
- "${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg" \
- "vncviewer" "Network;" false
+ "${PORTNAME}" "vncviewer" "Network;" false
.else
+CMAKE_ARGS+= -DBUILD_VIEWER=0
PLIST_SUB+= VIEWER="@comment "
.endif
@@ -111,16 +106,15 @@ CONFIGURE_ARGS+= \
--disable-dmx --disable-xwin --disable-xephyr --disable-kdrive \
--disable-config-dbus --disable-config-hal \
--disable-dri2 --enable-install-libxf86config --enable-glx \
- --with-default-font-path="catalogue:${PREFIX}/share/fonts,built-ins" \
- --with-xkb-path=${PREFIX}/share/X11/xkb \
- --with-xkb-output=/var/lib/xkb \
- --with-xkb-bin-directory=${PREFIX}/bin \
- --with-serverconfig-path=${PREFIX}/lib/X11 \
+ --with-default-font-path="catalogue:${LOCALBASE}/share/fonts,built-ins" \
+ --with-xkb-path=${LOCALBASE}/share/X11/xkb \
+ --with-xkb-bin-directory=${LOCALBASE}/bin \
+ --with-serverconfig-path=${LOCALBASE}/lib/X11 \
--disable-selective-werror
.ifdef WITH_NEW_XORG
-CONFIGURE_ARGS+= --with-fontrootdir=${PREFIX}/share/fonts
+CONFIGURE_ARGS+= --with-fontrootdir=${LOCALBASE}/share/fonts
.else
-CONFIGURE_ARGS+= --with-fontdir=${PREFIX}/share/fonts
+CONFIGURE_ARGS+= --with-fontdir=${LOCALBASE}/share/fonts
.endif
.include <bsd.port.pre.mk>
@@ -156,9 +150,5 @@ post-build:
post-install:
@cd ${WRKSRC}/unix/xserver/hw/vnc/ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install
-.if ${PORT_OPTIONS:MVIEWER}
- @${MKDIR} ${PREFIX}/share/icons/hicolor/scalable/apps/
- @cd ${WRKSRC}/media/ && ${INSTALL_DATA} icons/tigervnc.svg ${PREFIX}/share/icons/hicolor/scalable/apps/
-.endif
.include <bsd.port.post.mk>
diff --git a/net/tigervnc/files/patch-vncviewer-always-built b/net/tigervnc/files/patch-vncviewer-always-built
new file mode 100644
index 000000000000..7d4978b74808
--- /dev/null
+++ b/net/tigervnc/files/patch-vncviewer-always-built
@@ -0,0 +1,19 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 5159)
++++ CMakeLists.txt (working copy)
+@@ -390,9 +390,12 @@
+ add_subdirectory(po)
+ endif()
+
+-add_subdirectory(vncviewer)
++option(BUILD_VIEWER "Build TigerVNC viewer" ON)
++if(BUILD_VIEWER)
++ add_subdirectory(vncviewer)
++ add_subdirectory(media)
++endif()
+
+-add_subdirectory(media)
+
+ include(cmake/BuildPackages.cmake)
+
diff --git a/net/tigervnc/pkg-plist b/net/tigervnc/pkg-plist
index 5ce98c6cc803..f94e8eaa7bbf 100644
--- a/net/tigervnc/pkg-plist
+++ b/net/tigervnc/pkg-plist
@@ -3,23 +3,43 @@ bin/vncconfig
bin/vncpasswd
bin/vncserver
%%VIEWER%%bin/vncviewer
-%%VIEWER%%share/icons/hicolor/scalable/apps/tigervnc.svg
bin/x0vncserver
lib/xorg/modules/extensions/libvnc.la
lib/xorg/modules/extensions/libvnc.so
+man/man1/vncpasswd.1.gz
+man/man1/x0vncserver.1.gz
+man/man1/vncserver.1.gz
+man/man1/vncconfig.1.gz
+man/man1/Xvnc.1.gz
+%%VIEWER%%man/man1/vncviewer.1.gz
%%NLS%%share/locale/de/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/fr/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/pl/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/ru/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sk/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/tigervnc.mo
-%%DOCSDIR%%/README.txt
-%%DOCSDIR%%/LICENCE.TXT
-@dirrm %%DOCSDIR%%
-@unexec %D/%%DOCSDIR%% 2>/dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENCE.TXT
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry lib/xorg/modules/extensions
@dirrmtry lib/xorg/modules
@dirrmtry lib/xorg
+%%VIEWER%%share/icons/hicolor/16x16/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/22x22/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/24x24/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/32x32/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/48x48/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/scalable/apps/tigervnc.svg
+%%VIEWER%%@dirrmtry share/icons/hicolor/48x48/apps
+%%VIEWER%%@dirrmtry share/icons/hicolor/48x48
+%%VIEWER%%@dirrmtry share/icons/hicolor/32x32/apps
+%%VIEWER%%@dirrmtry share/icons/hicolor/32x32
+%%VIEWER%%@dirrmtry share/icons/hicolor/24x24/apps
+%%VIEWER%%@dirrmtry share/icons/hicolor/24x24
+%%VIEWER%%@dirrmtry share/icons/hicolor/22x22/apps
+%%VIEWER%%@dirrmtry share/icons/hicolor/22x22
+%%VIEWER%%@dirrmtry share/icons/hicolor/16x16/apps
+%%VIEWER%%@dirrmtry share/icons/hicolor/16x16
%%VIEWER%%@dirrmtry share/icons/hicolor/scalable/apps
%%VIEWER%%@dirrmtry share/icons/hicolor/scalable
%%VIEWER%%@dirrmtry share/icons/hicolor