aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2015-12-02 13:35:50 +0800
committerdelphij <delphij@FreeBSD.org>2015-12-02 13:35:50 +0800
commitb882e5c74817cac43dc3f6c940b9d659cdeccf00 (patch)
tree25848842fe89e2531567a1bdb0ecdb689c40d80c /net
parent9522610a0c808075e61bb49b86aa199c2c08da13 (diff)
downloadfreebsd-ports-gnome-b882e5c74817cac43dc3f6c940b9d659cdeccf00.tar.gz
freebsd-ports-gnome-b882e5c74817cac43dc3f6c940b9d659cdeccf00.tar.zst
freebsd-ports-gnome-b882e5c74817cac43dc3f6c940b9d659cdeccf00.zip
Update OpenLDAP to 2.4.43.
While there, revert previous NDEBUG behavior for non-debug builds. MFH: 2015Q4
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile23
-rw-r--r--net/openldap24-server/distinfo4
-rw-r--r--net/openldap24-server/files/patch-CVE-2015-690811
3 files changed, 12 insertions, 26 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 79703666635a..369a89b543d0 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openldap
-DISTVERSION= 2.4.42
+DISTVERSION= 2.4.43
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -56,10 +56,10 @@ WANT_OPENLDAP_VER?= 24
BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
-PORTREVISION_CLIENT= 2
-PORTREVISION_SERVER= 2
+PORTREVISION_CLIENT= 0
+PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 2
-OPENLDAP_SHLIB_MINOR= 10.5
+OPENLDAP_SHLIB_MINOR= 10.6
OPENLDAP_MAJOR= ${DISTVERSION:R}
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
@@ -189,15 +189,6 @@ CONFIGURE_ARGS= --with-threads=posix \
# XXX FreeBSD does not implement O_DSYNC and fdatasync at this time.
CFLAGS+= -DMDB_DSYNC=O_SYNC -Dfdatasync=fsync
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug=yes
-.else
-CONFIGURE_ARGS+= --disable-debug
-CFLAGS+= -DNDEBUG
-.endif
-
-MAKE_ENV+= STRIP=${STRIP}
-
.if !${PORT_OPTIONS:MFETCH}
CONFIGURE_ARGS+= --without-fetch
.endif
@@ -283,6 +274,12 @@ CONFIGURE_ARGS+= --enable-constraint=${OVERLAY_ENABLE}
CONFIGURE_ARGS+= --enable-dds=${OVERLAY_ENABLE}
.endif
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+= --enable-debug=yes
+.endif
+
+MAKE_ENV+= STRIP=${STRIP}
+
.if ${PORT_OPTIONS:MDEREF}
CONFIGURE_ARGS+= --enable-deref=${OVERLAY_ENABLE}
.endif
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 1c0f790eb646..c2bea7d10d65 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openldap-2.4.42.tgz) = eeb7b0e2c5852bfd2650e83909bb6152835c0b862fab10b63954dc1bcbba8e63
-SIZE (openldap-2.4.42.tgz) = 5645925
+SHA256 (openldap-2.4.43.tgz) = 34d78e5598a2b0360d26a9050fcdbbe198c65493b013bb607839d5598b6978c8
+SIZE (openldap-2.4.43.tgz) = 5654057
diff --git a/net/openldap24-server/files/patch-CVE-2015-6908 b/net/openldap24-server/files/patch-CVE-2015-6908
deleted file mode 100644
index 5b64e6010e84..000000000000
--- a/net/openldap24-server/files/patch-CVE-2015-6908
+++ /dev/null
@@ -1,11 +0,0 @@
---- libraries/liblber/io.c.orig 2015-08-14 15:25:28 UTC
-+++ libraries/liblber/io.c
-@@ -679,7 +679,7 @@ done:
- return (ber->ber_tag);
- }
-
-- assert( 0 ); /* ber structure is messed up ?*/
-+ /* invalid input */
- return LBER_DEFAULT;
- }
-