aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-02-08 03:40:36 +0800
committerJason Helfman <jgh@FreeBSD.org>2013-02-08 03:40:36 +0800
commitb9639e84163520c91d1c3e19aec0a7b35e5b5a78 (patch)
tree0ce9fadac7ce5784900c3147989d4febdfe4528a /net
parentec9949ae2bf8b41fabd4c0830509319e6a10206c (diff)
downloadfreebsd-ports-gnome-b9639e84163520c91d1c3e19aec0a7b35e5b5a78.tar.gz
freebsd-ports-gnome-b9639e84163520c91d1c3e19aec0a7b35e5b5a78.tar.zst
freebsd-ports-gnome-b9639e84163520c91d1c3e19aec0a7b35e5b5a78.zip
- update to 1.8
- while here trim historical header, adopt optionsNG PR: 175928 Submitted by: maintainer, squat@squat.no
Diffstat (limited to 'net')
-rw-r--r--net/miniupnpd/Makefile21
-rw-r--r--net/miniupnpd/distinfo4
-rw-r--r--net/miniupnpd/files/patch-Makefile24
-rw-r--r--net/miniupnpd/files/patch-genconfig.sh35
4 files changed, 13 insertions, 71 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 85c4aaa558aa..fe9b27e1eaab 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: miniupnpd
-# Date created: 22 March 2007
-# Whom: Daniel O'Connor <darius@dons.net.au>
-#
+# Created by: Daniel O'Connor <darius@dons.net.au>
# $FreeBSD$
-#
PORTNAME= miniupnpd
-PORTVERSION= 1.7
+PORTVERSION= 1.8
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -27,17 +23,22 @@ MAN8= miniupnpd.8
USE_RC_SUBR= miniupnpd
-OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off
+OPTIONS_DEFINE= PF_ENABLE_FILTER_RULES
+PF_ENABLE_FILTER_RULES_DESC= Enable pf generation of filter rules
.include <bsd.port.options.mk>
-.if defined(WITH_PF_ENABLE_FILTER_RULES)
+.if ${PORT_OPTIONS:MWITH_PF_ENABLE_FILTER_RULES}
EXTRA_PATCHES= ${PATCHDIR}/pf_enable_filter_rules.patch
.endif
+post-patch-script:
+ @${REINPLACE_CMD} 's|CFLAGS ?= -pipe -Os|CFLAGS ?= -pipe|' \
+ ${WRKSRC}/Makefile
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${PREFIX}/sbin/miniupnpd
+ @${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample ${PREFIX}/etc/miniupnpd.conf.sample
- @${INSTALL_MAN} ${WRKSRC}/miniupnpd.1 ${PREFIX}/man/man8/miniupnpd.8
+ @${INSTALL_MAN} ${WRKSRC}/miniupnpd.8 ${MAN8PREFIX}/man/man8/miniupnpd.8
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
index d936b65ff1cf..7e1eeb3ebbf7 100644
--- a/net/miniupnpd/distinfo
+++ b/net/miniupnpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (miniupnpd-1.7.tar.gz) = 27cfacea0a2aefc109b44497b756bf3e4ab9f92beb55fc492b09df5c46c6bb74
-SIZE (miniupnpd-1.7.tar.gz) = 138047
+SHA256 (miniupnpd-1.8.tar.gz) = e453a9225a2883e759d09e15c51bb0265b8a019d1132434131e6929fef0076bb
+SIZE (miniupnpd-1.8.tar.gz) = 146679
diff --git a/net/miniupnpd/files/patch-Makefile b/net/miniupnpd/files/patch-Makefile
deleted file mode 100644
index d3b820fac183..000000000000
--- a/net/miniupnpd/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.orig 2012-05-30 10:27:24.587226775 +0200
-+++ Makefile 2012-05-30 10:28:12.497226510 +0200
-@@ -15,7 +15,7 @@
- # $ CONFIG_OPTIONS="--ipv6 --igd2" make
- #
-
--CFLAGS ?= -pipe -Os
-+CFLAGS ?= -pipe
- #CFLAGS = -pipe -O -g -DDEBUG
- CFLAGS += -ansi
- CFLAGS += -Wall
-@@ -43,10 +43,12 @@
-
- # better way to find if we are using ipf or pf
- .if $(OSNAME) == "FreeBSD"
-+.if defined(/etc/rc.subr) && defined(/etc/rc.conf)
- FWNAME != . /etc/rc.subr; . /etc/rc.conf; \
- if checkyesno ipfilter_enable; then \
- echo "ipf"; else echo "pf"; fi
- .endif
-+.endif
-
- .if $(OSNAME) == "NetBSD"
- FWNAME != . /etc/rc.subr; . /etc/rc.conf; \
diff --git a/net/miniupnpd/files/patch-genconfig.sh b/net/miniupnpd/files/patch-genconfig.sh
deleted file mode 100644
index ecbc3a4f1690..000000000000
--- a/net/miniupnpd/files/patch-genconfig.sh
+++ /dev/null
@@ -1,35 +0,0 @@
---- genconfig.sh.orig 2012-05-24 20:05:47.000000000 +0200
-+++ genconfig.sh 2012-05-30 20:12:57.685877655 +0200
-@@ -112,18 +112,20 @@
- # new way to see which one to use PF or IPF.
- # see http://miniupnp.tuxfamily.org/forum/viewtopic.php?p=957
- # source file with handy subroutines like checkyesno
-- . /etc/rc.subr
-- # source config file so we can probe vars
-- . /etc/rc.conf
-- if checkyesno ipfilter_enable; then
-- echo "Using ipf"
-- FW=ipf
-- elif checkyesno pf_enable; then
-- echo "Using pf"
-- FW=pf
-- elif checkyesno firewall_enable; then
-- echo "Using ifpw"
-- FW=ipfw
-+ if [ -f /etc/rc.subr ] && [ -f /etc/rc.conf ]; then
-+ . /etc/rc.subr
-+ # source config file so we can probe vars
-+ . /etc/rc.conf
-+ if checkyesno ipfilter_enable; then
-+ echo "Using ipf"
-+ FW=ipf
-+ elif checkyesno pf_enable; then
-+ echo "Using pf"
-+ FW=pf
-+ elif checkyesno firewall_enable; then
-+ echo "Using ifpw"
-+ FW=ipfw
-+ fi
- else
- echo "Could not detect usage of ipf, pf, ipfw. Compiling for pf by default"
- FW=pf