aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-10-07 20:39:06 +0800
committeroliver <oliver@FreeBSD.org>2005-10-07 20:39:06 +0800
commitbc268b0c68f8e7e0db57b5d18ec11857d09fa088 (patch)
tree8469e249b310b75d24c59c1f4f8c1c684151fbc9 /net
parentcbfd4f4ed4d48777a1ddfff1dd18ba74cea8fb12 (diff)
downloadfreebsd-ports-gnome-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.tar.gz
freebsd-ports-gnome-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.tar.zst
freebsd-ports-gnome-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.zip
upgrade to 0.5.1
mark as IGNORE for FreeBSD below 5 (0.5.0 also didn't compiled on <5)
Diffstat (limited to 'net')
-rw-r--r--net/cyphesis/Makefile18
-rw-r--r--net/cyphesis/distinfo4
-rw-r--r--net/cyphesis/files/patch-client-ClientConnection.cpp20
-rw-r--r--net/cyphesis/files/patch-common-system.cpp17
-rw-r--r--net/cyphesis/files/patch-server-CommClient.cpp29
-rw-r--r--net/cyphesis/files/patch-tools-AdminClient.cpp20
-rw-r--r--net/cyphesis/files/patch-tools-cycmd.cpp20
7 files changed, 16 insertions, 112 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 985cfab9e3be..a1ec300ccc3f 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= cyphesis
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.5.1
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=worldforge
@@ -16,7 +16,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= A server for WorldForge games
LIB_DEPENDS= Atlas-0.6.0:${PORTSDIR}/devel/atlas-devel \
- varconf-1.0.4:${PORTSDIR}/devel/varconf \
+ varconf-1.0.5:${PORTSDIR}/devel/varconf \
wfmath-0.3.3:${PORTSDIR}/math/wfmath \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
skstream-0.3.3:${PORTSDIR}/net/skstream \
@@ -36,12 +36,22 @@ USE_GNOME= gnomehack
MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
@${REINPLACE_CMD} -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/server/CommMDNSPublisher.h
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -55,4 +65,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/cyphesis/distinfo b/net/cyphesis/distinfo
index 2e24a84aaa48..8d3ee67eb4f6 100644
--- a/net/cyphesis/distinfo
+++ b/net/cyphesis/distinfo
@@ -1,2 +1,2 @@
-MD5 (cyphesis-0.5.0.tar.bz2) = b55acc85575efd401f8cb2c233dafe81
-SIZE (cyphesis-0.5.0.tar.bz2) = 549759
+MD5 (cyphesis-0.5.1.tar.bz2) = fb91e6fefb247e0b800cc5d960f8f585
+SIZE (cyphesis-0.5.1.tar.bz2) = 551320
diff --git a/net/cyphesis/files/patch-client-ClientConnection.cpp b/net/cyphesis/files/patch-client-ClientConnection.cpp
deleted file mode 100644
index 7d2f5ca5da7f..000000000000
--- a/net/cyphesis/files/patch-client-ClientConnection.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- client/ClientConnection.cpp.orig Sun Oct 2 18:13:33 2005
-+++ client/ClientConnection.cpp Sun Oct 2 18:13:55 2005
-@@ -172,7 +172,7 @@
-
- int ClientConnection::negotiate()
- {
-- Atlas::Net::StreamConnect conn("cyphesis_aiclient", ios, *this);
-+ Atlas::Net::StreamConnect conn("cyphesis_aiclient", ios);
-
- debug(std::cout << "Negotiating... " << std::flush;);
- while (conn.getState() == Atlas::Net::StreamConnect::IN_PROGRESS) {
-@@ -185,7 +185,7 @@
- return -1;
- }
-
-- codec = conn.getCodec();
-+ codec = conn.getCodec(*this);
-
- encoder = new Atlas::Objects::ObjectsEncoder(*codec);
-
diff --git a/net/cyphesis/files/patch-common-system.cpp b/net/cyphesis/files/patch-common-system.cpp
deleted file mode 100644
index 3f23278df2a7..000000000000
--- a/net/cyphesis/files/patch-common-system.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- common/system.cpp.orig Sun Oct 2 17:42:56 2005
-+++ common/system.cpp Sun Oct 2 17:43:29 2005
-@@ -74,6 +74,14 @@
- #endif
- }
-
-+#ifndef SA_ONESHOT
-+# ifdef SA_RESETHAND
-+# define SA_ONESHOT SA_RESETHAND
-+# else
-+# define SA_ONESHOT 0
-+# endif
-+#endif
-+
- void interactive_signals()
- {
- #if defined(HAVE_SIGACTION)
diff --git a/net/cyphesis/files/patch-server-CommClient.cpp b/net/cyphesis/files/patch-server-CommClient.cpp
deleted file mode 100644
index d4710f217c2b..000000000000
--- a/net/cyphesis/files/patch-server-CommClient.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- server/CommClient.cpp.orig Sun Oct 2 18:09:37 2005
-+++ server/CommClient.cpp Sun Oct 2 18:11:05 2005
-@@ -28,7 +28,7 @@
- {
- m_clientIos.setTimeout(0,1000);
-
-- m_negotiate = new Atlas::Net::StreamAccept("cyphesis " + m_commServer.m_server.getName(), m_clientIos, *this);
-+ m_negotiate = new Atlas::Net::StreamAccept("cyphesis " + m_commServer.m_server.getName(), m_clientIos);
- }
-
- CommClient::CommClient(CommServer & svr, BaseEntity & c) :
-@@ -38,7 +38,7 @@
- {
- m_clientIos.setTimeout(0,1000);
-
-- m_negotiate = new Atlas::Net::StreamConnect("cyphesis " + m_commServer.m_server.getName(), m_clientIos, *this);
-+ m_negotiate = new Atlas::Net::StreamConnect("cyphesis " + m_commServer.m_server.getName(), m_clientIos);
- }
-
- CommClient::~CommClient()
-@@ -85,7 +85,7 @@
- // Negotiation was successful
-
- // Get the codec that negotiation established
-- m_codec = m_negotiate->getCodec();
-+ m_codec = m_negotiate->getCodec(*this);
-
- // Create a new encoder to send high level objects to the codec
- m_encoder = new Atlas::Objects::ObjectsEncoder(*m_codec);
diff --git a/net/cyphesis/files/patch-tools-AdminClient.cpp b/net/cyphesis/files/patch-tools-AdminClient.cpp
deleted file mode 100644
index 9f3525788217..000000000000
--- a/net/cyphesis/files/patch-tools-AdminClient.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/AdminClient.cpp.orig Sun Oct 2 18:16:32 2005
-+++ tools/AdminClient.cpp Sun Oct 2 18:16:51 2005
-@@ -408,7 +408,7 @@
- int AdminClient::negotiate()
- {
- // Do client negotiation with the server
-- Atlas::Net::StreamConnect conn("cycmd", *ios, *this);
-+ Atlas::Net::StreamConnect conn("cycmd", *ios);
-
- while (conn.getState() == Atlas::Negotiate::IN_PROGRESS) {
- // conn.poll() does all the negotiation
-@@ -423,7 +423,7 @@
- // Negotiation was successful
-
- // Get the codec that negotiation established
-- codec = conn.getCodec();
-+ codec = conn.getCodec(*this);
-
- // Create the encoder
- encoder = new Atlas::Objects::ObjectsEncoder(*codec);
diff --git a/net/cyphesis/files/patch-tools-cycmd.cpp b/net/cyphesis/files/patch-tools-cycmd.cpp
deleted file mode 100644
index ede187aa0a7b..000000000000
--- a/net/cyphesis/files/patch-tools-cycmd.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/cycmd.cpp.orig Sun Oct 2 18:15:03 2005
-+++ tools/cycmd.cpp Sun Oct 2 18:15:34 2005
-@@ -589,7 +589,7 @@
- int Interactive<Stream>::negotiate()
- {
- // Do client negotiation with the server
-- Atlas::Net::StreamConnect conn("cycmd", ios, *this);
-+ Atlas::Net::StreamConnect conn("cycmd", ios);
-
- std::cout << "Negotiating... " << std::flush;
- while (conn.getState() == Atlas::Negotiate::IN_PROGRESS) {
-@@ -606,7 +606,7 @@
- // Negotiation was successful
-
- // Get the codec that negotiation established
-- codec = conn.getCodec();
-+ codec = conn.getCodec(*this);
-
- // Create the encoder
- encoder = new Atlas::Objects::ObjectsEncoder(*codec);