aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-04 16:27:19 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-04 16:27:19 +0800
commitbda712ddf04eb15f015706f16a82c0b974f4e5b5 (patch)
tree2f8bbdffc881bbfca748896b79a96d5865ca779d /net
parent71052f98621be79bd9f6681380a19367fdbf3794 (diff)
downloadfreebsd-ports-gnome-bda712ddf04eb15f015706f16a82c0b974f4e5b5.tar.gz
freebsd-ports-gnome-bda712ddf04eb15f015706f16a82c0b974f4e5b5.tar.zst
freebsd-ports-gnome-bda712ddf04eb15f015706f16a82c0b974f4e5b5.zip
- Update to 0.2
Note that maintainer requested author to release new version (Jan '12) as 0.2. PR: ports/168916 Submitted by: sunpoet (myself) Approved by: Josh Carroll <josh.carroll@gmail.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/shaperprobe/Makefile4
-rw-r--r--net/shaperprobe/distinfo4
-rw-r--r--net/shaperprobe/files/patch-diffprobe.h6
-rw-r--r--net/shaperprobe/files/patch-prober.c54
4 files changed, 39 insertions, 29 deletions
diff --git a/net/shaperprobe/Makefile b/net/shaperprobe/Makefile
index a9ad9f15da56..558af0e925d8 100644
--- a/net/shaperprobe/Makefile
+++ b/net/shaperprobe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= shaperprobe
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= net
MASTER_SITES= http://www.cc.gatech.edu/~partha/diffprobe/
DISTNAME= ${PORTNAME}
@@ -21,6 +21,6 @@ MAKEFILE= Makefile.osx
PLIST_FILES= bin/prober
do-install:
- @${INSTALL} ${WRKSRC}/prober ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/prober ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/net/shaperprobe/distinfo b/net/shaperprobe/distinfo
index 0355ffb5af14..be61752c7f8d 100644
--- a/net/shaperprobe/distinfo
+++ b/net/shaperprobe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (shaperprobe.tgz) = 9b19cd96f987dad9a90873342325b5921537848ce8082af8a6798d79f49dffd6
-SIZE (shaperprobe.tgz) = 16455
+SHA256 (shaperprobe.tgz) = 0d978a0e6bd978c5ee4a47a0c38e31d07ac0def87a92ecd03a9d9d3951a63e6d
+SIZE (shaperprobe.tgz) = 16387
diff --git a/net/shaperprobe/files/patch-diffprobe.h b/net/shaperprobe/files/patch-diffprobe.h
index 51b0ffbd95aa..882708858d13 100644
--- a/net/shaperprobe/files/patch-diffprobe.h
+++ b/net/shaperprobe/files/patch-diffprobe.h
@@ -1,12 +1,12 @@
---- ./diffprobe.h.orig 2009-12-01 12:47:55.000000000 -0800
-+++ ./diffprobe.h 2011-06-11 10:51:08.000000000 -0700
+--- diffprobe.h.orig 2012-01-25 04:33:22.000000000 +0800
++++ diffprobe.h 2012-06-07 16:32:41.050222578 +0800
@@ -26,6 +26,8 @@
#ifndef _DIFFPROBE_H_
#define _DIFFPROBE_H_
+#include <netinet/in.h>
+
- #define VERSION 3
+ #define VERSION 4
#define RATE_FACTOR 0.9
#define RATE_DROP_FACTOR 2
@@ -69,7 +71,7 @@
diff --git a/net/shaperprobe/files/patch-prober.c b/net/shaperprobe/files/patch-prober.c
index 5c32f00eaea8..c1e1856c9d00 100644
--- a/net/shaperprobe/files/patch-prober.c
+++ b/net/shaperprobe/files/patch-prober.c
@@ -1,5 +1,5 @@
---- ./prober.c.orig 2009-11-29 00:47:46.000000000 -0800
-+++ ./prober.c 2011-06-11 10:51:08.000000000 -0700
+--- prober.c.orig 2012-01-25 04:33:22.000000000 +0800
++++ prober.c 2012-06-07 16:37:14.013216127 +0800
@@ -34,6 +34,8 @@
#include <stdlib.h>
#include <string.h>
@@ -9,37 +9,47 @@
#define __FAVOR_BSD /* For compilation in Linux. */
#include <netinet/in.h>
#include <netinet/udp.h>
-@@ -356,27 +358,27 @@
- //XXX: the meas code needs trains and lower cpu
+@@ -357,27 +359,27 @@
+ //following two lines for 802.11a/b/g/n links
if(capacityup < 80000) capacityup = measupcap;
if(capacitydown < 80000) capacitydown = measdowncap;
-- if(capacityup > 100000)
-+ /* if(capacityup > 100000)
- {
- printf("Upstream: greater than 100 Mbps.\n");
- capacityup = 95000;
- }
- else
+- if(capacityup > 200000)
- {
-+ { */
+- printf("Upstream: greater than 200 Mbps.\n");
+- capacityup = 195000;
+- }
+- else
+- {
++// if(capacityup > 200000)
++// {
++// printf("Upstream: greater than 200 Mbps.\n");
++// capacityup = 195000;
++// }
++// else
++// {
printf("Upstream: %d Kbps.\n", (int)capacityup);
// capacityup *= 0.95; //reduce loss-based aborts
- }
-+ /* } */
++// }
truecapup = capacityup;
-- if(capacitydown > 100000)
-+ /* if(capacitydown > 100000)
- {
- printf("Downstream: greater than 100 Mbps.\n");
- capacitydown = 95000;
- }
- else
+- if(capacitydown > 200000)
+- {
+- printf("Downstream: greater than 200 Mbps.\n");
+- capacitydown = 195000;
+- }
+- else
- {
-+ { */
++// if(capacitydown > 200000)
++// {
++// printf("Downstream: greater than 200 Mbps.\n");
++// capacitydown = 195000;
++// }
++// else
++// {
printf("Downstream: %d Kbps.\n", (int)capacitydown);
// capacitydown *= 0.95; //reduce loss-based aborts
- }
-+ /* } */
++// }
truecapdown = capacitydown;
printf("\nThe measurement will last for about %.1f minutes. Please wait.\n",