aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 21:14:48 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 21:14:48 +0800
commitc011d97e196f1c58e8cb0ee6be909e572ba287d8 (patch)
tree31486505f8f7320e0343224db7c4eb72e65a29a0 /net
parentacd53a4149acfc32e1f4b2db13a91c210f2083bf (diff)
downloadfreebsd-ports-gnome-c011d97e196f1c58e8cb0ee6be909e572ba287d8.tar.gz
freebsd-ports-gnome-c011d97e196f1c58e8cb0ee6be909e572ba287d8.tar.zst
freebsd-ports-gnome-c011d97e196f1c58e8cb0ee6be909e572ba287d8.zip
- Support staging
- Respect CFLAGS - Don't build with debug symbols
Diffstat (limited to 'net')
-rw-r--r--net/dhcpdump/Makefile8
-rw-r--r--net/dhcpdump/files/patch-Makefile8
2 files changed, 11 insertions, 5 deletions
diff --git a/net/dhcpdump/Makefile b/net/dhcpdump/Makefile
index dba30bd7a5d8..587021834552 100644
--- a/net/dhcpdump/Makefile
+++ b/net/dhcpdump/Makefile
@@ -9,15 +9,13 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Decode and diagnose sniffed DHCP packets
-MAN8= dhcpdump.8
-PLIST_FILES= bin/dhcpdump
+PLIST_FILES= bin/dhcpdump man/man8/dhcpdump.8.gz
USES= perl5
USE_PERL5= build
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dhcpdump ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/dhcpdump.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/dhcpdump ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dhcpdump.8 ${STAGEDIR}${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/net/dhcpdump/files/patch-Makefile b/net/dhcpdump/files/patch-Makefile
new file mode 100644
index 000000000000..8016381d26f2
--- /dev/null
+++ b/net/dhcpdump/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- ./Makefile.orig 2014-02-26 14:13:07.131955471 +0100
++++ ./Makefile 2014-02-26 14:13:21.108957821 +0100
+@@ -1,5 +1,3 @@
+-CFLAGS= -Wall -g
+-LDFLAGS= -g
+ LIBS= -lpcap
+
+ all: dhcpdump dhcpdump.8