aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-01-16 08:42:00 +0800
committercpm <cpm@FreeBSD.org>2018-01-16 08:42:00 +0800
commitc128f1d6b163202223473143cd66b2997c929b10 (patch)
tree852913cce4a618147d189fcc5f46beb07fdd146c /net
parentff3c3ff37853cf485e77701b8c6b465ca1e03944 (diff)
downloadfreebsd-ports-gnome-c128f1d6b163202223473143cd66b2997c929b10.tar.gz
freebsd-ports-gnome-c128f1d6b163202223473143cd66b2997c929b10.tar.zst
freebsd-ports-gnome-c128f1d6b163202223473143cd66b2997c929b10.zip
- Unbreak build with Clang 6
- Rework patches to push the code upstream - Fix WWW in pkg-descr - Pet portlint Reported by: pkg-fallout
Diffstat (limited to 'net')
-rw-r--r--net/grive2/Makefile4
-rw-r--r--net/grive2/files/patch-grive_CMakeLists.txt9
-rw-r--r--net/grive2/files/patch-libgrive_CMakeLists.txt13
-rw-r--r--net/grive2/files/patch-libgrive_src_util_File.cc11
-rw-r--r--net/grive2/pkg-descr2
5 files changed, 30 insertions, 9 deletions
diff --git a/net/grive2/Makefile b/net/grive2/Makefile
index b5741d398ebc..228e1cc8ba9d 100644
--- a/net/grive2/Makefile
+++ b/net/grive2/Makefile
@@ -22,11 +22,11 @@ LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
CONFLICTS_INSTALL= grive-[0-9]*
+USES= cmake pkgconfig localbase
+
USE_GITHUB= yes
GH_ACCOUNT= vitalif
-USES= cmake pkgconfig localbase
-
PLIST_FILES= bin/grive \
man/man1/grive.1.gz
diff --git a/net/grive2/files/patch-grive_CMakeLists.txt b/net/grive2/files/patch-grive_CMakeLists.txt
index 09bd5176da48..b577efe95481 100644
--- a/net/grive2/files/patch-grive_CMakeLists.txt
+++ b/net/grive2/files/patch-grive_CMakeLists.txt
@@ -1,8 +1,13 @@
--- grive/CMakeLists.txt.orig 2016-01-14 20:51:31 UTC
+++ grive/CMakeLists.txt
-@@ -26,4 +26,4 @@ set_target_properties( grive_executable
+@@ -26,4 +26,9 @@ set_target_properties( grive_executable
)
install(TARGETS grive_executable RUNTIME DESTINATION bin)
-install(FILES doc/grive.1 DESTINATION share/man/man1 )
-+install(FILES doc/grive.1 DESTINATION man/man1 )
++
++if ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )
++ install(FILES doc/grive.1 DESTINATION man/man1 )
++else ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )
++ install(FILES doc/grive.1 DESTINATION share/man/man1 )
++endif( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )
diff --git a/net/grive2/files/patch-libgrive_CMakeLists.txt b/net/grive2/files/patch-libgrive_CMakeLists.txt
new file mode 100644
index 000000000000..ab4c836287aa
--- /dev/null
+++ b/net/grive2/files/patch-libgrive_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- libgrive/CMakeLists.txt.orig 2018-01-15 23:32:17 UTC
++++ libgrive/CMakeLists.txt
+@@ -149,6 +149,10 @@ target_link_libraries( btest
+ ${Boost_LIBRARIES}
+ )
+
++if ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" )
++ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-c++11-narrowing" )
++endif ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" )
++
+ if ( WIN32 )
+ else ( WIN32 )
+ set_target_properties( btest
diff --git a/net/grive2/files/patch-libgrive_src_util_File.cc b/net/grive2/files/patch-libgrive_src_util_File.cc
index 293a2eef42fe..2910f9f876c7 100644
--- a/net/grive2/files/patch-libgrive_src_util_File.cc
+++ b/net/grive2/files/patch-libgrive_src_util_File.cc
@@ -1,10 +1,13 @@
---- libgrive/src/util/File.cc.orig 2016-08-28 12:56:18 UTC
+--- libgrive/src/util/File.cc.orig 2016-01-14 20:51:31 UTC
+++ libgrive/src/util/File.cc
-@@ -32,6 +32,7 @@
- #include <sys/stat.h>
+@@ -33,6 +33,10 @@
#include <sys/types.h>
#include <fcntl.h>
-+#include <unistd.h>
++#if defined(__FreeBSD__) || defined(__OpenBSD__)
++#include <unistd.h>
++#endif
++
#ifdef WIN32
#include <io.h>
+ typedef int ssize_t ;
diff --git a/net/grive2/pkg-descr b/net/grive2/pkg-descr
index 40b7018e6e5b..dd8534722210 100644
--- a/net/grive2/pkg-descr
+++ b/net/grive2/pkg-descr
@@ -1,4 +1,4 @@
Grive2 is the fork of original "Grive" Google Drive client with the
support for the new Drive REST API and partial sync.
-WWW: https://github.com/vitalif/grive2/
+WWW: https://github.com/vitalif/grive2