aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-24 23:00:15 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-24 23:00:15 +0800
commitc1f153c1933b352e5d96de95f63c416f76483f8d (patch)
tree88f2027fd26578d130551b8d4f15e028fc72eafc /net
parent45c16638a7dbfb402f43fb6806ed24deea0874b7 (diff)
downloadfreebsd-ports-gnome-c1f153c1933b352e5d96de95f63c416f76483f8d.tar.gz
freebsd-ports-gnome-c1f153c1933b352e5d96de95f63c416f76483f8d.tar.zst
freebsd-ports-gnome-c1f153c1933b352e5d96de95f63c416f76483f8d.zip
- Support staging
- Respect CC - Respect CFLAGS - This port does not build with clang, use gcc
Diffstat (limited to 'net')
-rw-r--r--net/shaperprobe/Makefile5
-rw-r--r--net/shaperprobe/files/patch-Makefile.osx12
2 files changed, 15 insertions, 2 deletions
diff --git a/net/shaperprobe/Makefile b/net/shaperprobe/Makefile
index be6d7bb0ca61..c9c7a456d08f 100644
--- a/net/shaperprobe/Makefile
+++ b/net/shaperprobe/Makefile
@@ -13,11 +13,12 @@ COMMENT= Utility to check for traffic shapers
LICENSE= GPLv2
+USE_GCC= yes
+
MAKEFILE= Makefile.osx
PLIST_FILES= bin/prober
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/prober ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/prober ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net/shaperprobe/files/patch-Makefile.osx b/net/shaperprobe/files/patch-Makefile.osx
new file mode 100644
index 000000000000..617fe99b9e10
--- /dev/null
+++ b/net/shaperprobe/files/patch-Makefile.osx
@@ -0,0 +1,12 @@
+--- Makefile.osx.orig 2012-01-24 21:33:22.000000000 +0100
++++ Makefile.osx 2014-02-24 15:57:22.575172070 +0100
+@@ -1,7 +1,7 @@
+
+-CC=gcc
++CC?=gcc
+
+-CFLAGS=-c -Wall -O3 -fno-strict-aliasing -DOSX
++CFLAGS+=-c -DOSX
+ LDFLAGS=-lm
+
+ SOURCES=prober.c tcp_client.c tcpserver.c wrappers.c tbdetect.c measflow.c