aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-14 17:01:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-14 17:01:09 +0800
commitc25020fe6b61a01e242be28aa48fe3cb931efdcb (patch)
treeca6cc1151179ec184a9413240bebe6648b772c50 /net
parenta9b88ee159e43d067a74e397b7f2fccbf6febee9 (diff)
downloadfreebsd-ports-gnome-c25020fe6b61a01e242be28aa48fe3cb931efdcb.tar.gz
freebsd-ports-gnome-c25020fe6b61a01e242be28aa48fe3cb931efdcb.tar.zst
freebsd-ports-gnome-c25020fe6b61a01e242be28aa48fe3cb931efdcb.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'net')
-rw-r--r--net/sendsnpp/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/net/sendsnpp/Makefile b/net/sendsnpp/Makefile
index 54a89e6ee64e..597e80c24144 100644
--- a/net/sendsnpp/Makefile
+++ b/net/sendsnpp/Makefile
@@ -12,16 +12,13 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Tool for sending messages through a RFC1861 compliant SNPP server
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
PLIST_FILES= bin/sendSNPP.pl
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/${PORTNAME}.pl
+SHEBANG_FILES= sendSNPP.pl
do-install:
- cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME}.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>