aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorassar <assar@FreeBSD.org>2001-08-28 21:47:15 +0800
committerassar <assar@FreeBSD.org>2001-08-28 21:47:15 +0800
commitc281852187348841fcb2a42a7740f1c940d6385b (patch)
tree77563bd2b0aa7cfd6fc7a0df3ef00bcab3b5b803 /net
parentf116893da5f79ea5969aa4c63fdacbab6f657b12 (diff)
downloadfreebsd-ports-gnome-c281852187348841fcb2a42a7740f1c940d6385b.tar.gz
freebsd-ports-gnome-c281852187348841fcb2a42a7740f1c940d6385b.tar.zst
freebsd-ports-gnome-c281852187348841fcb2a42a7740f1c940d6385b.zip
patch around crashes for hostnames longer than 15 characters
PR: ports/30159 Approved by: chris@aims.com.au (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/rdesktop-devel/Makefile1
-rw-r--r--net/rdesktop-devel/files/patch-aa12
-rw-r--r--net/rdesktop/Makefile1
-rw-r--r--net/rdesktop/files/patch-aa12
4 files changed, 26 insertions, 0 deletions
diff --git a/net/rdesktop-devel/Makefile b/net/rdesktop-devel/Makefile
index 24663f9decac..6982e3673e78 100644
--- a/net/rdesktop-devel/Makefile
+++ b/net/rdesktop-devel/Makefile
@@ -35,5 +35,6 @@ do-patch:
@${PERL} -pi.orig -e 's:^install.*:install\: rdesktop:g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:<endian.h>:<machine/endian.h>:g' ${WRKSRC}/rdesktop.h
+ @${PATCH} ${PATCH_ARGS} < files/patch-aa
.include <bsd.port.mk>
diff --git a/net/rdesktop-devel/files/patch-aa b/net/rdesktop-devel/files/patch-aa
new file mode 100644
index 000000000000..e9b7e1fb54eb
--- /dev/null
+++ b/net/rdesktop-devel/files/patch-aa
@@ -0,0 +1,12 @@
+--- secure.c~ Mon Aug 27 16:33:56 2001
++++ secure.c Mon Aug 27 16:36:19 2001
+@@ -387,6 +387,9 @@
+ {
+ int hostlen = 2 * ( hostname == 0 ? 0 : strlen (hostname));
+
++ if (hostlen > 30)
++ hostlen = 30;
++
+ out_uint16_be (s, 5); /* unknown */
+ out_uint16_be (s, 0x14);
+ out_uint8 (s, 0x7c);
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 24663f9decac..6982e3673e78 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -35,5 +35,6 @@ do-patch:
@${PERL} -pi.orig -e 's:^install.*:install\: rdesktop:g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:<endian.h>:<machine/endian.h>:g' ${WRKSRC}/rdesktop.h
+ @${PATCH} ${PATCH_ARGS} < files/patch-aa
.include <bsd.port.mk>
diff --git a/net/rdesktop/files/patch-aa b/net/rdesktop/files/patch-aa
new file mode 100644
index 000000000000..e9b7e1fb54eb
--- /dev/null
+++ b/net/rdesktop/files/patch-aa
@@ -0,0 +1,12 @@
+--- secure.c~ Mon Aug 27 16:33:56 2001
++++ secure.c Mon Aug 27 16:36:19 2001
+@@ -387,6 +387,9 @@
+ {
+ int hostlen = 2 * ( hostname == 0 ? 0 : strlen (hostname));
+
++ if (hostlen > 30)
++ hostlen = 30;
++
+ out_uint16_be (s, 5); /* unknown */
+ out_uint16_be (s, 0x14);
+ out_uint8 (s, 0x7c);