aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-08-28 17:40:17 +0800
committermiwi <miwi@FreeBSD.org>2007-08-28 17:40:17 +0800
commitc2b087347be9817dbf89b1fca6f0ca4f388cb175 (patch)
treeeca609b4a4f0da68cb8e1dc0cafa76b5b3a150b3 /net
parentf5b3c3b8732fb33114560a11d9b4d7796de88c5a (diff)
downloadfreebsd-ports-gnome-c2b087347be9817dbf89b1fca6f0ca4f388cb175.tar.gz
freebsd-ports-gnome-c2b087347be9817dbf89b1fca6f0ca4f388cb175.tar.zst
freebsd-ports-gnome-c2b087347be9817dbf89b1fca6f0ca4f388cb175.zip
This package consists of three classes which handles the encoding
and decoding of data in Bittorrent format. You can also extract useful informations from .torrent files, create .torrent files and query the torrent's scrape page to get its statistics. PHP5 only. WWW: http://pear.php.net/package/File_Bittorrent2/ PR: ports/115891 Submitted by: Zhen REN <bg1tpt at gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-File_Bittorrent2/Makefile35
-rw-r--r--net/pear-File_Bittorrent2/distinfo3
-rw-r--r--net/pear-File_Bittorrent2/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e6d61a5e3334..3dc5e75c2a6c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -587,6 +587,7 @@
SUBDIR += pcnfsd
SUBDIR += pdb
SUBDIR += pear-Auth_RADIUS
+ SUBDIR += pear-File_Bittorrent2
SUBDIR += pear-Net_CDDB
SUBDIR += pear-Net_CheckIP
SUBDIR += pear-Net_DIME
diff --git a/net/pear-File_Bittorrent2/Makefile b/net/pear-File_Bittorrent2/Makefile
new file mode 100644
index 000000000000..40a91d5cd736
--- /dev/null
+++ b/net/pear-File_Bittorrent2/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pear-File_Bittorrent2
+# Date created: 28 Aug 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Bittorrent2
+DISTVERSION= 1.0.0RC1
+CATEGORIES= net pear
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Decode and Encode data in Bittorrent format
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= File
+FILES= Bittorrent2/Decode.php Bittorrent2/Encode.php \
+ Bittorrent2/Exception.php Bittorrent2/MakeTorrent.php
+
+_EXAMPLESDIR= .
+EXAMPLES= example.php example_mktorrent.php \
+ install-x86-universal-2005.0.iso.torrent \
+ scrape.php torrentinfo.php
+
+_TESTSDIR= Tests
+TESTS= AllTests.php Bug7406.php Bug8085.php FileBittorrent2.php
+
+post-extract:
+ @ cd ${WRKSRC}/File; ${MV} Bittorrent2 ${WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/net/pear-File_Bittorrent2/distinfo b/net/pear-File_Bittorrent2/distinfo
new file mode 100644
index 000000000000..fe95008ea195
--- /dev/null
+++ b/net/pear-File_Bittorrent2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 615b467a202c91b7b151d316d7a73349
+SHA256 (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 9e5d7325f0a7094e763074bc9d7e5eec19204219042727cc6eb944eb8dda7035
+SIZE (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 69940
diff --git a/net/pear-File_Bittorrent2/pkg-descr b/net/pear-File_Bittorrent2/pkg-descr
new file mode 100644
index 000000000000..1da08223e01d
--- /dev/null
+++ b/net/pear-File_Bittorrent2/pkg-descr
@@ -0,0 +1,7 @@
+This package consists of three classes which handles the encoding
+and decoding of data in Bittorrent format. You can also extract
+useful informations from .torrent files, create .torrent files
+and query the torrent's scrape page to get its statistics.
+PHP5 only.
+
+WWW: http://pear.php.net/package/File_Bittorrent2/