aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2016-07-08 09:04:00 +0800
committercy <cy@FreeBSD.org>2016-07-08 09:04:00 +0800
commitc683c09c9de5fe277a8dc5f7ab43421a939ec1c6 (patch)
tree2f4262d4a0db6086cf9e96063790ef4ba4146dbe /net
parentc248418713efa78205056b0fec99fad9f2e960c7 (diff)
downloadfreebsd-ports-gnome-c683c09c9de5fe277a8dc5f7ab43421a939ec1c6.tar.gz
freebsd-ports-gnome-c683c09c9de5fe277a8dc5f7ab43421a939ec1c6.tar.zst
freebsd-ports-gnome-c683c09c9de5fe277a8dc5f7ab43421a939ec1c6.zip
Welcome tigervnc-devel 1.7.0 Beta (actual version number is 1.6.90).
Updates from the tigervnc 1.6.0 base port include: - Multi-threaded decoder in the FLTK viewer - Improved SSH integration in the Java viewer - Fine grained lock down of Xvnc parameters - Compatibility with Xorg 1.18 - Lots of packaging fixes - Better compatibility with Vino, both in the FLTK and Java viewer
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tigervnc-devel/Makefile145
-rw-r--r--net/tigervnc-devel/distinfo3
-rw-r--r--net/tigervnc-devel/files/patch-CMakeLists.txt11
-rw-r--r--net/tigervnc-devel/files/patch-cmake_BuildPackages.cmake10
-rw-r--r--net/tigervnc-devel/files/patch-unix_vncserver20
-rw-r--r--net/tigervnc-devel/files/patch-unix_xserver117.patch11
-rw-r--r--net/tigervnc-devel/pkg-descr5
-rw-r--r--net/tigervnc-devel/pkg-plist40
9 files changed, 246 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 68b778cc81bf..c4f0d0452b7c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1298,6 +1298,7 @@
SUBDIR += thcrut
SUBDIR += throttled
SUBDIR += tigervnc
+ SUBDIR += tigervnc-devel
SUBDIR += tightvnc
SUBDIR += tintin++
SUBDIR += tiny-network-utilities
diff --git a/net/tigervnc-devel/Makefile b/net/tigervnc-devel/Makefile
new file mode 100644
index 000000000000..1df600a93943
--- /dev/null
+++ b/net/tigervnc-devel/Makefile
@@ -0,0 +1,145 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= tigervnc
+PORTVERSION= 1.6.90
+DISTVERSIONPREFIX= v
+CATEGORIES= net x11-servers
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= High-performance, platform-neutral implementation of VNC
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENCE.TXT
+
+PATCH_DEPENDS= ${NONEXISTENT}:x11-servers/xorg-server:patch
+BUILD_DEPENDS= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/dri \
+ ${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
+ bash:shells/bash
+# almost equivalent to x11-servers/xorg-server's
+RUN_DEPENDS= ${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
+ xkbcomp:x11/xkbcomp
+
+CONFLICTS= tridiavnc-[0-9]* \
+ tightvnc-[0-9]* \
+ tigervnc-devel-[0-9]* \
+ vnc-[0-9]*
+
+USES= autoreconf:build cmake cpe gmake jpeg libtool pkgconfig \
+ python ssl iconv
+USE_GL= gl
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= TigerVNC
+
+USE_XORG+= bigreqsproto compositeproto damageproto fixesproto fontsproto glproto \
+ inputproto kbproto pixman randrproto renderproto resourceproto \
+ scrnsaverproto videoproto xau xdmcp xext xkbfile xcmiscproto xextproto \
+ xfont xproto xrandr xtrans xtst xorg-macros presentproto \
+ x11 sm ice xrender xdamage
+
+LIB_DEPENDS= libunwind.so:devel/libunwind \
+ libxshmfence.so:x11/libxshmfence \
+ libfontconfig.so:x11-fonts/fontconfig
+
+CFLAGS+= -fPIC
+
+OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER DOCS
+OPTIONS_DEFAULT= GNUTLS PAM VIEWER
+VIEWER_DESC= Build vncviewer
+
+.include <bsd.port.options.mk>
+
+CMAKE_ARGS= -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=${STAGE}${PREFIX}
+
+.if ${PORT_OPTIONS:MGNUTLS}
+LIB_DEPENDS+= libtasn1.so:security/libtasn1 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libgnutls.so:security/gnutls
+CONFIGURE_ARGS+= --enable-glx-tls
+CMAKE_ARGS+= -DENABLE_GNUTLS=1
+.else
+CMAKE_ARGS+= -DENABLE_GNUTLS=0
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CMAKE_ARGS+= -DENABLE_NLS=1
+PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DENABLE_NLS=0
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPAM}
+CMAKE_ARGS+= -DENABLE_PAM=1
+.else
+CMAKE_ARGS+= -DENABLE_PAM=0
+.endif
+
+.if ${PORT_OPTIONS:MVIEWER}
+CMAKE_ARGS+= -DBUILD_VIEWER=1
+LIB_DEPENDS+= libpng.so:graphics/png \
+ libfltk.so:x11-toolkits/fltk
+# ImageMagick is required to generate icons during build process
+BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:graphics/ImageMagick
+USE_XORG+= xcursor xfixes xft xinerama
+PLIST_SUB+= VIEWER=""
+INSTALLS_ICONS= yes
+DESKTOP_ENTRIES= "TigerVNC viewer" "Connect to VNC server and display remote desktop" \
+ "${PORTNAME}" "vncviewer" "Network;" false
+.else
+CMAKE_ARGS+= -DBUILD_VIEWER=0
+PLIST_SUB+= VIEWER="@comment "
+.endif
+
+MAKE_ARGS+= TIGERVNC_SRCDIR=${WRKSRC}
+CONFIGURE_ARGS+= \
+ --prefix=${PREFIX} --mandir=${PREFIX}/man/ \
+ --docdir=${PREFIX}/share/doc/${PORTNAME}/ --with-pic --without-dtrace \
+ --disable-static --disable-dri --disable-unit-tests \
+ --disable-xinerama --disable-xvfb --disable-xnest --disable-xorg \
+ --disable-dmx --disable-xwin --disable-xephyr --disable-kdrive \
+ --disable-config-dbus --disable-config-hal \
+ --disable-dri2 --enable-install-libxf86config --enable-glx \
+ --with-default-font-path="catalogue:${LOCALBASE}/share/fonts,built-ins" \
+ --with-xkb-path=${LOCALBASE}/share/X11/xkb \
+ --with-xkb-bin-directory=${LOCALBASE}/bin \
+ --with-serverconfig-path=${LOCALBASE}/lib/X11 \
+ --disable-selective-werror \
+ --with-fontrootdir=${LOCALBASE}/share/fonts
+
+.include <bsd.port.pre.mk>
+
+TIGERVNC_XORG_PATCH_VER= 117
+
+# import from x11-server/xorg-server/Makefile
+.if ${SSL_DEFAULT} == base
+# The reason why I use this is cause openssl from base doesn't
+# install a .pc file and configure will fail trying to find it.
+# Setting both of those variables to a *non-empty* value by-passes
+# the pkg-config check.
+CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
+.endif
+
+XORG_WRKDIR= ${MAKE} -C ${PORTSDIR}/x11-servers/xorg-server -VWRKSRC
+
+pre-patch:
+ @${CP} -R `${XORG_WRKDIR}`/ ${WRKSRC}/unix/xserver/
+
+post-patch:
+ @cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver${TIGERVNC_XORG_PATCH_VER}.patch
+
+post-configure:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${AUTORECONF} -fiv
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ./configure ${CONFIGURE_ARGS}
+
+post-build:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} SHELL=${LOCALBASE}/bin/bash
+
+post-install:
+ @cd ${WRKSRC}/unix/xserver/hw/vnc/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install
+
+.include <bsd.port.post.mk>
diff --git a/net/tigervnc-devel/distinfo b/net/tigervnc-devel/distinfo
new file mode 100644
index 000000000000..72e11e739f06
--- /dev/null
+++ b/net/tigervnc-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467937482
+SHA256 (TigerVNC-tigervnc-v1.6.90_GH0.tar.gz) = df11dd48d5c360dbe6c505a5a3cec3f12589fac759a0726f2f358c1aee36a5a9
+SIZE (TigerVNC-tigervnc-v1.6.90_GH0.tar.gz) = 1401599
diff --git a/net/tigervnc-devel/files/patch-CMakeLists.txt b/net/tigervnc-devel/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c85cb06617c6
--- /dev/null
+++ b/net/tigervnc-devel/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2013-07-21 16:21:37.028241067 +0000
++++ CMakeLists.txt 2013-07-21 16:21:59.310260222 +0000
+@@ -26,7 +26,7 @@
+ # Installation paths
+ set(BIN_DIR "${CMAKE_INSTALL_PREFIX}/bin")
+ set(DATA_DIR "${CMAKE_INSTALL_PREFIX}/share")
+-set(MAN_DIR "${DATA_DIR}/man")
++set(MAN_DIR "${CMAKE_INSTALL_PREFIX}/man")
+ set(LOCALE_DIR "${DATA_DIR}/locale")
+ set(DOC_DIR "${CMAKE_INSTALL_PREFIX}/share/doc/${CMAKE_PROJECT_NAME}-${VERSION}")
+
diff --git a/net/tigervnc-devel/files/patch-cmake_BuildPackages.cmake b/net/tigervnc-devel/files/patch-cmake_BuildPackages.cmake
new file mode 100644
index 000000000000..5da0133daa7e
--- /dev/null
+++ b/net/tigervnc-devel/files/patch-cmake_BuildPackages.cmake
@@ -0,0 +1,10 @@
+--- cmake/BuildPackages.cmake.orig 2012-05-28 00:21:51.000000000 +0900
++++ cmake/BuildPackages.cmake 2012-05-28 00:22:15.000000000 +0900
+@@ -86,5 +86,5 @@
+ # Common
+ #
+
+-install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION doc)
+-install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION doc)
++install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION share/doc/tigervnc)
++install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION share/doc/tigervnc)
diff --git a/net/tigervnc-devel/files/patch-unix_vncserver b/net/tigervnc-devel/files/patch-unix_vncserver
new file mode 100644
index 000000000000..045d688cd85e
--- /dev/null
+++ b/net/tigervnc-devel/files/patch-unix_vncserver
@@ -0,0 +1,20 @@
+--- unix/vncserver.orig 2012-05-27 21:16:41.000000000 +0900
++++ unix/vncserver 2012-05-27 21:17:13.000000000 +0900
+@@ -422,7 +422,7 @@
+
+ socket(S, $AF_INET, $SOCK_STREAM, 0) || die "$prog: socket failed: $!\n";
+ eval 'setsockopt(S, &SOL_SOCKET, &SO_REUSEADDR, pack("l", 1))';
+- if (!bind(S, pack('S n x12', $AF_INET, 6000 + $n))) {
++ if (!bind(S, sockaddr_in(6000 + $n, &INADDR_ANY))) {
+ close(S);
+ return 0;
+ }
+@@ -430,7 +430,7 @@
+
+ socket(S, $AF_INET, $SOCK_STREAM, 0) || die "$prog: socket failed: $!\n";
+ eval 'setsockopt(S, &SOL_SOCKET, &SO_REUSEADDR, pack("l", 1))';
+- if (!bind(S, pack('S n x12', $AF_INET, 5900 + $n))) {
++ if (!bind(S, sockaddr_in(5900 + $n, &INADDR_ANY))) {
+ close(S);
+ return 0;
+ }
diff --git a/net/tigervnc-devel/files/patch-unix_xserver117.patch b/net/tigervnc-devel/files/patch-unix_xserver117.patch
new file mode 100644
index 000000000000..62dbbcb2d025
--- /dev/null
+++ b/net/tigervnc-devel/files/patch-unix_xserver117.patch
@@ -0,0 +1,11 @@
+--- unix/xserver117.patch.orig 2015-10-13 17:11:25.207390000 +0200
++++ unix/xserver117.patch 2015-10-13 17:11:42.276049000 +0200
+@@ -66,7 +66,7 @@ diff -up xorg-server-1.17.1/mi/miinitext
+ #include "globals.h"
+
+ +#ifdef TIGERVNC
+-+extern void vncExtensionInit(INITARGS);
+++extern void vncExtensionInit(void);
+ +#endif
+ +
+ /* The following is only a small first step towards run-time
diff --git a/net/tigervnc-devel/pkg-descr b/net/tigervnc-devel/pkg-descr
new file mode 100644
index 000000000000..698856fa5bea
--- /dev/null
+++ b/net/tigervnc-devel/pkg-descr
@@ -0,0 +1,5 @@
+TigerVNC is a high-performance, platform-neutral implementation of VNC,
+a client/server application that allows users to launch and interact with
+graphical applications on remote machines.
+
+WWW: http://tigervnc.org/
diff --git a/net/tigervnc-devel/pkg-plist b/net/tigervnc-devel/pkg-plist
new file mode 100644
index 000000000000..ffd84668a434
--- /dev/null
+++ b/net/tigervnc-devel/pkg-plist
@@ -0,0 +1,40 @@
+bin/Xvnc
+bin/vncconfig
+bin/vncpasswd
+bin/vncserver
+%%VIEWER%%bin/vncviewer
+bin/x0vncserver
+lib/xorg/modules/extensions/libvnc.so
+man/man1/vncpasswd.1.gz
+man/man1/x0vncserver.1.gz
+man/man1/vncserver.1.gz
+man/man1/vncconfig.1.gz
+man/man1/Xvnc.1.gz
+%%VIEWER%%man/man1/vncviewer.1.gz
+%%NLS%%share/locale/bg/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/da/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/de/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/el/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/es/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/it/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/tigervnc.mo
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENCE.TXT
+%%VIEWER%%share/icons/hicolor/16x16/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/22x22/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/24x24/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/32x32/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/48x48/apps/tigervnc.png
+%%VIEWER%%share/icons/hicolor/scalable/apps/tigervnc.svg