aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-10-17 11:41:22 +0800
committerhrs <hrs@FreeBSD.org>2013-10-17 11:41:22 +0800
commitc8411c38ca2528085ddd4b700d8e6aec113ad9d1 (patch)
treec99f60cd4f222db71364e61c608685ccc1cd7d3c /net
parentd28110756d43368e21fea3a4722aa647a70ca416 (diff)
downloadfreebsd-ports-gnome-c8411c38ca2528085ddd4b700d8e6aec113ad9d1.tar.gz
freebsd-ports-gnome-c8411c38ca2528085ddd4b700d8e6aec113ad9d1.tar.zst
freebsd-ports-gnome-c8411c38ca2528085ddd4b700d8e6aec113ad9d1.zip
Add STAGEDIR support.
Diffstat (limited to 'net')
-rw-r--r--net/http_ping/Makefile9
-rw-r--r--net/http_ping/files/patch-Makefile21
2 files changed, 15 insertions, 15 deletions
diff --git a/net/http_ping/Makefile b/net/http_ping/Makefile
index a7bf1d7c1222..f650fa3bdc27 100644
--- a/net/http_ping/Makefile
+++ b/net/http_ping/Makefile
@@ -13,13 +13,6 @@ COMMENT= Measure HTTP Latency
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN1= http_ping.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/http_ping
-
-NO_STAGE= yes
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/http_ping ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/http_ping.1 ${PREFIX}/man/man1
+PLIST_FILES= bin/http_ping man/man1/http_ping.1.gz
.include <bsd.port.mk>
diff --git a/net/http_ping/files/patch-Makefile b/net/http_ping/files/patch-Makefile
index 73bc1d8f8d4e..bb4254548615 100644
--- a/net/http_ping/files/patch-Makefile
+++ b/net/http_ping/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-03-03 07:36:07.000000000 +0900
-+++ Makefile 2013-03-03 07:44:01.000000000 +0900
+--- Makefile.orig 2002-01-04 14:50:06.000000000 +0900
++++ Makefile 2013-10-17 12:39:39.000000000 +0900
@@ -14,13 +14,15 @@
#SSL_INC = -I$(SSL_TREE)/include
#SSL_LIBS = -L$(SSL_TREE)/lib -lssl -lcrypto
@@ -12,7 +12,7 @@
+SSL_DEFS= -DUSE_SSL ${OPENSSL_CFLAGS}
+SSL_INC= -I${OPENSSLINC}
+SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
-+bINDIR = ${PREFIX}/bin
++BINDIR = ${PREFIX}/bin
+MANDIR = ${MANPREFIX}/man/man1
+CC?= gcc -Wall
+CFLAGS+= -g $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)
@@ -22,12 +22,19 @@
#LDFLAGS = -g $(SSL_LIBS) $(SYSV_LIBS)
all: http_ping
-@@ -32,7 +34,7 @@
+@@ -32,11 +34,10 @@
$(CC) $(CFLAGS) -c http_ping.c
-install: all
+- rm -f $(BINDIR)/http_ping
+- cp http_ping $(BINDIR)
+- rm -f $(MANDIR)/http_ping.1
+- cp http_ping.1 $(MANDIR)
+install:
- rm -f $(BINDIR)/http_ping
- cp http_ping $(BINDIR)
- rm -f $(MANDIR)/http_ping.1
++ mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(MANDIR)
++ $(BSD_INSTALL_PROGRAM) http_ping $(DESTDIR)$(BINDIR)
++ $(BSD_INSTALL_MAN) http_ping.1 $(DESTDIR)$(MANDIR)
+
+ clean:
+ rm -f http_ping *.o core core.* *.core