aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-25 09:58:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-25 09:58:39 +0800
commitcd5213742afc1fcf0ad7bb89837976f5427fdbc4 (patch)
tree0e8ded856306ffaa94d251276683ea0d82b7c84b /net
parent5d1c5406a40763e93ce1acfcebee8b89c6f60cc1 (diff)
downloadfreebsd-ports-gnome-cd5213742afc1fcf0ad7bb89837976f5427fdbc4.tar.gz
freebsd-ports-gnome-cd5213742afc1fcf0ad7bb89837976f5427fdbc4.tar.zst
freebsd-ports-gnome-cd5213742afc1fcf0ad7bb89837976f5427fdbc4.zip
- Add p5-IO-Socket-IP 0.07
IO::Socket::IP provides a protocol-independent way to use IPv4 and IPv6 sockets, as a drop-in replacement for IO::Socket::INET. Most constructor arguments and methods are provided in a backward-compatible way. For a list of known differences, see the IO::Socket::INET INCOMPATIBILITES section below. It uses the getaddrinfo(3) function to convert hostnames and service names or port numbers into sets of possible addresses to connect to or listen on. This allows it to work for IPv6 where the system supports it, while still falling back to IPv4-only on systems which don't. WWW: http://search.cpan.org/dist/IO-Socket-IP/ Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-IO-Socket-IP/Makefile24
-rw-r--r--net/p5-IO-Socket-IP/distinfo2
-rw-r--r--net/p5-IO-Socket-IP/pkg-descr11
-rw-r--r--net/p5-IO-Socket-IP/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ccd5fc3631ae..16fa8b558588 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -506,6 +506,7 @@
SUBDIR += p5-Growl-GNTP
SUBDIR += p5-IO-Interface
SUBDIR += p5-IO-Socket-INET6
+ SUBDIR += p5-IO-Socket-IP
SUBDIR += p5-IO-Socket-Multicast
SUBDIR += p5-IO-Socket-Multicast6
SUBDIR += p5-IP-Anonymous
diff --git a/net/p5-IO-Socket-IP/Makefile b/net/p5-IO-Socket-IP/Makefile
new file mode 100644
index 000000000000..c3ec1079c77b
--- /dev/null
+++ b/net/p5-IO-Socket-IP/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-IO-Socket-IP
+# Date created: 2011-10-15
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Socket-IP
+PORTVERSION= 0.07
+CATEGORIES= net ipv6 perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A drop-in replacement for IO::Socket::INET supporting both IPv4 and IPv6
+
+BUILD_DEPENDS= p5-Socket-GetAddrInfo>=0.17:${PORTSDIR}/net/p5-Socket-GetAddrInfo
+RUN_DEPENDS= p5-Socket-GetAddrInfo>=0.17:${PORTSDIR}/net/p5-Socket-GetAddrInfo
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Socket::IP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Socket-IP/distinfo b/net/p5-IO-Socket-IP/distinfo
new file mode 100644
index 000000000000..b5dff90d0f3f
--- /dev/null
+++ b/net/p5-IO-Socket-IP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-Socket-IP-0.07.tar.gz) = 306d168775487aa30f9510b0c5230ae4f54fcfe094877e7abe4c4cf94287aceb
+SIZE (IO-Socket-IP-0.07.tar.gz) = 29503
diff --git a/net/p5-IO-Socket-IP/pkg-descr b/net/p5-IO-Socket-IP/pkg-descr
new file mode 100644
index 000000000000..a5ccd8a8c864
--- /dev/null
+++ b/net/p5-IO-Socket-IP/pkg-descr
@@ -0,0 +1,11 @@
+IO::Socket::IP provides a protocol-independent way to use IPv4 and IPv6 sockets,
+as a drop-in replacement for IO::Socket::INET. Most constructor arguments and
+methods are provided in a backward-compatible way. For a list of known
+differences, see the IO::Socket::INET INCOMPATIBILITES section below.
+
+It uses the getaddrinfo(3) function to convert hostnames and service names or
+port numbers into sets of possible addresses to connect to or listen on. This
+allows it to work for IPv6 where the system supports it, while still falling
+back to IPv4-only on systems which don't.
+
+WWW: http://search.cpan.org/dist/IO-Socket-IP/
diff --git a/net/p5-IO-Socket-IP/pkg-plist b/net/p5-IO-Socket-IP/pkg-plist
new file mode 100644
index 000000000000..fcb66ac8d89c
--- /dev/null
+++ b/net/p5-IO-Socket-IP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/IO/Socket/IP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Socket/IP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Socket/IP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Socket
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
+@dirrmtry %%SITE_PERL%%/IO/Socket
+@dirrmtry %%SITE_PERL%%/IO