aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-12-25 03:32:06 +0800
committermiwi <miwi@FreeBSD.org>2015-12-25 03:32:06 +0800
commitd29711c65afd2bf32328da3c9dc3d8b9f9e06232 (patch)
tree02d847fd1a412e4076bcd39fc2a3e65d5c47884e /net
parent870428eef36bdb732ccf17d40d94914e0d7c5d96 (diff)
downloadfreebsd-ports-gnome-d29711c65afd2bf32328da3c9dc3d8b9f9e06232.tar.gz
freebsd-ports-gnome-d29711c65afd2bf32328da3c9dc3d8b9f9e06232.tar.zst
freebsd-ports-gnome-d29711c65afd2bf32328da3c9dc3d8b9f9e06232.zip
txrestapi makes it easier to create Twisted REST API services. Normally,
one would create Resource subclasses defining each segment of a path; this is cubersome to implement and results in output that isn't very readable. txrestapi provides an APIResource class allowing complex mapping of path to callback (a la Django) with a readable decorator. WWW: https://pypi.python.org/pypi/txrestapi/ PR: 205064 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-txrestapi/Makefile19
-rw-r--r--net/py-txrestapi/distinfo2
-rw-r--r--net/py-txrestapi/pkg-descr8
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ff8b93b2b807..e1f7c94e7957 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -996,6 +996,7 @@
SUBDIR += py-twitter
SUBDIR += py-twitter-tools
SUBDIR += py-txamqp
+ SUBDIR += py-txrestapi
SUBDIR += py-uritemplate
SUBDIR += py-urllib3
SUBDIR += py-wolframalpha
diff --git a/net/py-txrestapi/Makefile b/net/py-txrestapi/Makefile
new file mode 100644
index 000000000000..9bfd653889f4
--- /dev/null
+++ b/net/py-txrestapi/Makefile
@@ -0,0 +1,19 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= txrestapi
+PORTVERSION= 0.2
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Easing the creation of REST API services in Python
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-txrestapi/distinfo b/net/py-txrestapi/distinfo
new file mode 100644
index 000000000000..f7f94a3867ed
--- /dev/null
+++ b/net/py-txrestapi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (txrestapi-0.2.tar.gz) = 3e432b88bc3788255a4d873e72c1ef6e9d0883306e95cd36c79542e792a08e31
+SIZE (txrestapi-0.2.tar.gz) = 5233
diff --git a/net/py-txrestapi/pkg-descr b/net/py-txrestapi/pkg-descr
new file mode 100644
index 000000000000..d224160dcd5b
--- /dev/null
+++ b/net/py-txrestapi/pkg-descr
@@ -0,0 +1,8 @@
+txrestapi makes it easier to create Twisted REST API services. Normally,
+one would create Resource subclasses defining each segment of a path;
+this is cubersome to implement and results in output that isn't very
+readable. txrestapi provides an APIResource class allowing complex
+mapping of path to callback (a la Django) with a readable decorator.
+
+
+WWW: https://pypi.python.org/pypi/txrestapi/