aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-10-03 22:40:50 +0800
committermat <mat@FreeBSD.org>2018-10-03 22:40:50 +0800
commitd3910f4295225192f1e2d42a7e91ef83a4014f7a (patch)
tree370547453db1e997d2892e67677c7a2911fffc62 /net
parent40219fbbb9ff0203b96e89ef33ddb8ff699ab1da (diff)
downloadfreebsd-ports-gnome-d3910f4295225192f1e2d42a7e91ef83a4014f7a.tar.gz
freebsd-ports-gnome-d3910f4295225192f1e2d42a7e91ef83a4014f7a.tar.zst
freebsd-ports-gnome-d3910f4295225192f1e2d42a7e91ef83a4014f7a.zip
Add missing dependencies, fix QA, cleanup.
Diffstat (limited to 'net')
-rw-r--r--net/nfs-ganesha/Makefile23
-rw-r--r--net/nfs-ganesha/distinfo6
-rw-r--r--net/nfs-ganesha/pkg-plist217
3 files changed, 135 insertions, 111 deletions
diff --git a/net/nfs-ganesha/Makefile b/net/nfs-ganesha/Makefile
index b23ed1fafa30..131d9a683a6d 100644
--- a/net/nfs-ganesha/Makefile
+++ b/net/nfs-ganesha/Makefile
@@ -1,29 +1,40 @@
# $FreeBSD$
PORTNAME= nfs-ganesha
+DISTVERSIONPREFIX= V
DISTVERSION= 2.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MAINTAINER= fatih@gandi.net
COMMENT= NFS fileserver that runs in user mode
LIB_DEPENDS= libdbus-1.so:devel/dbus
-RUN_DEPENDS= ${KMODDIR}/getfhat.ko:net/nfs-ganesha-kmod
+RUN_DEPENDS= nfs-ganesha-kmod>0:net/nfs-ganesha-kmod \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject>0:devel/py-gobject@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR}
-USES= cmake bison kmod pkgconfig python:build
+USES= cmake bison pkgconfig python:2.7
USE_RC_SUBR= ganesha
USE_GITHUB= yes
-GH_ACCOUNT= nfs-ganesha
-GH_TAGNAME= V2.7.0
-CFLAGS+= -Wno-error
GH_TUPLE= nfs-ganesha:ntirpc:v1.7.0:ganesha/src/libntirpc
+CFLAGS+= -Wno-error
+
CMAKE_ARGS= -DLIB_INSTALL_DIR=${LOCALBASE}/lib -DUSE_GSS=OFF -DUSE_9P=OFF \
-DUSE_FSAL_PROXY=OFF -DUSE_FSAL_GPFS=OFF -DUSE_FSAL_CEPH=OFF \
-DUSE_FSAL_GLUSTER=OFF -DUSE_FSAL_RGW=OFF -DUSE_RADOS_RECOV=OFF \
-DUSE_DBUS=ON -DUSE_ADMIN_TOOLS=ON
CMAKE_SOURCE_PATH= ${WRKSRC}/src
+post-install:
+ @${RM} -rf ${STAGEDIR}${PREFIX}/var
+ @${MKDIR} ${STAGEDIR}/var/run/ganesha
+ @${MV} ${STAGEDIR}${PREFIX}/etc/ganesha/ganesha.conf ${STAGEDIR}${PREFIX}/etc/ganesha/ganesha.conf.sample
+ @${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.pyc' -delete
+ @${PYTHON_CMD} -m compileall -d ${PYTHON_SITELIBDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O -m compileall -d ${PYTHON_SITELIBDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
+
.include <bsd.port.mk>
diff --git a/net/nfs-ganesha/distinfo b/net/nfs-ganesha/distinfo
index dea3b000ab0a..1c1642558e03 100644
--- a/net/nfs-ganesha/distinfo
+++ b/net/nfs-ganesha/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1537179573
-SHA256 (nfs-ganesha-nfs-ganesha-2.7.0-V2.7.0_GH0.tar.gz) = a458bd461049e4800bad24a2fd01335de6020f46ee495d5b2621eb3270097bca
-SIZE (nfs-ganesha-nfs-ganesha-2.7.0-V2.7.0_GH0.tar.gz) = 1691800
+TIMESTAMP = 1538575190
+SHA256 (nfs-ganesha-nfs-ganesha-V2.7.0_GH0.tar.gz) = a458bd461049e4800bad24a2fd01335de6020f46ee495d5b2621eb3270097bca
+SIZE (nfs-ganesha-nfs-ganesha-V2.7.0_GH0.tar.gz) = 1691800
SHA256 (nfs-ganesha-ntirpc-v1.7.0_GH0.tar.gz) = 61c72b481cd75945852df2f9ee5a6080e6f8cca7e57f4c7bc950f6cea0a7fbdb
SIZE (nfs-ganesha-ntirpc-v1.7.0_GH0.tar.gz) = 373195
diff --git a/net/nfs-ganesha/pkg-plist b/net/nfs-ganesha/pkg-plist
index 24bdde2adb40..13163b084da2 100644
--- a/net/nfs-ganesha/pkg-plist
+++ b/net/nfs-ganesha/pkg-plist
@@ -1,131 +1,144 @@
-include/ntirpc/libc_private.h
-include/ntirpc/version.h
-include/ntirpc/intrinsic.h
-include/ntirpc/rpcsvc/crypt.h
-include/ntirpc/reentrant.h
-include/ntirpc/getpeereid.h
-include/ntirpc/un-namespace.h
+bin/fake_recall
+bin/ganesha.nfsd
+bin/ganesha_conf
+bin/ganesha_mgr
+bin/ganesha_stats
+bin/get_clientids
+bin/grace_period
+@sample etc/ganesha/ganesha.conf.sample
include/ntirpc/fpmath.h
+include/ntirpc/getpeereid.h
+include/ntirpc/intrinsic.h
+include/ntirpc/libc_private.h
include/ntirpc/lttng/rpcping.h
include/ntirpc/lttng/xprt.h
-include/ntirpc/misc/socket.h
-include/ntirpc/misc/stdint.h
-include/ntirpc/misc/stdio.h
-include/ntirpc/misc/os_epoll.h
-include/ntirpc/misc/portable.h
-include/ntirpc/misc/rbtree_x.h
+include/ntirpc/misc/abstract_atomic.h
include/ntirpc/misc/bsd_epoll.h
+include/ntirpc/misc/city.h
include/ntirpc/misc/citycrc.h
-include/ntirpc/misc/opr.h
include/ntirpc/misc/event.h
-include/ntirpc/misc/city.h
-include/ntirpc/misc/abstract_atomic.h
-include/ntirpc/misc/queue.h
-include/ntirpc/misc/wait_queue.h
+include/ntirpc/misc/opr.h
include/ntirpc/misc/opr_queue.h
+include/ntirpc/misc/os_epoll.h
+include/ntirpc/misc/portable.h
+include/ntirpc/misc/queue.h
+include/ntirpc/misc/rbtree.h
+include/ntirpc/misc/rbtree_x.h
+include/ntirpc/misc/socket.h
+include/ntirpc/misc/stdint.h
+include/ntirpc/misc/stdio.h
include/ntirpc/misc/timespec.h
+include/ntirpc/misc/wait_queue.h
include/ntirpc/misc/winpthreads.h
-include/ntirpc/misc/rbtree.h
include/ntirpc/namespace.h
-include/ntirpc/rpc/pmap_prot.h
-include/ntirpc/rpc/rpc_com.h
-include/ntirpc/rpc/xdr_inline.h
-include/ntirpc/rpc/gss_internal.h
-include/ntirpc/rpc/rpcb_prot.x
-include/ntirpc/rpc/rpcb_prot.h
-include/ntirpc/rpc/tirpc_compat.h
-include/ntirpc/rpc/xdr.h
-include/ntirpc/rpc/rpc_msg.h
-include/ntirpc/rpc/svc_rqst.h
+include/ntirpc/netconfig.h
+include/ntirpc/reentrant.h
+include/ntirpc/rpc/auth.h
+include/ntirpc/rpc/auth_gss.h
include/ntirpc/rpc/auth_inline.h
-include/ntirpc/rpc/rpc_cksum.h
-include/ntirpc/rpc/clnt.h
-include/ntirpc/rpc/des_crypt.h
include/ntirpc/rpc/auth_stat.h
-include/ntirpc/rpc/clnt_stat.h
-include/ntirpc/rpc/xdr_ioq.h
-include/ntirpc/rpc/auth_gss.h
-include/ntirpc/rpc/rpcent.h
-include/ntirpc/rpc/rpcb_clnt.h
-include/ntirpc/rpc/rpc_err.h
-include/ntirpc/rpc/svc.h
include/ntirpc/rpc/auth_unix.h
-include/ntirpc/rpc/types.h
-include/ntirpc/rpc/work_pool.h
+include/ntirpc/rpc/clnt.h
+include/ntirpc/rpc/clnt_stat.h
include/ntirpc/rpc/des.h
-include/ntirpc/rpc/pool_queue.h
+include/ntirpc/rpc/des_crypt.h
+include/ntirpc/rpc/gss_internal.h
include/ntirpc/rpc/nettype.h
-include/ntirpc/rpc/auth.h
-include/ntirpc/rpc/svc_auth.h
+include/ntirpc/rpc/pmap_prot.h
include/ntirpc/rpc/pmap_rmt.h
+include/ntirpc/rpc/pool_queue.h
include/ntirpc/rpc/rpc.h
-include/ntirpc/netconfig.h
-bin/ganesha_stats
-bin/ganesha_conf
-bin/ganesha_mgr
-bin/fake_recall
-bin/get_clientids
-bin/grace_period
-bin/ganesha.nfsd
-lib/libntirpc.so.1.7
-lib/libntirpc.so.1.7.0
-lib/libntirpc.so
-lib/ganesha/libfsalmem.so.4
-lib/ganesha/libfsalnull.so
+include/ntirpc/rpc/rpc_cksum.h
+include/ntirpc/rpc/rpc_com.h
+include/ntirpc/rpc/rpc_err.h
+include/ntirpc/rpc/rpc_msg.h
+include/ntirpc/rpc/rpcb_clnt.h
+include/ntirpc/rpc/rpcb_prot.h
+include/ntirpc/rpc/rpcb_prot.x
+include/ntirpc/rpc/rpcent.h
+include/ntirpc/rpc/svc.h
+include/ntirpc/rpc/svc_auth.h
+include/ntirpc/rpc/svc_rqst.h
+include/ntirpc/rpc/tirpc_compat.h
+include/ntirpc/rpc/types.h
+include/ntirpc/rpc/work_pool.h
+include/ntirpc/rpc/xdr.h
+include/ntirpc/rpc/xdr_inline.h
+include/ntirpc/rpc/xdr_ioq.h
+include/ntirpc/rpcsvc/crypt.h
+include/ntirpc/un-namespace.h
+include/ntirpc/version.h
lib/ganesha/libfsaldummylustre.so
lib/ganesha/libfsalmem.so
-lib/ganesha/libfsalvfs.so
+lib/ganesha/libfsalmem.so.4
lib/ganesha/libfsalmem.so.4.2.0
-lib/python2.7/site-packages/Ganesha/config_editor.pyc
-lib/python2.7/site-packages/Ganesha/glib_dbus_stats.pyc
-lib/python2.7/site-packages/Ganesha/glib_dbus_stats.py
-lib/python2.7/site-packages/Ganesha/io_stats.py
-lib/python2.7/site-packages/Ganesha/admin.py
-lib/python2.7/site-packages/Ganesha/ganesha_mgr_utils.pyc
-lib/python2.7/site-packages/Ganesha/admin.pyc
-lib/python2.7/site-packages/Ganesha/QtUI/log_settings.py
-lib/python2.7/site-packages/Ganesha/QtUI/__init__.py
-lib/python2.7/site-packages/Ganesha/QtUI/exports_table.pyc
-lib/python2.7/site-packages/Ganesha/QtUI/log_settings.pyc
-lib/python2.7/site-packages/Ganesha/QtUI/exports_table.py
-lib/python2.7/site-packages/Ganesha/QtUI/clients_table.pyc
-lib/python2.7/site-packages/Ganesha/QtUI/__init__.pyc
-lib/python2.7/site-packages/Ganesha/QtUI/clients_table.py
-lib/python2.7/site-packages/Ganesha/io_stats.pyc
-lib/python2.7/site-packages/Ganesha/__init__.py
-lib/python2.7/site-packages/Ganesha/config_editor.py
-lib/python2.7/site-packages/Ganesha/__init__.pyc
-lib/python2.7/site-packages/Ganesha/export_mgr.py
-lib/python2.7/site-packages/Ganesha/ganesha_mgr_utils.py
-lib/python2.7/site-packages/Ganesha/log_mgr.py
-lib/python2.7/site-packages/Ganesha/client_mgr.pyc
-lib/python2.7/site-packages/Ganesha/log_mgr.pyc
-lib/python2.7/site-packages/Ganesha/export_mgr.pyc
-lib/python2.7/site-packages/Ganesha/client_mgr.py
-lib/python2.7/site-packages/ganeshactl-2.7.0-py2.7.egg-info
+lib/ganesha/libfsalnull.so
+lib/ganesha/libfsalvfs.so
+lib/libntirpc.so
+lib/libntirpc.so.1.7
+lib/libntirpc.so.1.7.0
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/__init__.py
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/clients_table.py
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/clients_table.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/clients_table.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/exports_table.py
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/exports_table.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/exports_table.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/log_settings.py
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/log_settings.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/QtUI/log_settings.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/__init__.py
+%%PYTHON_SITELIBDIR%%/Ganesha/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/admin.py
+%%PYTHON_SITELIBDIR%%/Ganesha/admin.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/admin.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/client_mgr.py
+%%PYTHON_SITELIBDIR%%/Ganesha/client_mgr.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/client_mgr.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/config_editor.py
+%%PYTHON_SITELIBDIR%%/Ganesha/config_editor.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/config_editor.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/export_mgr.py
+%%PYTHON_SITELIBDIR%%/Ganesha/export_mgr.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/export_mgr.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/ganesha_mgr_utils.py
+%%PYTHON_SITELIBDIR%%/Ganesha/ganesha_mgr_utils.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/ganesha_mgr_utils.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/glib_dbus_stats.py
+%%PYTHON_SITELIBDIR%%/Ganesha/glib_dbus_stats.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/glib_dbus_stats.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/io_stats.py
+%%PYTHON_SITELIBDIR%%/Ganesha/io_stats.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/io_stats.pyo
+%%PYTHON_SITELIBDIR%%/Ganesha/log_mgr.py
+%%PYTHON_SITELIBDIR%%/Ganesha/log_mgr.pyc
+%%PYTHON_SITELIBDIR%%/Ganesha/log_mgr.pyo
+%%PYTHON_SITELIBDIR%%/ganeshactl-%%PYTHON_VER%%.0-py%%PYTHON_VER%%.egg-info
libdata/pkgconfig/libntirpc.pc
-share/doc/ganesha/config_samples/vfs.conf
+share/doc/ganesha/config_samples/README
+share/doc/ganesha/config_samples/ceph.conf
share/doc/ganesha/config_samples/config.txt
-share/doc/ganesha/config_samples/logrotate_ganesha
-share/doc/ganesha/config_samples/gpfs.ganesha.exports.conf
-share/doc/ganesha/config_samples/gpfs.ganesha.nfsd.conf
+share/doc/ganesha/config_samples/ds.conf
+share/doc/ganesha/config_samples/export.txt
share/doc/ganesha/config_samples/ganesha.conf.example
+share/doc/ganesha/config_samples/gluster.conf
+share/doc/ganesha/config_samples/gpfs.conf
+share/doc/ganesha/config_samples/gpfs.ganesha.exports.conf
+share/doc/ganesha/config_samples/gpfs.ganesha.log.conf
share/doc/ganesha/config_samples/gpfs.ganesha.main.conf
+share/doc/ganesha/config_samples/gpfs.ganesha.nfsd.conf
+share/doc/ganesha/config_samples/logging.txt
share/doc/ganesha/config_samples/logrotate_fsal_gluster
-share/doc/ganesha/config_samples/gluster.conf
+share/doc/ganesha/config_samples/logrotate_ganesha
+share/doc/ganesha/config_samples/lustre.conf
share/doc/ganesha/config_samples/mem.conf
-share/doc/ganesha/config_samples/gpfs.ganesha.log.conf
-share/doc/ganesha/config_samples/export.txt
-share/doc/ganesha/config_samples/ds.conf
-share/doc/ganesha/config_samples/ceph.conf
+share/doc/ganesha/config_samples/proxy.conf
share/doc/ganesha/config_samples/rgw.conf
-share/doc/ganesha/config_samples/README
-share/doc/ganesha/config_samples/logging.txt
-share/doc/ganesha/config_samples/xfs.conf
share/doc/ganesha/config_samples/rgw_bucket.conf
-share/doc/ganesha/config_samples/gpfs.conf
-share/doc/ganesha/config_samples/proxy.conf
-share/doc/ganesha/config_samples/lustre.conf
+share/doc/ganesha/config_samples/vfs.conf
+share/doc/ganesha/config_samples/xfs.conf
share/man/man8/ganesha_conf.8
-etc/ganesha/ganesha.conf
-@dir var/run/ganesha
+@dir /var/run/ganesha