aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-02-15 17:44:30 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-02-15 17:44:30 +0800
commitd52d4ff555591c7156ce9f08c0a159c22bd54e98 (patch)
treec3a166dd610936ce18394ac4ce08c9bd7cecce13 /net
parent013e7ccacef4145de995772d22b77a47401688ee (diff)
downloadfreebsd-ports-gnome-d52d4ff555591c7156ce9f08c0a159c22bd54e98.tar.gz
freebsd-ports-gnome-d52d4ff555591c7156ce9f08c0a159c22bd54e98.tar.zst
freebsd-ports-gnome-d52d4ff555591c7156ce9f08c0a159c22bd54e98.zip
Add spoofer 0.4, ANA Spoofer Project testing software.
PR: ports/92913 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/spoofer/Makefile38
-rw-r--r--net/spoofer/distinfo3
-rw-r--r--net/spoofer/pkg-descr5
4 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f7ae5f95c6b4..b83394026f20 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -649,6 +649,7 @@
SUBDIR += socketbind
SUBDIR += socketpipe
SUBDIR += socks5
+ SUBDIR += spoofer
SUBDIR += spread
SUBDIR += spread-j
SUBDIR += ssldump
diff --git a/net/spoofer/Makefile b/net/spoofer/Makefile
new file mode 100644
index 000000000000..75d747163a0a
--- /dev/null
+++ b/net/spoofer/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: spoofer
+# Date created: 6 February 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spoofer
+PORTVERSION= 0.4
+CATEGORIES= net
+MASTER_SITES= http://spoofer.csail.mit.edu/
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= ANA Spoofer Project testing software
+
+PLIST_FILES= bin/spoofer
+PORTDOCS= README CHANGES
+
+SRC= spoofer.c util.c trace.c
+CFLAGS+= -D_FBSD
+
+do-build:
+.for f in ${SRC}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f} -o ${WRKSRC}/${f:C/\.c$/.o/}
+.endfor
+ ${CC} ${SRC:C/(.*)\.c$/${WRKSRC}\/\1.o/} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/spoofer/distinfo b/net/spoofer/distinfo
new file mode 100644
index 000000000000..893a707f8e80
--- /dev/null
+++ b/net/spoofer/distinfo
@@ -0,0 +1,3 @@
+MD5 (spoofer-0.4.tar.gz) = eb40e52d04844eec2be4b82ff27f7686
+SHA256 (spoofer-0.4.tar.gz) = 7b7523f416c2e1a0ff5b4e635cca22a8468317f358cd40a0a1c0f76c24d422ae
+SIZE (spoofer-0.4.tar.gz) = 10401
diff --git a/net/spoofer/pkg-descr b/net/spoofer/pkg-descr
new file mode 100644
index 000000000000..138173670102
--- /dev/null
+++ b/net/spoofer/pkg-descr
@@ -0,0 +1,5 @@
+Spoofer helps ANA Spoofer Project better understand the current state of
+filtering in the Internet. It attempts to send a series of spoofed UDP packets
+to a central server which logs and summarizes the results.
+
+WWW: http://spoofer.csail.mit.edu/