aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2002-11-03 23:51:39 +0800
committersumikawa <sumikawa@FreeBSD.org>2002-11-03 23:51:39 +0800
commitd5910d94acf2fe4399b32656a526e3d5b238ec7c (patch)
tree9301c94e8455dea39173852502db23ab9caf77c2 /net
parent7685ff860ede09a2d1ab77ae8e3f92735dfc3bbc (diff)
downloadfreebsd-ports-gnome-d5910d94acf2fe4399b32656a526e3d5b238ec7c.tar.gz
freebsd-ports-gnome-d5910d94acf2fe4399b32656a526e3d5b238ec7c.tar.zst
freebsd-ports-gnome-d5910d94acf2fe4399b32656a526e3d5b238ec7c.zip
Add startup script.
Diffstat (limited to 'net')
-rw-r--r--net/totd/Makefile4
-rw-r--r--net/totd/files/totd.sh18
2 files changed, 21 insertions, 1 deletions
diff --git a/net/totd/Makefile b/net/totd/Makefile
index 6993c0e5bc51..b48626ff2460 100644
--- a/net/totd/Makefile
+++ b/net/totd/Makefile
@@ -6,7 +6,7 @@
PORTNAME= totd
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
@@ -18,5 +18,7 @@ GNU_CONFIGURE= YES
post-install:
${INSTALL_DATA} ${FILESDIR}/totd.conf.sample ${PREFIX}/etc
+ @${SED} 's@%PREFIX%@${LOCALBASE}@g' ${FILESDIR}/totd.sh > ${PREFIX}/etc/rc.d/totd.sh
+ @${CHMOD} +x ${PREFIX}/etc/rc.d/totd.sh
.include <bsd.port.mk>
diff --git a/net/totd/files/totd.sh b/net/totd/files/totd.sh
new file mode 100644
index 000000000000..9a528db44489
--- /dev/null
+++ b/net/totd/files/totd.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ if [ -x %PREFIX%/sbin/totd ]; then
+ %PREFIX%/sbin/totd && echo -n ' totd'
+ fi
+ ;;
+
+ stop)
+ /usr/bin/killall totd && echo -n ' totd'
+ ;;
+
+ *)
+ echo "Usage: `basename $0` { start | stop }"
+ exit 64
+ ;;
+esac