aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
commitd6c170198e97f1109801df05948762e423645c4b (patch)
treee61ab76efa292f985d8e20e449572329fa964c1c /net
parent6174635d1f2fb489f2267a3388ddd0cc658b8c00 (diff)
downloadfreebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.tar.gz
freebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.tar.zst
freebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.zip
SSP support has been added to ports with WITH_SSP for i386 and amd64
on FreeBSD 10, and amd64 on earlier versions. SSP_UNSAFE is added to disable in a port if it fails to build, but this should only be used in rare circumstances such as kernel modules. Otherwise, the port may just be failing due to lack of respecting LDFLAGS. On FreeBSD 10, this uses an ldscript in /usr/lib/libc.so to pull in libssp_nonshared.a to address issues linking on i386 [1]. On earlier FreeBSD versions the WITH_SSP knob will add -lssp_nonshared to LDFLAGS on i386. This is not needed on amd64. However, several hundred ports do not currently respect LDFLAGS, so this support is disabled currently as it causes build failures if a dependency is looking for the stack_chk symbols. Many thanks to jlh@ for this as he had many years of patience in getting all of the necessary pieces [1][2] in. [1] http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup PR: ports/138228 [2] Submitted by: jlh (bsd.ssp.mk based on) Reviewed by: bapt With hat: portmgr exp-runs done: 37 over a month on 91i386,91amd64,10i386,10amd64
Diffstat (limited to 'net')
-rw-r--r--net/aoe/Makefile9
-rw-r--r--net/etherboot/Makefile1
-rw-r--r--net/iet/Makefile3
-rw-r--r--net/ng_daphne/Makefile8
-rw-r--r--net/ng_mikrotik_eoip/Makefile2
-rw-r--r--net/skyfish/Makefile8
-rw-r--r--net/userfw/Makefile7
7 files changed, 16 insertions, 22 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index 29da5efad00b..b180917fda60 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -1,13 +1,9 @@
-# Ports collection makefile for: aoe (ATA Over Ethernet) driver
-# Date created: 22 May 2006
-# Whom: Stacey D. Son <sds@son.org>
-#
+# Created by: Stacey D. Son <sds@son.org>
# $FreeBSD$
-#
PORTNAME= aoe
PORTVERSION= 1.2.0
-CATEGORIES= net
+CATEGORIES= net kld
MASTER_SITES= http://www.son.org/download/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
@@ -15,6 +11,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
NO_PACKAGE= Should be in sync with the kernel to work correctly
+SSP_UNSAFE= kernel module does not support ssp
WRKSRC= ${WRKDIR}/dev/aoe
MAN4= aoe.4
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index 959955dd5026..a5567998bafc 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= SF http://etherboot.berlios.de/dist/
MAINTAINER= ambrisko@FreeBSD.org
COMMENT= Network boot of FreeBSD a.out/ELF kernels (improved netboot)
+SSP_UNSAFE= yes
ONLY_FOR_ARCHS= i386
NO_PACKAGE= lots of configuration necessary
diff --git a/net/iet/Makefile b/net/iet/Makefile
index 45294a9c666a..5fb0eaa241a6 100644
--- a/net/iet/Makefile
+++ b/net/iet/Makefile
@@ -4,7 +4,7 @@
PORTNAME= iet
PORTVERSION= 1.4.20.2
PORTREVISION= 6
-CATEGORIES= net
+CATEGORIES= net kld
MASTER_SITES= SF/iscsitarget/iscsitarget/${PORTVERSION}/
DISTNAME= iscsitarget-${PORTVERSION}
@@ -18,6 +18,7 @@ COMMENT= The iSCSI Enterprise Target
LICENSE= GPLv2
+SSP_UNSAFE= kernel module does not support ssp
BUILD_WRKSRC= ${WRKSRC}/freebsd
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/net/ng_daphne/Makefile b/net/ng_daphne/Makefile
index ce95f8146506..37a29bf07703 100644
--- a/net/ng_daphne/Makefile
+++ b/net/ng_daphne/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ng_daphne
-# Date created: 8 November 2003
-# Whom: Gerasimos Dimitriadis
-#
+# Created by: Gerasimos Dimitriadis
# $FreeBSD$
-#
PORTNAME= ng_daphne
PORTVERSION= 1.0
@@ -15,6 +11,8 @@ MASTER_SITES= http://newton.ee.auth.gr/ng_daphne/ \
MAINTAINER= gedimitr@auth.gr
COMMENT= A simple netgraph module for multihop ad hoc networks
+SSP_UNSAFE= kernel module does not support ssp
+
.include <bsd.port.pre.mk>
SYSDIR?= ${SRC_BASE}/sys
diff --git a/net/ng_mikrotik_eoip/Makefile b/net/ng_mikrotik_eoip/Makefile
index b84903e7fd5e..e45121c6a827 100644
--- a/net/ng_mikrotik_eoip/Makefile
+++ b/net/ng_mikrotik_eoip/Makefile
@@ -12,6 +12,8 @@ COMMENT= Netgraph node for Mikrotik EoIP tunneling
LICENSE= BSD
+SSP_UNSAFE= kernel module does not support ssp
+
OPTIONS_DEFINE= PTABLE
PTABLE_DESC= Use O(1) lookup for tunnel hooks
# This option enables usage of static pointer table to find needed decimal-named hook,
diff --git a/net/skyfish/Makefile b/net/skyfish/Makefile
index 64b32f0c15bc..a167c7a9e28d 100644
--- a/net/skyfish/Makefile
+++ b/net/skyfish/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: skyfish
-# Date created: 23 May 2008
-# Whom: Nsand <nsand@sura.ru>
-#
+# Created by: Nsand <nsand@sura.ru>
# $FreeBSD$
-#
PORTNAME= skyfish
PORTVERSION= 0.91
@@ -13,6 +9,8 @@ MASTER_SITES= ftp://ftp.lissyara.su/users/nsand/skyfish/
MAINTAINER= nsand@sura.ru
COMMENT= Grabbing TCP streams from network interface (SAT internet)
+SSP_UNSAFE= kernel module does not support ssp
+
.include <bsd.port.pre.mk>
SYSDIR?= ${SRC_BASE}/sys
diff --git a/net/userfw/Makefile b/net/userfw/Makefile
index 6177d3d4a82a..70914984ddc8 100644
--- a/net/userfw/Makefile
+++ b/net/userfw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: userfw
-# Date created: 10 Mar 2012
-# Whom: Maxim Ignatenko
-#
+# Created by: Maxim Ignatenko
# $FreeBSD$
-#
PORTNAME= userfw
PORTVERSION= 0.1.3
@@ -17,6 +13,7 @@ COMMENT= Modular packet filter
LICENSE= BSD
+SSP_UNSAFE= kernel module does not support ssp
USE_XZ= yes
USES= cmake:outsource
USE_LDCONFIG= yes