aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-10-19 08:28:57 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-10-19 08:28:57 +0800
commitd895c43e2aba481ee91a87cde39d50b9fda49270 (patch)
treed79e6ec5fa21e3e2aa720ad3b67828d06d29752b /net
parent69bb2e0942c0f2a092be4d9b4e2b41e0e1174902 (diff)
downloadfreebsd-ports-gnome-d895c43e2aba481ee91a87cde39d50b9fda49270.tar.gz
freebsd-ports-gnome-d895c43e2aba481ee91a87cde39d50b9fda49270.tar.zst
freebsd-ports-gnome-d895c43e2aba481ee91a87cde39d50b9fda49270.zip
This module implements a scalable method of quickly propagating files
to a large number of servers in one or more locations via rsync or scp. This module and the included script, ccp, take a much more efficient approach that is O(log n). Once the file(s) are been copied to a remote server, that server will be promoted to be used as source server for copying to remaining servers. Thus, the rate of transfer increases exponentially rather than linearly. Servers can be specified in groups (e.g. datacenter) to prevent copying across groups. This maximizes the number of transfers done over a local high-speed connection (LAN) while minimizing the number of transfers over the WAN. The number of multiple simultaneous transfers per source point is configurable. The total number of simultaneously forked processes is limited via Proc::Queue, and is currently hard coded to 32. WWW: http://search.cpan.org/dist/Net-CascadeCopy/ PR: ports/151487 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-CascadeCopy/Makefile27
-rw-r--r--net/p5-Net-CascadeCopy/distinfo3
-rw-r--r--net/p5-Net-CascadeCopy/pkg-descr20
-rw-r--r--net/p5-Net-CascadeCopy/pkg-plist7
5 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d2063645327b..652784016e0f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -535,6 +535,7 @@
SUBDIR += p5-Net-CIDR-Lite
SUBDIR += p5-Net-CIDR-MobileJP
SUBDIR += p5-Net-CSTA
+ SUBDIR += p5-Net-CascadeCopy
SUBDIR += p5-Net-Cassandra
SUBDIR += p5-Net-Cassandra-Easy
SUBDIR += p5-Net-DAV-Server
diff --git a/net/p5-Net-CascadeCopy/Makefile b/net/p5-Net-CascadeCopy/Makefile
new file mode 100644
index 000000000000..1c7d08ca0a7d
--- /dev/null
+++ b/net/p5-Net-CascadeCopy/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-CascadeCopy
+# Date created: 2010-10-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-CascadeCopy
+PORTVERSION= 0.2.4
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Rapidly propagate files to many servers in multiple locations
+
+RUN_DEPENDS= p5-Class-Std-Utils>=v0.0.0:${PORTSDIR}/devel/p5-Class-Std-Utils \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Proc-Queue>=0:${PORTSDIR}/devel/p5-Proc-Queue
+
+PERL_CONFIGURE= yes
+
+MAN1= ccp.1
+MAN3= Net::CascadeCopy.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-CascadeCopy/distinfo b/net/p5-Net-CascadeCopy/distinfo
new file mode 100644
index 000000000000..34d4c0bd00ec
--- /dev/null
+++ b/net/p5-Net-CascadeCopy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-CascadeCopy-0.2.4.tar.gz) = 9f18b988f4b36a42ab0358a77c35e6df
+SHA256 (Net-CascadeCopy-0.2.4.tar.gz) = dcf712c885231c3f0cf9549c58a0967b310d5de55b2d902adec1cef2f28aeb86
+SIZE (Net-CascadeCopy-0.2.4.tar.gz) = 16214
diff --git a/net/p5-Net-CascadeCopy/pkg-descr b/net/p5-Net-CascadeCopy/pkg-descr
new file mode 100644
index 000000000000..fb69924950f2
--- /dev/null
+++ b/net/p5-Net-CascadeCopy/pkg-descr
@@ -0,0 +1,20 @@
+This module implements a scalable method of quickly propagating files
+to a large number of servers in one or more locations via rsync or
+scp.
+
+This module and the included script, ccp, take a much more efficient
+approach that is O(log n). Once the file(s) are been copied to a
+remote server, that server will be promoted to be used as source
+server for copying to remaining servers. Thus, the rate of transfer
+increases exponentially rather than linearly.
+
+Servers can be specified in groups (e.g. datacenter) to prevent
+copying across groups. This maximizes the number of transfers done
+over a local high-speed connection (LAN) while minimizing the number
+of transfers over the WAN.
+
+The number of multiple simultaneous transfers per source point is
+configurable. The total number of simultaneously forked processes is
+limited via Proc::Queue, and is currently hard coded to 32.
+
+WWW: http://search.cpan.org/dist/Net-CascadeCopy/
diff --git a/net/p5-Net-CascadeCopy/pkg-plist b/net/p5-Net-CascadeCopy/pkg-plist
new file mode 100644
index 000000000000..5d4b5dec5023
--- /dev/null
+++ b/net/p5-Net-CascadeCopy/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CascadeCopy/.packlist
+%%SITE_PERL%%/Net/CascadeCopy.pm
+bin/ccp
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CascadeCopy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net