aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-20 23:44:05 +0800
committerpav <pav@FreeBSD.org>2005-07-20 23:44:05 +0800
commitd9eee117849796fbf19ebe3fad0fc5c1a3ae3745 (patch)
treeea526b6eb96f48a33a908db026aa1434e5506e9d /net
parenta57410e93847f0142d6130d15bf1d47a60321eb6 (diff)
downloadfreebsd-ports-gnome-d9eee117849796fbf19ebe3fad0fc5c1a3ae3745.tar.gz
freebsd-ports-gnome-d9eee117849796fbf19ebe3fad0fc5c1a3ae3745.tar.zst
freebsd-ports-gnome-d9eee117849796fbf19ebe3fad0fc5c1a3ae3745.zip
- Add optional patch that changes smbclient invocation to match arguments
that samba3 expects PR: ports/77015 Submitted by: Taik0 <suikogaiden@gmail.com> Approved by: maintainer timeout (5 months)
Diffstat (limited to 'net')
-rw-r--r--net/linpopup/Makefile4
-rw-r--r--net/linpopup/files/extra-patch-samba312
2 files changed, 16 insertions, 0 deletions
diff --git a/net/linpopup/Makefile b/net/linpopup/Makefile
index befb32b651ce..4b5414dd4edb 100644
--- a/net/linpopup/Makefile
+++ b/net/linpopup/Makefile
@@ -25,6 +25,10 @@ USE_GNOME= gtk12
USE_X_PREFIX= yes
USE_REINPLACE= yes
+.if defined(WITH_SAMBA3)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-samba3
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s#/doc/#/share/doc/#" ${WRKSRC}/Makefile
diff --git a/net/linpopup/files/extra-patch-samba3 b/net/linpopup/files/extra-patch-samba3
new file mode 100644
index 000000000000..a172b6d1bb48
--- /dev/null
+++ b/net/linpopup/files/extra-patch-samba3
@@ -0,0 +1,12 @@
+diff -ur send.c send.c
+--- send.c Tue Mar 14 03:45:05 2000
++++ send.c Wed Feb 2 17:05:46 2005
+@@ -92,7 +92,7 @@
+ /* -- launch smbclient and read output from pipe -- */
+ //sprintf (command_line, "( %s cat %s ) | smbclient -M \"%s\" -U \"%s\" -n \"%s\" \"%s\"", (MULTI_RECIPIENTS ? prefix : ""), temp_filename, head_text, user_rc.samba_username, user_rc.samba_nbiosname, user_rc.samba_misc);
+
+- sprintf (command_line, "( %s cat %s ) | smbclient -M \"%s\" -U \"%s\" -n \"%s\" \"%s\" 2>&1", (MULTI_RECIPIENTS ? prefix : ""), temp_filename, head_text, user_rc.samba_username, user_rc.samba_nbiosname, user_rc.samba_misc);
++ sprintf (command_line, "( %s cat %s ) | smbclient -M \"%s\" -U \"%s\" -n \"%s\" 2>&1", (MULTI_RECIPIENTS ? prefix : ""), temp_filename, head_text, user_rc.samba_username, user_rc.samba_nbiosname);
+
+
+ output = popen (command_line, "r");