aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-10 07:52:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-10 07:52:30 +0800
commitdae6574975eafc2acf681a7305a0fcc1db529724 (patch)
treeea71b3504ac1b64e124bcdbbcdb6ba5ee3a6c0f3 /net
parent0d6bfeccadae31f9a5c3d5c3b047256421e16ed5 (diff)
downloadfreebsd-ports-gnome-dae6574975eafc2acf681a7305a0fcc1db529724.tar.gz
freebsd-ports-gnome-dae6574975eafc2acf681a7305a0fcc1db529724.tar.zst
freebsd-ports-gnome-dae6574975eafc2acf681a7305a0fcc1db529724.zip
- Support staging
- Convert USE_GMAKE to USES
Diffstat (limited to 'net')
-rw-r--r--net/ccxstream/Makefile60
1 files changed, 21 insertions, 39 deletions
diff --git a/net/ccxstream/Makefile b/net/ccxstream/Makefile
index 8820afed50ed..45b3e7e8a3c8 100644
--- a/net/ccxstream/Makefile
+++ b/net/ccxstream/Makefile
@@ -1,55 +1,37 @@
# Created by: Michael Handler <handler@grendel.net>
# $FreeBSD$
-PORTNAME= ccxstream
-PORTVERSION= 1.0.15
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= SF/xbplayer/XStream%20Servers/ccXStream%20${PORTVERSION}%20for%20Linux
+PORTNAME= ccxstream
+PORTVERSION= 1.0.15
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= SF/xbplayer/XStream%20Servers/ccXStream%20${PORTVERSION}%20for%20Linux
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Stream media files to XBox Media Center via XBMSP
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Stream media files to XBox Media Center via XBMSP
+
+USES= gmake
+USE_RC_SUBR= ccxstream
+
+PLIST_FILES= bin/ccxtest \
+ sbin/ccxstream
+PORTDOCS= README ChangeLog TODO xbmsp-xml.txt xbmsp.txt
OPTIONS_DEFINE= SO_KEEPALIVE TCP_NODELAY DOCS
-OPTIONS_DEFAULT= SO_KEEPALIVE
+OPTIONS_DEFAULT=SO_KEEPALIVE
SO_KEEPALIVE_DESC= Build with SO_KEEPALIVE
+SO_KEEPALICE_CFLAGS= -DSO_KEEPALIVE
TCP_NODELAY_DESC= Build with TCP_NODELAY
+TCP_NODELAY_CFLAGS= -DTCP_NODELAY
-USE_GMAKE= yes
-USE_RC_SUBR= ccxstream
-
-PLIST_FILES= bin/ccxtest \
- sbin/ccxstream
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README ChangeLog TODO xbmsp-xml.txt xbmsp.txt
-.endif
-
do-install:
- @${MKDIR} ${PREFIX}/sbin
- @${INSTALL_PROGRAM} ${WRKSRC}/ccxstream ${PREFIX}/sbin
- @${INSTALL_PROGRAM} ${WRKSRC}/ccxtest ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ccxstream ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ccxtest ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-# enable SO_KEEPALIVE
-.if ${PORT_OPTIONS:MSO_KEEPALIVE}
-CFLAGS+= -DSO_KEEPALIVE
-.endif
-
-# enable TCP_NODELAY
-.if ${PORT_OPTIONS:MTCP_NODELAY}
-CFLAGS+= -DTCP_NODELAY
-.endif
.include <bsd.port.mk>