aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-14 02:45:55 +0800
committermiwi <miwi@FreeBSD.org>2010-02-14 02:45:55 +0800
commitdbdfaf4783bc18c4260dc2c24e165c1420e95123 (patch)
treee3dbb4450a68fa8ffbe7186ec6ee7c9f6ff19c25 /net
parent41be626d7a8e6a6e18158462ae2e287af39d3be1 (diff)
downloadfreebsd-ports-gnome-dbdfaf4783bc18c4260dc2c24e165c1420e95123.tar.gz
freebsd-ports-gnome-dbdfaf4783bc18c4260dc2c24e165c1420e95123.tar.zst
freebsd-ports-gnome-dbdfaf4783bc18c4260dc2c24e165c1420e95123.zip
Toonel.net exploits a tunneling technique combined with data compression.
It runs compressed data frames from toonel client to one of the toonel servers and then these are forwarded to the target host. Reducing the size of resources that are transferred between the server and the client makes more efficient use of the user's bandwidth. WWW: http://toonel.net PR: ports/143552 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/toonel/Makefile35
-rw-r--r--net/toonel/distinfo3
-rw-r--r--net/toonel/files/toonel.sh.in7
-rw-r--r--net/toonel/pkg-descr7
5 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5d187a77e74f..e91907f6f0e2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1010,6 +1010,7 @@
SUBDIR += tinyldap
SUBDIR += tn5250
SUBDIR += tn5250j
+ SUBDIR += toonel
SUBDIR += torsocks
SUBDIR += tptest
SUBDIR += traceroute
diff --git a/net/toonel/Makefile b/net/toonel/Makefile
new file mode 100644
index 000000000000..a0806603d5b3
--- /dev/null
+++ b/net/toonel/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: toonel
+# Date created: 2010-02-04
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= toonel
+PORTVERSION= 0.0.50.50
+CATEGORIES= net java
+MASTER_SITES= http://www.toonel.net/generic/005050/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Tunneling with data compression
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+SUB_FILES= ${PORTNAME}.sh
+SUB_LIST= JARNAME=${DISTNAME}${EXTRACT_SUFX}
+
+PLIST_FILES= bin/${PORTNAME} ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}/
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${JAVAJARDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/toonel/distinfo b/net/toonel/distinfo
new file mode 100644
index 000000000000..203fd6753aeb
--- /dev/null
+++ b/net/toonel/distinfo
@@ -0,0 +1,3 @@
+MD5 (toonel.jar) = a00729ad6126933b90770eced3c37a95
+SHA256 (toonel.jar) = 5d1e6665f018dea7f20fc4f9ad0c6fda3cb2f8e432cc6734302a8e020ff254ce
+SIZE (toonel.jar) = 120074
diff --git a/net/toonel/files/toonel.sh.in b/net/toonel/files/toonel.sh.in
new file mode 100644
index 000000000000..b3705ab2d572
--- /dev/null
+++ b/net/toonel/files/toonel.sh.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+JAVA="%%LOCALBASE%%/bin/java"
+JARPATH="%%JAVALIBDIR%%"
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+exec "${JAVA}" -jar "${JARPATH}/%%JARNAME%%" "$@"
diff --git a/net/toonel/pkg-descr b/net/toonel/pkg-descr
new file mode 100644
index 000000000000..b27e0afb7c6d
--- /dev/null
+++ b/net/toonel/pkg-descr
@@ -0,0 +1,7 @@
+Toonel.net exploits a tunneling technique combined with data compression.
+It runs compressed data frames from toonel client to one of the toonel
+servers and then these are forwarded to the target host. Reducing the
+size of resources that are transferred between the server and the client
+makes more efficient use of the user's bandwidth.
+
+WWW: http://toonel.net