aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2001-12-24 07:27:43 +0800
committermbr <mbr@FreeBSD.org>2001-12-24 07:27:43 +0800
commitdcb7f9714571361a08a3db10f986e9c3efce3649 (patch)
treed5c90183a0e142e339056c91d6261d795abe0f67 /net
parente9d498482ddacda31825ecc208ef1fd7610d1c4a (diff)
downloadfreebsd-ports-gnome-dcb7f9714571361a08a3db10f986e9c3efce3649.tar.gz
freebsd-ports-gnome-dcb7f9714571361a08a3db10f986e9c3efce3649.tar.zst
freebsd-ports-gnome-dcb7f9714571361a08a3db10f986e9c3efce3649.zip
Change my email address, upgrade to latest version and fix
the endless loop during install in the case no netscape was installed. PR: ports/31390 Reviewed by: Dmitry Sivachenko <mitya@cavia.pp.ru>
Diffstat (limited to 'net')
-rw-r--r--net/citrix_ica/Makefile24
-rw-r--r--net/citrix_ica/distinfo2
-rw-r--r--net/citrix_ica/files/response6
-rw-r--r--net/citrix_xenapp/Makefile24
-rw-r--r--net/citrix_xenapp/distinfo2
-rw-r--r--net/citrix_xenapp/files/response6
6 files changed, 42 insertions, 22 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index d0862eae8087..46a2c57bab1a 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= citrix_ica
-PORTVERSION= 6.0.908
+PORTVERSION= 6.20.973
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= linuxx86
-MAINTAINER= mb@imp.ch
+MAINTAINER= mbr@FreeBSD.org
RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
@@ -33,8 +33,24 @@ IGNORE='The distribution file for this port may not be automatically fetched due
.endif
do-install:
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/response \
- > ${WRKSRC}/response
+ @if (test -d "${CDIR}") ; \
+ then \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "A ${CDIR} installation does already exist." ; \
+ ${ECHO} "Please move it away or delete the old port" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${FALSE} ; \
+ fi
+ @if (test -d "/usr/lib/netscape"\
+ || test -d "/usr/local/netscape"\
+ || test -d "/usr/local/lib/netscape") ; \
+ then \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ else \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ fi
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
> ${WRKSRC}/wfcmgr.x
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
diff --git a/net/citrix_ica/distinfo b/net/citrix_ica/distinfo
index 09151aa51587..89aae3add0a6 100644
--- a/net/citrix_ica/distinfo
+++ b/net/citrix_ica/distinfo
@@ -1 +1 @@
-MD5 (citrix_ica/linuxx86.tar.gz) = cd26657c3436a34f7a0b1d5084189678
+MD5 (citrix_ica/linuxx86.tar.gz) = 695f88fc72af02b2f30198e6bf526a8f
diff --git a/net/citrix_ica/files/response b/net/citrix_ica/files/response
deleted file mode 100644
index 8cdad35f2e40..000000000000
--- a/net/citrix_ica/files/response
+++ /dev/null
@@ -1,6 +0,0 @@
-1
-DESTINATION
-y
-y
-y
-3
diff --git a/net/citrix_xenapp/Makefile b/net/citrix_xenapp/Makefile
index d0862eae8087..46a2c57bab1a 100644
--- a/net/citrix_xenapp/Makefile
+++ b/net/citrix_xenapp/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= citrix_ica
-PORTVERSION= 6.0.908
+PORTVERSION= 6.20.973
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= linuxx86
-MAINTAINER= mb@imp.ch
+MAINTAINER= mbr@FreeBSD.org
RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
@@ -33,8 +33,24 @@ IGNORE='The distribution file for this port may not be automatically fetched due
.endif
do-install:
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/response \
- > ${WRKSRC}/response
+ @if (test -d "${CDIR}") ; \
+ then \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "A ${CDIR} installation does already exist." ; \
+ ${ECHO} "Please move it away or delete the old port" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${FALSE} ; \
+ fi
+ @if (test -d "/usr/lib/netscape"\
+ || test -d "/usr/local/netscape"\
+ || test -d "/usr/local/lib/netscape") ; \
+ then \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ else \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ fi
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
> ${WRKSRC}/wfcmgr.x
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
diff --git a/net/citrix_xenapp/distinfo b/net/citrix_xenapp/distinfo
index 09151aa51587..89aae3add0a6 100644
--- a/net/citrix_xenapp/distinfo
+++ b/net/citrix_xenapp/distinfo
@@ -1 +1 @@
-MD5 (citrix_ica/linuxx86.tar.gz) = cd26657c3436a34f7a0b1d5084189678
+MD5 (citrix_ica/linuxx86.tar.gz) = 695f88fc72af02b2f30198e6bf526a8f
diff --git a/net/citrix_xenapp/files/response b/net/citrix_xenapp/files/response
deleted file mode 100644
index 8cdad35f2e40..000000000000
--- a/net/citrix_xenapp/files/response
+++ /dev/null
@@ -1,6 +0,0 @@
-1
-DESTINATION
-y
-y
-y
-3