aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-04-24 02:39:04 +0800
committerpi <pi@FreeBSD.org>2016-04-24 02:39:04 +0800
commitdcf0cbc7b52d5756945de5f2622656ccc3a31dc2 (patch)
tree970709dcb1e48ffd30ce532650b9915e0f60d8e5 /net
parent4323f02f3ab828f89c078b3d5b0dffce894d77bb (diff)
downloadfreebsd-ports-gnome-dcf0cbc7b52d5756945de5f2622656ccc3a31dc2.tar.gz
freebsd-ports-gnome-dcf0cbc7b52d5756945de5f2622656ccc3a31dc2.tar.zst
freebsd-ports-gnome-dcf0cbc7b52d5756945de5f2622656ccc3a31dc2.zip
New port: net/ipdecap
Decapsulate traffic encapsulated within GRE, IPIP, 6in4 and ESP protocols from a pcap file. Can also remove IEEE 802.1Q (virtual lan - vlan) header. WWW: https://loicpefferkorn.net/ipdecap/ PR: 208993 Submitted by: Loic Pefferkorn <loic-freebsd@loicp.eu>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ipdecap/Makefile29
-rw-r--r--net/ipdecap/distinfo2
-rw-r--r--net/ipdecap/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 365df2a890f1..1b4b6cb9bf70 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -252,6 +252,7 @@
SUBDIR += iodine
SUBDIR += ip2location
SUBDIR += ip6_int
+ SUBDIR += ipdecap
SUBDIR += ipgrab
SUBDIR += iplog
SUBDIR += ipsorc
diff --git a/net/ipdecap/Makefile b/net/ipdecap/Makefile
new file mode 100644
index 000000000000..ddb8f90f4f30
--- /dev/null
+++ b/net/ipdecap/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= ipdecap
+PORTVERSION= 0.7.1
+CATEGORIES= net
+
+MAINTAINER= loic-freebsd@loicp.eu
+COMMENT= Decapsulate traffic encapsulated within GRE, IPIP, 6in4, ESP protocols
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pcap/vlan.h:net/libpcap
+LIB_DEPENDS= libpcap.so:net/libpcap
+
+PLIST_FILES= bin/ipdecap\
+ man/man1/ipdecap.1.gz
+
+USE_GITHUB= yes
+GH_ACCOUNT= lpefferkorn
+GH_TAGNAME= e9c6ba5
+
+GNU_CONFIGURE= yes
+USES= autoreconf gmake
+
+regression-test: extract
+ cd ${WRKSRC}/unit_tests && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
+
+.include <bsd.port.mk>
diff --git a/net/ipdecap/distinfo b/net/ipdecap/distinfo
new file mode 100644
index 000000000000..70a9807fc55d
--- /dev/null
+++ b/net/ipdecap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lpefferkorn-ipdecap-0.7.1-e9c6ba5_GH0.tar.gz) = 1def11eb0afb0a5fcbc2de045e71b7c82a140b489ca344b6b543050998cea9fd
+SIZE (lpefferkorn-ipdecap-0.7.1-e9c6ba5_GH0.tar.gz) = 818781
diff --git a/net/ipdecap/pkg-descr b/net/ipdecap/pkg-descr
new file mode 100644
index 000000000000..77d8d5f4bd1d
--- /dev/null
+++ b/net/ipdecap/pkg-descr
@@ -0,0 +1,6 @@
+Decapsulate traffic encapsulated within GRE, IPIP, 6in4 and ESP protocols
+from a pcap file.
+
+Can also remove IEEE 802.1Q (virtual lan - vlan) header.
+
+WWW: https://loicpefferkorn.net/ipdecap/