aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-11-02 05:06:46 +0800
committermarcus <marcus@FreeBSD.org>2006-11-02 05:06:46 +0800
commitdd71a4d249a2de0bc9f69ba1b8222bd38f794a57 (patch)
tree2840fea9d13d24b07c8a99491c4aac91ae6ce88e /net
parentcbd91e64fb1569188a1801e941dc9875e4f7a825 (diff)
downloadfreebsd-ports-gnome-dd71a4d249a2de0bc9f69ba1b8222bd38f794a57.tar.gz
freebsd-ports-gnome-dd71a4d249a2de0bc9f69ba1b8222bd38f794a57.tar.zst
freebsd-ports-gnome-dd71a4d249a2de0bc9f69ba1b8222bd38f794a57.zip
Update to 0.99.4. This release fixes a few security bugs as well as other
functional problems, adds some new features and protocol support, and updates many other protocols. Also: * Force snmp.name searches to be spring searches instead of OIDs. This reverts to ethereal behavior, and works a lot better * Convert to OPTIONS * Add optional RTP stream playback support * Use OPENSSLBASE instead of /usr to pick up ports OpenSSL [1] For a summary of all features and fixes see http://www.wireshark.org/docs/relnotes/wireshark-0.99.4.html . Security: See http://www.wireshark.org/docs/relnotes/wireshark-0.99.4.html for security bugs fixed in this release Requested by: David Wood <david@wood2.org.uk> [1]
Diffstat (limited to 'net')
-rw-r--r--net/wireshark/Makefile49
-rw-r--r--net/wireshark/distinfo6
-rw-r--r--net/wireshark/files/patch-epan_dissectors_packet-snmp.c11
-rw-r--r--net/wireshark/pkg-plist4
4 files changed, 59 insertions, 11 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 1a3e62e49afa..7fd78c4741ad 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= wireshark
-PORTVERSION= 0.99.3a
+PORTVERSION= 0.99.4
PORTREVISION?= 0
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/
@@ -22,15 +22,20 @@ USE_PYTHON_BUILD=yes
USE_ICONV= yes
USE_BZIP2= yes
USE_GCC= 3.4+
+USE_GMAKE= yes
USE_GNOME= gnometarget
WANT_GNOME= yes
USE_OPENSSL= yes
-CONFIGURE_ENV= MIBDIRS="/dev/null"
+CONFIGURE_ENV= MIBDIRS="/dev/null" \
+ LIBS="${WIRESHARK_LIBS}"
CONFIGURE_ARGS+= --program-transform-name="" \
- --with-ssl=/usr
+ --with-ssl=${OPENSSLBASE}
MAKE_ENV= MIBDIRS="/dev/null"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+WIRESHARK_LIBS=
.for x in capinfos editcap idl2wrs mergecap text2pcap
.if defined(LITE)
@@ -55,6 +60,13 @@ PLIST_SUB+= ${x:U}=bin/$x
USE_XLIB= yes
.endif
+.if !defined(LITE)
+OPTIONS= RTP "Enable support for playing back RTP streams" off \
+ SNMP "Enable SNMP OID translation support" on \
+ ADNS "Enable asynchronous DNS lookup support" on \
+ PCRE "Enable regular expression matching support" on
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
@@ -65,6 +77,7 @@ USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
.else
USE_GNOME+= gtk20
+WIRESHARK_LIBS+=${PTHREAD_LIBS}
.endif
.else
PLIST_SUB+= WIRESHARK="@comment wireshark not built"
@@ -97,11 +110,29 @@ CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-pcre=no
.endif
+#.if defined(WITH_LUA) && !defined(LITE)
+#USE_LUA= 5.1
+#CONFIGURE_ARGS+=--with-lua=${LUA_PREFIX}
+#PLIST_SUB+= LUA=""
+#.else
+CONFIGURE_ARGS+=--without-lua
+#PLIST_SUB+= LUA="@comment "
+#.endif
+
+.if defined(WITH_RTP) && !defined(LITE)
+LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio
+CONFIGURE_ARGS+=--with-portaudio=${LOCALBASE}
+WIRESHARK_LIBS+=${PTHREAD_LIBS}
+.else
+CONFIGURE_ARGS+=--without-portaudio
+.endif
+
.if !defined(WITHOUT_SNMP) && !defined(LITE)
LIB_DEPENDS+= netsnmp.9:${PORTSDIR}/net-mgmt/net-snmp
-CONFIGURE_ARGS+= --with-net-snmp=${LOCALBASE}/bin/net-snmp-config
+CONFIGURE_ARGS+= --with-net-snmp=${LOCALBASE}/bin/net-snmp-config \
+ --without-ucd-snmp
.else
-CONFIGURE_ARGS+= --enable-snmp=no --with-ucd-snmp=no --with-net-snmp=no
+CONFIGURE_ARGS+= --with-ucd-snmp=no --with-net-snmp=no
.endif
.if !defined(WITHOUT_ADNS) && !defined(LITE)
@@ -124,4 +155,10 @@ CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
MAN1+= dumpcap.1 tshark.1
MAN4+= wireshark-filter.4
+post-patch:
+ @${REINPLACE_CMD} -e 's|lua5\.1|lua${LUA_VER_STR}|g ; \
+ s|NETSNMPCNFIG|NETSNMPCONFIG| ; \
+ s|-llua${LUA_VER_STR}|${LUA_LIBDIR}/liblua.a|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index d5f0a09e4e5c..5c2978f557fb 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1,3 +1,3 @@
-MD5 (wireshark-0.99.3a.tar.bz2) = 3eca72f5875204e25552bb3dabfec115
-SHA256 (wireshark-0.99.3a.tar.bz2) = dc1cc15fa9dd788d118f60e8a5ad272ab39c8ba471337449d3ab0a1eb06f5766
-SIZE (wireshark-0.99.3a.tar.bz2) = 10049208
+MD5 (wireshark-0.99.4.tar.bz2) = 05fada181e12bfa94b52f0b10395b28c
+SHA256 (wireshark-0.99.4.tar.bz2) = a4f15c73e2b67c888cbedfaa8093661dff6cb859357c197c60f3026baddb939e
+SIZE (wireshark-0.99.4.tar.bz2) = 10472441
diff --git a/net/wireshark/files/patch-epan_dissectors_packet-snmp.c b/net/wireshark/files/patch-epan_dissectors_packet-snmp.c
new file mode 100644
index 000000000000..42413f5bee51
--- /dev/null
+++ b/net/wireshark/files/patch-epan_dissectors_packet-snmp.c
@@ -0,0 +1,11 @@
+--- epan/dissectors/packet-snmp.c.orig Wed Nov 1 14:44:36 2006
++++ epan/dissectors/packet-snmp.c Wed Nov 1 14:44:49 2006
+@@ -3305,7 +3305,7 @@ void proto_register_snmp(void) {
+ "snmp.TimeTicks", HFILL }},
+ { &hf_snmp_name,
+ { "name", "snmp.name",
+- FT_OID, BASE_NONE, NULL, 0,
++ FT_STRING, BASE_NONE, NULL, 0,
+ "snmp.ObjectName", HFILL }},
+ { &hf_snmp_valueType,
+ { "valueType", "snmp.valueType",
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index 2f66f01677e1..f04c2d3b3447 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -48,8 +48,6 @@ lib/wireshark/plugins/%%PORTVERSION%%/pcli.la
lib/wireshark/plugins/%%PORTVERSION%%/pcli.so
lib/wireshark/plugins/%%PORTVERSION%%/profinet.la
lib/wireshark/plugins/%%PORTVERSION%%/profinet.so
-lib/wireshark/plugins/%%PORTVERSION%%/rdm.la
-lib/wireshark/plugins/%%PORTVERSION%%/rdm.so
lib/wireshark/plugins/%%PORTVERSION%%/rlm.la
lib/wireshark/plugins/%%PORTVERSION%%/rlm.so
lib/wireshark/plugins/%%PORTVERSION%%/rtnet.la
@@ -71,6 +69,7 @@ lib/libwiretap.la
lib/libwiretap.so
lib/libwiretap.so.0
%%DATADIR%%/AUTHORS-SHORT
+%%DATADIR%%/COPYING
%%DATADIR%%/capinfos.html
%%DATADIR%%/cfilters
%%DATADIR%%/colorfilters
@@ -89,6 +88,7 @@ lib/libwiretap.so.0
%%DATADIR%%/dtds/pocsettings.dtd
%%DATADIR%%/dtds/presence.dtd
%%DATADIR%%/dtds/reginfo.dtd
+%%DATADIR%%/dtds/rlmi.dtd
%%DATADIR%%/dtds/rss.dtd
%%DATADIR%%/dtds/smil.dtd
%%DATADIR%%/dtds/watcherinfo.dtd