aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-03-25 02:49:56 +0800
committerlioux <lioux@FreeBSD.org>2001-03-25 02:49:56 +0800
commite2abbdb24bb3b29fed02da3013065d44cefc8058 (patch)
treee535e4130c456069ed0cba5c7b1e8a30683e6c62 /net
parent425e9252d2f58bce822b3f10ec19d900810c8979 (diff)
downloadfreebsd-ports-gnome-e2abbdb24bb3b29fed02da3013065d44cefc8058.tar.gz
freebsd-ports-gnome-e2abbdb24bb3b29fed02da3013065d44cefc8058.tar.zst
freebsd-ports-gnome-e2abbdb24bb3b29fed02da3013065d44cefc8058.zip
A fully compliant DynDNS.org client for UNIX (supports NIC v2.0)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ipcheck/Makefile31
-rw-r--r--net/ipcheck/distinfo1
-rw-r--r--net/ipcheck/pkg-comment1
-rw-r--r--net/ipcheck/pkg-descr22
-rw-r--r--net/ipcheck/pkg-plist1
6 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f766d2040c96..8ed06f40afe7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -125,6 +125,7 @@
SUBDIR += icqlib0
SUBDIR += icqnix
SUBDIR += ip-tun
+ SUBDIR += ipcheck
SUBDIR += ipfm
SUBDIR += iplog
SUBDIR += ipw
diff --git a/net/ipcheck/Makefile b/net/ipcheck/Makefile
new file mode 100644
index 000000000000..387133f92765
--- /dev/null
+++ b/net/ipcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ipcheck
+# Date created: 24 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipcheck
+PORTVERSION= 0.85
+CATEGORIES= net
+MASTER_SITES= http://ipcheck.sourceforge.net/
+DISTNAME= ipcheck.py
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-patch:
+ @${SED} -e "s!/usr/bin/python!${LOCALBASE}/bin/python!" \
+ -e "s!ppp0!tun0!" \
+ ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${DISTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/ipcheck/distinfo b/net/ipcheck/distinfo
new file mode 100644
index 000000000000..e87c75092431
--- /dev/null
+++ b/net/ipcheck/distinfo
@@ -0,0 +1 @@
+MD5 (ipcheck.py) = 29b6823d6d1bcfa3e6544fd8b78d889c
diff --git a/net/ipcheck/pkg-comment b/net/ipcheck/pkg-comment
new file mode 100644
index 000000000000..d93a7f7fb134
--- /dev/null
+++ b/net/ipcheck/pkg-comment
@@ -0,0 +1 @@
+A fully compliant DynDNS.org client for UNIX (supports NIC v2.0)
diff --git a/net/ipcheck/pkg-descr b/net/ipcheck/pkg-descr
new file mode 100644
index 000000000000..c0b6001e7c6f
--- /dev/null
+++ b/net/ipcheck/pkg-descr
@@ -0,0 +1,22 @@
+[from web site]
+This is a simple Python script to register your dynamic IP address
+using the NIC V2.0 protocol. We aim to be fully compliant with the
+dyndns client specification.
+
+We currently support all options and latest recommendations by
+Dyndns. Ipcheck is easy to install and very easy to use.
+
+Root access is not required and no configuration files are needed.
+
+Just specify your username, password and hostname(s) on the command
+line (or cron entry).
+
+You can specify the interface (default tun0) to search for your ip
+address on or use web based IP detection.
+
+There is also direct support for determining the IP address on the
+following devices: Linksys (-L), Netgear (-N), Draytek (-D), Netopia
+(-O), HawkingTech (-H), Cisco 667i (-C), Cisco 700 series (-I),
+ZyXEL Prestige (-Z), SMC Barricade (-S)
+
+WWW: http://ipcheck.sourceforge.net/
diff --git a/net/ipcheck/pkg-plist b/net/ipcheck/pkg-plist
new file mode 100644
index 000000000000..ae286ad3ac52
--- /dev/null
+++ b/net/ipcheck/pkg-plist
@@ -0,0 +1 @@
+bin/ipcheck.py