aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2019-01-06 20:18:06 +0800
committerGleb Popov <arrowd@FreeBSD.org>2019-01-06 20:18:06 +0800
commite2c3fdc1fdeca1ffbdfef680e3e712ddc2e7e06f (patch)
treeec6e8ffeefbf83bfc231412c2c7a6b883ecd5bd8 /net
parente8d137116e2942f75f1fed8f603384210db17ec0 (diff)
downloadfreebsd-ports-gnome-e2c3fdc1fdeca1ffbdfef680e3e712ddc2e7e06f.tar.gz
freebsd-ports-gnome-e2c3fdc1fdeca1ffbdfef680e3e712ddc2e7e06f.tar.zst
freebsd-ports-gnome-e2c3fdc1fdeca1ffbdfef680e3e712ddc2e7e06f.zip
lang/ghc: Update to 8.6.3 and bump PORTREVISION's of all Haskell ports.
As usual, it is recommended to rebuild or reinstall all the dependent ports and the lang/ghc port itself in one of the following ways: # portmaster -w -r ghc or # portupgrade -fr lang/ghc In case of pkg(8), it is probably safer to remove all the GHC-dependent packages along with GHC and reinstall everything from scratch. For example: # pkg query "%ro" ghc > ghc-pkgs.txt # pkg delete -y lang/ghc # pkg install -y `cat ghc-pkgs.txt` During update some hs-* ports got two PORTREVISION bumps in a row. Other ports got a PORTVERSION update together with one PORTREVISION bump. This is caused by bulk-bumping PORTREVISION of all hs-* ports. There are a lot of them updated, so figuring out which ones require a bump and which are not is too tedious. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D18707
Diffstat (limited to 'net')
-rw-r--r--net/hs-aws/Makefile1
-rw-r--r--net/hs-bsb-http-chunked/Makefile2
-rw-r--r--net/hs-bsb-http-chunked/distinfo6
-rw-r--r--net/hs-bsb-http-chunked/files/patch-bsb-http-chunked.cabal9
-rw-r--r--net/hs-connection/Makefile2
-rw-r--r--net/hs-gsasl/Makefile2
-rw-r--r--net/hs-hoauth2/Makefile2
-rw-r--r--net/hs-hostname/Makefile2
-rw-r--r--net/hs-iproute/Makefile2
-rw-r--r--net/hs-maccatcher/Makefile2
-rw-r--r--net/hs-network-info/Makefile1
-rw-r--r--net/hs-network-multicast/Makefile2
-rw-r--r--net/hs-network-protocol-xmpp/Makefile2
-rw-r--r--net/hs-network-uri/Makefile2
-rw-r--r--net/hs-network/Makefile2
-rw-r--r--net/hs-pcap/Makefile2
-rw-r--r--net/hs-publicsuffixlist/Makefile2
-rw-r--r--net/hs-resolv/Makefile2
-rw-r--r--net/hs-resolv/files/patch-resolv.cabal11
-rw-r--r--net/hs-sendfile/Makefile2
-rw-r--r--net/hs-simple-sendfile/Makefile2
-rw-r--r--net/hs-socks/Makefile2
22 files changed, 30 insertions, 32 deletions
diff --git a/net/hs-aws/Makefile b/net/hs-aws/Makefile
index 0666f84b4715..548506fac97a 100644
--- a/net/hs-aws/Makefile
+++ b/net/hs-aws/Makefile
@@ -2,6 +2,7 @@
PORTNAME= aws
PORTVERSION= 0.20
+PORTREVISION= 1
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-bsb-http-chunked/Makefile b/net/hs-bsb-http-chunked/Makefile
index 55dcca5f44f4..0548c2975fa0 100644
--- a/net/hs-bsb-http-chunked/Makefile
+++ b/net/hs-bsb-http-chunked/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= bsb-http-chunked
-PORTVERSION= 0.0.0.2
+PORTVERSION= 0.0.0.4
PORTREVISION= 1
CATEGORIES= net haskell
diff --git a/net/hs-bsb-http-chunked/distinfo b/net/hs-bsb-http-chunked/distinfo
index 0ef011a0535b..5c8f04d8c17b 100644
--- a/net/hs-bsb-http-chunked/distinfo
+++ b/net/hs-bsb-http-chunked/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524928561
-SHA256 (cabal/bsb-http-chunked-0.0.0.2.tar.gz) = 28cb750979763c815fbf69a6dc510f837b7ccbe262adf0a28ad270966737d5f4
-SIZE (cabal/bsb-http-chunked-0.0.0.2.tar.gz) = 6503
+TIMESTAMP = 1545495255
+SHA256 (cabal/bsb-http-chunked-0.0.0.4.tar.gz) = 148309e23eb8b261c1de374712372d62d8c8dc8ee504c392809c7ec33c0a0e7c
+SIZE (cabal/bsb-http-chunked-0.0.0.4.tar.gz) = 6630
diff --git a/net/hs-bsb-http-chunked/files/patch-bsb-http-chunked.cabal b/net/hs-bsb-http-chunked/files/patch-bsb-http-chunked.cabal
deleted file mode 100644
index 4c3d7444036f..000000000000
--- a/net/hs-bsb-http-chunked/files/patch-bsb-http-chunked.cabal
+++ /dev/null
@@ -1,9 +0,0 @@
---- bsb-http-chunked.cabal.orig 2018-04-28 15:19:50 UTC
-+++ bsb-http-chunked.cabal
-@@ -43,5 +43,4 @@ Library
- Blaze.ByteString.Builder.Internal.Write
-
- build-depends: base >= 4.3 && < 4.12,
-- bytestring >= 0.9 && < 0.11,
-- bytestring-builder < 0.11
-+ bytestring >= 0.9 && < 0.11
diff --git a/net/hs-connection/Makefile b/net/hs-connection/Makefile
index 1576479079f5..c247122b239f 100644
--- a/net/hs-connection/Makefile
+++ b/net/hs-connection/Makefile
@@ -2,7 +2,7 @@
PORTNAME= connection
PORTVERSION= 0.2.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-gsasl/Makefile b/net/hs-gsasl/Makefile
index 04aa6f834eef..1079d7c6b287 100644
--- a/net/hs-gsasl/Makefile
+++ b/net/hs-gsasl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gsasl
PORTVERSION= 0.3.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-hoauth2/Makefile b/net/hs-hoauth2/Makefile
index 05df1bed48a0..cf223794473c 100644
--- a/net/hs-hoauth2/Makefile
+++ b/net/hs-hoauth2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hoauth2
PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
index 6697122f8328..1fdeb18486f8 100644
--- a/net/hs-hostname/Makefile
+++ b/net/hs-hostname/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostname
PORTVERSION= 1.0
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-iproute/Makefile b/net/hs-iproute/Makefile
index 66569e20a09d..f8939c576bd6 100644
--- a/net/hs-iproute/Makefile
+++ b/net/hs-iproute/Makefile
@@ -2,7 +2,7 @@
PORTNAME= iproute
PORTVERSION= 1.7.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-maccatcher/Makefile b/net/hs-maccatcher/Makefile
index 02151aecb827..4d9dc6e27f1a 100644
--- a/net/hs-maccatcher/Makefile
+++ b/net/hs-maccatcher/Makefile
@@ -2,7 +2,7 @@
PORTNAME= maccatcher
PORTVERSION= 2.1.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-info/Makefile b/net/hs-network-info/Makefile
index 6f46a10aed83..06ab44b123a5 100644
--- a/net/hs-network-info/Makefile
+++ b/net/hs-network-info/Makefile
@@ -2,6 +2,7 @@
PORTNAME= network-info
PORTVERSION= 0.2.0.10
+PORTREVISION= 1
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-multicast/Makefile b/net/hs-network-multicast/Makefile
index 1d90e0433826..3cad3e6bb3b6 100644
--- a/net/hs-network-multicast/Makefile
+++ b/net/hs-network-multicast/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network-multicast
PORTVERSION= 0.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-protocol-xmpp/Makefile b/net/hs-network-protocol-xmpp/Makefile
index b9a662c7cbd9..8308c78ff7dd 100644
--- a/net/hs-network-protocol-xmpp/Makefile
+++ b/net/hs-network-protocol-xmpp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network-protocol-xmpp
PORTVERSION= 0.4.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-uri/Makefile b/net/hs-network-uri/Makefile
index 76b529c5ec89..24d85aa239b5 100644
--- a/net/hs-network-uri/Makefile
+++ b/net/hs-network-uri/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network-uri
PORTVERSION= 2.6.1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network/Makefile b/net/hs-network/Makefile
index d15ce6f489b8..a0df2e673a75 100644
--- a/net/hs-network/Makefile
+++ b/net/hs-network/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network
PORTVERSION= 2.6.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-pcap/Makefile b/net/hs-pcap/Makefile
index af88c3774da9..70adc968931a 100644
--- a/net/hs-pcap/Makefile
+++ b/net/hs-pcap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pcap
PORTVERSION= 0.4.5.2
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-publicsuffixlist/Makefile b/net/hs-publicsuffixlist/Makefile
index c22c0738f3fd..33f0ce32918d 100644
--- a/net/hs-publicsuffixlist/Makefile
+++ b/net/hs-publicsuffixlist/Makefile
@@ -2,7 +2,7 @@
PORTNAME= publicsuffixlist
PORTVERSION= 0.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-resolv/Makefile b/net/hs-resolv/Makefile
index 6abb0a6cc712..f299ed5de0bd 100644
--- a/net/hs-resolv/Makefile
+++ b/net/hs-resolv/Makefile
@@ -2,7 +2,7 @@
PORTNAME= resolv
PORTVERSION= 0.1.1.1
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-resolv/files/patch-resolv.cabal b/net/hs-resolv/files/patch-resolv.cabal
index 7bf02d0ad6ac..e4b5d13960e6 100644
--- a/net/hs-resolv/files/patch-resolv.cabal
+++ b/net/hs-resolv/files/patch-resolv.cabal
@@ -1,11 +1,16 @@
---- resolv.cabal.orig 2018-04-09 19:24:44 UTC
+--- resolv.cabal.orig 2017-10-26 22:24:39 UTC
+++ resolv.cabal
-@@ -78,7 +78,7 @@ library
+@@ -78,11 +78,11 @@ library
Network.DNS.FFI
Compat
- build-depends: base >= 4.5 && <4.11
-+ build-depends: base >= 4.5 && <4.12
++ build-depends: base >= 4.5 && <4.13
, base16-bytestring == 0.1.*
, binary >= 0.7.3 && < 0.9
, bytestring >= 0.9.2 && < 0.11
+- , containers >= 0.4.2.1 && < 0.6
++ , containers >= 0.4.2.1 && < 0.7
+
+ ghc-options: -Wall
+ include-dirs: cbits
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
index 1176dcd63a69..e1e8bd251d41 100644
--- a/net/hs-sendfile/Makefile
+++ b/net/hs-sendfile/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sendfile
PORTVERSION= 0.7.9
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
index 1586c6fa5c3c..a42c2edff34b 100644
--- a/net/hs-simple-sendfile/Makefile
+++ b/net/hs-simple-sendfile/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simple-sendfile
PORTVERSION= 0.2.25
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-socks/Makefile b/net/hs-socks/Makefile
index 278ecd027681..235767762805 100644
--- a/net/hs-socks/Makefile
+++ b/net/hs-socks/Makefile
@@ -2,7 +2,7 @@
PORTNAME= socks
PORTVERSION= 0.5.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org