aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-03-03 01:05:25 +0800
committerflo <flo@FreeBSD.org>2011-03-03 01:05:25 +0800
commite76b40c45e673ff050618eb91c511fd26afec126 (patch)
tree1a032e3ff44b1c94e26bd596b03b32f28cb40fd7 /net
parente1dbbd626a05b8e12ea4acd59144d289e5e378eb (diff)
downloadfreebsd-ports-gnome-e76b40c45e673ff050618eb91c511fd26afec126.tar.gz
freebsd-ports-gnome-e76b40c45e673ff050618eb91c511fd26afec126.tar.zst
freebsd-ports-gnome-e76b40c45e673ff050618eb91c511fd26afec126.zip
- Update to 1.8.3
- add a new option NEWG711, off by default. It enables a new algorithm for G711 which should be cleaner but slower
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile10
-rw-r--r--net/asterisk/distinfo4
-rw-r--r--net/asterisk/files/extra-patch-menuselect-tree-g711-new-codec.diff10
-rw-r--r--net/asterisk/files/patch-Makefile23
-rw-r--r--net/asterisk/files/patch-configure30
-rw-r--r--net/asterisk10/Makefile10
-rw-r--r--net/asterisk10/distinfo4
-rw-r--r--net/asterisk10/files/extra-patch-menuselect-tree-g711-new-codec.diff10
-rw-r--r--net/asterisk10/files/patch-Makefile23
-rw-r--r--net/asterisk10/files/patch-configure30
10 files changed, 92 insertions, 62 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index b146b218c7d8..898c75b5ce10 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.2.4
-PORTREVISION= 1
+PORTVERSION= 1.8.3
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -60,7 +59,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CURL "Enable CURL support" on \
ILBC "Enable iLBC codec" off \
SPANDSP "Enable Spandsp faxing support" off \
- EXCHANGE "Enable Exchange calendar support" off
+ EXCHANGE "Enable Exchange calendar support" off \
+ NEWG711 "Enable new G711 Codes"
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -253,6 +253,10 @@ LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
PLIST_SUB+= WITH_EXCHANGE=""
.endif
+.if defined(WITH_NEWG711)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
+.endif
+
.if defined(WITH_MISC_PATCHES)
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index 259d703524f6..e17e3277a6f9 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.2.4.tar.gz) = 978dc9b1f4585c31fafa23a86e347ad46a75d8b438c059423f804bea088bbb1d
-SIZE (asterisk-1.8.2.4.tar.gz) = 26802859
+SHA256 (asterisk-1.8.3.tar.gz) = 976ae6dea0c22033049af8b8d19c9e058f13a04ba49a13b2ce9da9d2d4c07395
+SIZE (asterisk-1.8.3.tar.gz) = 26806503
diff --git a/net/asterisk/files/extra-patch-menuselect-tree-g711-new-codec.diff b/net/asterisk/files/extra-patch-menuselect-tree-g711-new-codec.diff
new file mode 100644
index 000000000000..d93e9cb28b17
--- /dev/null
+++ b/net/asterisk/files/extra-patch-menuselect-tree-g711-new-codec.diff
@@ -0,0 +1,10 @@
+--- menuselect-tree.orig 2011-02-21 09:56:29.000000000 +0100
++++ menuselect-tree 2011-02-21 09:56:46.000000000 +0100
+@@ -777,7 +777,6 @@
+ <member name="RADIO_RELAX" displayname="Relax DTMF for Radio Applications">
+ </member>
+ <member name="G711_NEW_ALGORITHM" displayname="Use the NEW ulaw/alaw codecs (slower, but cleaner)">
+- <defaultenabled>no</defaultenabled>
+ </member>
+ <member name="G711_REDUCED_BRANCHING" displayname="New ulaw/alaw codec, reduced branching (might help it run faster in some architectures)">
+ <depend>G711_NEW_ALGORITHM</depend>
diff --git a/net/asterisk/files/patch-Makefile b/net/asterisk/files/patch-Makefile
index 20cf399c3504..9dc24fa96ebe 100644
--- a/net/asterisk/files/patch-Makefile
+++ b/net/asterisk/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2010-12-08 03:51:05.000000000 +0500
-+++ Makefile 2011-01-15 04:05:06.000000000 +0500
+--- Makefile.orig 2011-01-12 16:57:43.000000000 +0100
++++ Makefile 2011-03-02 11:34:26.000000000 +0100
@@ -122,7 +122,7 @@
OVERWRITE=y
@@ -32,28 +32,29 @@
_ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
endif
-@@ -463,13 +465,17 @@
+@@ -463,13 +465,18 @@
done
- $(INSTALL) -m 644 doc/core-en_US.xml $(DESTDIR)$(ASTDATADIR)/static-http;
+ $(INSTALL) -m 644 doc/core-en_US.xml "$(DESTDIR)$(ASTDATADIR)/static-http";
if [ -d doc/tex/asterisk ] ; then \
-- $(INSTALL) -d $(DESTDIR)$(ASTDATADIR)/static-http/docs ; \
+- $(INSTALL) -d "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
+ $(INSTALL) -d $(DESTDIR)$(DOCSDIR) ; \
+ $(INSTALL) -d $(DESTDIR)$(DOCSDIR)/images ; \
for n in doc/tex/asterisk/* ; do \
-- $(INSTALL) -m 644 $$n $(DESTDIR)$(ASTDATADIR)/static-http/docs ; \
+- $(INSTALL) -m 644 $$n "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
+ $(INSTALL) -m 644 $$n $(DESTDIR)$(DOCSDIR) ; \
done \
fi
+ if [ ! -d $(DESTDIR)$(DOCSDIR)/images ]; then \
+ $(MKDIR) $(DESTDIR)$(DOCSDIR)/images; \
+ fi
++
for x in images/*.jpg; do \
-- $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTDATADIR)/images ; \
+- $(INSTALL) -m 644 $$x "$(DESTDIR)$(ASTDATADIR)/images" ; \
+ $(INSTALL) -m 644 $$x $(DESTDIR)$(DOCSDIR)/images ; \
done
$(MAKE) -C sounds install
-@@ -529,6 +535,7 @@
+@@ -529,6 +536,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/dictate"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/meetme"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/monitor"
@@ -61,7 +62,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/system"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/tmp"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/voicemail"
-@@ -550,6 +557,7 @@
+@@ -550,6 +558,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTDATADIR)/static-http"
$(INSTALL) -d "$(DESTDIR)$(ASTMANDIR)/man8"
$(INSTALL) -d "$(DESTDIR)$(AGI_DIR)"
@@ -69,7 +70,7 @@
bininstall: _all installdirs $(SUBDIRS_INSTALL)
$(INSTALL) -m 755 main/asterisk $(DESTDIR)$(ASTSBINDIR)/
-@@ -609,7 +617,7 @@
+@@ -609,7 +618,7 @@
@exit 1
endif
@@ -78,7 +79,7 @@
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
fi
-@@ -651,29 +659,18 @@
+@@ -651,29 +660,18 @@
else \
echo "Installing $$x" ; \
fi ; \
diff --git a/net/asterisk/files/patch-configure b/net/asterisk/files/patch-configure
index 1b5bf55ded99..7f9d1a6a71f1 100644
--- a/net/asterisk/files/patch-configure
+++ b/net/asterisk/files/patch-configure
@@ -1,14 +1,14 @@
---- configure.orig 2011-01-25 00:37:33.000000000 +0100
-+++ configure 2011-01-25 00:39:33.000000000 +0100
-@@ -621,7 +621,6 @@
+--- configure.orig 2011-01-09 22:40:34.000000000 +0100
++++ configure 2011-03-02 00:16:16.000000000 +0100
+@@ -600,7 +600,6 @@
ac_default_prefix=/usr/local
ac_default_prefix=/usr/local
ac_default_prefix=/usr/local
-ac_default_prefix=/usr
ac_header_list=
- ac_subst_vars='SHELL
- PATH_SEPARATOR
-@@ -4279,9 +4278,9 @@
+ ac_subst_vars='LTLIBOBJS
+ PBX_SYSLOG
+@@ -4677,9 +4676,9 @@
astheaderdir='${includedir}/asterisk'
astlibdir='${libdir}/asterisk'
astmandir='${mandir}'
@@ -20,7 +20,7 @@
astkeydir='${astvarlibdir}'
astspooldir='${localstatedir}/spool/asterisk'
astlogdir='${localstatedir}/log/asterisk'
-@@ -4303,9 +4302,6 @@
+@@ -4701,9 +4700,6 @@
case "${host_os}" in
freebsd*)
@@ -30,16 +30,16 @@
;;
openbsd*)
-@@ -27494,6 +27490,8 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
+@@ -17558,6 +17554,8 @@
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #include <ifaddrs.h>
++ #include <sys/types.h>
++ #include <sys/socket.h>
+ #include <ifaddrs.h>
int
main ()
-@@ -45012,7 +45010,7 @@
+@@ -25364,7 +25362,7 @@
fi
@@ -47,4 +47,4 @@
+ PLATFORM_OPENH323="h323_${OPENH323_SUFFIX}"
if test "${HAS_OPENH323:-unset}" != "unset"; then
- { echo "$as_me:$LINENO: checking OpenH323 installation validity" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking OpenH323 installation validity" >&5
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index b146b218c7d8..898c75b5ce10 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.2.4
-PORTREVISION= 1
+PORTVERSION= 1.8.3
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -60,7 +59,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CURL "Enable CURL support" on \
ILBC "Enable iLBC codec" off \
SPANDSP "Enable Spandsp faxing support" off \
- EXCHANGE "Enable Exchange calendar support" off
+ EXCHANGE "Enable Exchange calendar support" off \
+ NEWG711 "Enable new G711 Codes"
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -253,6 +253,10 @@ LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
PLIST_SUB+= WITH_EXCHANGE=""
.endif
+.if defined(WITH_NEWG711)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
+.endif
+
.if defined(WITH_MISC_PATCHES)
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff
diff --git a/net/asterisk10/distinfo b/net/asterisk10/distinfo
index 259d703524f6..e17e3277a6f9 100644
--- a/net/asterisk10/distinfo
+++ b/net/asterisk10/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.2.4.tar.gz) = 978dc9b1f4585c31fafa23a86e347ad46a75d8b438c059423f804bea088bbb1d
-SIZE (asterisk-1.8.2.4.tar.gz) = 26802859
+SHA256 (asterisk-1.8.3.tar.gz) = 976ae6dea0c22033049af8b8d19c9e058f13a04ba49a13b2ce9da9d2d4c07395
+SIZE (asterisk-1.8.3.tar.gz) = 26806503
diff --git a/net/asterisk10/files/extra-patch-menuselect-tree-g711-new-codec.diff b/net/asterisk10/files/extra-patch-menuselect-tree-g711-new-codec.diff
new file mode 100644
index 000000000000..d93e9cb28b17
--- /dev/null
+++ b/net/asterisk10/files/extra-patch-menuselect-tree-g711-new-codec.diff
@@ -0,0 +1,10 @@
+--- menuselect-tree.orig 2011-02-21 09:56:29.000000000 +0100
++++ menuselect-tree 2011-02-21 09:56:46.000000000 +0100
+@@ -777,7 +777,6 @@
+ <member name="RADIO_RELAX" displayname="Relax DTMF for Radio Applications">
+ </member>
+ <member name="G711_NEW_ALGORITHM" displayname="Use the NEW ulaw/alaw codecs (slower, but cleaner)">
+- <defaultenabled>no</defaultenabled>
+ </member>
+ <member name="G711_REDUCED_BRANCHING" displayname="New ulaw/alaw codec, reduced branching (might help it run faster in some architectures)">
+ <depend>G711_NEW_ALGORITHM</depend>
diff --git a/net/asterisk10/files/patch-Makefile b/net/asterisk10/files/patch-Makefile
index 20cf399c3504..9dc24fa96ebe 100644
--- a/net/asterisk10/files/patch-Makefile
+++ b/net/asterisk10/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2010-12-08 03:51:05.000000000 +0500
-+++ Makefile 2011-01-15 04:05:06.000000000 +0500
+--- Makefile.orig 2011-01-12 16:57:43.000000000 +0100
++++ Makefile 2011-03-02 11:34:26.000000000 +0100
@@ -122,7 +122,7 @@
OVERWRITE=y
@@ -32,28 +32,29 @@
_ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
endif
-@@ -463,13 +465,17 @@
+@@ -463,13 +465,18 @@
done
- $(INSTALL) -m 644 doc/core-en_US.xml $(DESTDIR)$(ASTDATADIR)/static-http;
+ $(INSTALL) -m 644 doc/core-en_US.xml "$(DESTDIR)$(ASTDATADIR)/static-http";
if [ -d doc/tex/asterisk ] ; then \
-- $(INSTALL) -d $(DESTDIR)$(ASTDATADIR)/static-http/docs ; \
+- $(INSTALL) -d "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
+ $(INSTALL) -d $(DESTDIR)$(DOCSDIR) ; \
+ $(INSTALL) -d $(DESTDIR)$(DOCSDIR)/images ; \
for n in doc/tex/asterisk/* ; do \
-- $(INSTALL) -m 644 $$n $(DESTDIR)$(ASTDATADIR)/static-http/docs ; \
+- $(INSTALL) -m 644 $$n "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
+ $(INSTALL) -m 644 $$n $(DESTDIR)$(DOCSDIR) ; \
done \
fi
+ if [ ! -d $(DESTDIR)$(DOCSDIR)/images ]; then \
+ $(MKDIR) $(DESTDIR)$(DOCSDIR)/images; \
+ fi
++
for x in images/*.jpg; do \
-- $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTDATADIR)/images ; \
+- $(INSTALL) -m 644 $$x "$(DESTDIR)$(ASTDATADIR)/images" ; \
+ $(INSTALL) -m 644 $$x $(DESTDIR)$(DOCSDIR)/images ; \
done
$(MAKE) -C sounds install
-@@ -529,6 +535,7 @@
+@@ -529,6 +536,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/dictate"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/meetme"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/monitor"
@@ -61,7 +62,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/system"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/tmp"
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/voicemail"
-@@ -550,6 +557,7 @@
+@@ -550,6 +558,7 @@
$(INSTALL) -d "$(DESTDIR)$(ASTDATADIR)/static-http"
$(INSTALL) -d "$(DESTDIR)$(ASTMANDIR)/man8"
$(INSTALL) -d "$(DESTDIR)$(AGI_DIR)"
@@ -69,7 +70,7 @@
bininstall: _all installdirs $(SUBDIRS_INSTALL)
$(INSTALL) -m 755 main/asterisk $(DESTDIR)$(ASTSBINDIR)/
-@@ -609,7 +617,7 @@
+@@ -609,7 +618,7 @@
@exit 1
endif
@@ -78,7 +79,7 @@
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
fi
-@@ -651,29 +659,18 @@
+@@ -651,29 +660,18 @@
else \
echo "Installing $$x" ; \
fi ; \
diff --git a/net/asterisk10/files/patch-configure b/net/asterisk10/files/patch-configure
index 1b5bf55ded99..7f9d1a6a71f1 100644
--- a/net/asterisk10/files/patch-configure
+++ b/net/asterisk10/files/patch-configure
@@ -1,14 +1,14 @@
---- configure.orig 2011-01-25 00:37:33.000000000 +0100
-+++ configure 2011-01-25 00:39:33.000000000 +0100
-@@ -621,7 +621,6 @@
+--- configure.orig 2011-01-09 22:40:34.000000000 +0100
++++ configure 2011-03-02 00:16:16.000000000 +0100
+@@ -600,7 +600,6 @@
ac_default_prefix=/usr/local
ac_default_prefix=/usr/local
ac_default_prefix=/usr/local
-ac_default_prefix=/usr
ac_header_list=
- ac_subst_vars='SHELL
- PATH_SEPARATOR
-@@ -4279,9 +4278,9 @@
+ ac_subst_vars='LTLIBOBJS
+ PBX_SYSLOG
+@@ -4677,9 +4676,9 @@
astheaderdir='${includedir}/asterisk'
astlibdir='${libdir}/asterisk'
astmandir='${mandir}'
@@ -20,7 +20,7 @@
astkeydir='${astvarlibdir}'
astspooldir='${localstatedir}/spool/asterisk'
astlogdir='${localstatedir}/log/asterisk'
-@@ -4303,9 +4302,6 @@
+@@ -4701,9 +4700,6 @@
case "${host_os}" in
freebsd*)
@@ -30,16 +30,16 @@
;;
openbsd*)
-@@ -27494,6 +27490,8 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
+@@ -17558,6 +17554,8 @@
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #include <ifaddrs.h>
++ #include <sys/types.h>
++ #include <sys/socket.h>
+ #include <ifaddrs.h>
int
main ()
-@@ -45012,7 +45010,7 @@
+@@ -25364,7 +25362,7 @@
fi
@@ -47,4 +47,4 @@
+ PLATFORM_OPENH323="h323_${OPENH323_SUFFIX}"
if test "${HAS_OPENH323:-unset}" != "unset"; then
- { echo "$as_me:$LINENO: checking OpenH323 installation validity" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking OpenH323 installation validity" >&5