aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-12 20:45:03 +0800
committermiwi <miwi@FreeBSD.org>2007-12-12 20:45:03 +0800
commite7794df0840b487bd36c0348400ab30df169f820 (patch)
treedd5b59543100b5eadb0468072817844fbd37d47a /net
parentfc3bcaaea44d557c3cb5554441eee7d5e3c778e6 (diff)
downloadfreebsd-ports-gnome-e7794df0840b487bd36c0348400ab30df169f820.tar.gz
freebsd-ports-gnome-e7794df0840b487bd36c0348400ab30df169f820.tar.zst
freebsd-ports-gnome-e7794df0840b487bd36c0348400ab30df169f820.zip
Net::GrowlClient provides a complete object oriented interface
to send Mac OS X Growl notifications across the network. Author: Raphael ROULET <raphael@perl-auvergne.com> WWW: http://search.cpan.org/~castor/Net-GrowlClient/ PR: ports/118184 Submitted by: Masahiro Teramoto <markun at onohara.to>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-GrowlClient/Makefile27
-rw-r--r--net/p5-Net-GrowlClient/distinfo3
-rw-r--r--net/p5-Net-GrowlClient/pkg-descr5
-rw-r--r--net/p5-Net-GrowlClient/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aec453c677ad..8d682e4a0e13 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -479,6 +479,7 @@
SUBDIR += p5-Net-Google-Calendar
SUBDIR += p5-Net-Gopher
SUBDIR += p5-Net-Growl
+ SUBDIR += p5-Net-GrowlClient
SUBDIR += p5-Net-HL7
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-Interface
diff --git a/net/p5-Net-GrowlClient/Makefile b/net/p5-Net-GrowlClient/Makefile
new file mode 100644
index 000000000000..b3f2f05856fd
--- /dev/null
+++ b/net/p5-Net-GrowlClient/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-GrowlClient
+# Date created: 2007-11-22
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-GrowlClient
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= Perl implementation of Growl Network Notification Protocol
+
+BUILD_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::GrowlClient.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-GrowlClient/distinfo b/net/p5-Net-GrowlClient/distinfo
new file mode 100644
index 000000000000..7a42f925e39f
--- /dev/null
+++ b/net/p5-Net-GrowlClient/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-GrowlClient-0.02.tar.gz) = 120a06c677546a9c7a68c75bf354fd34
+SHA256 (Net-GrowlClient-0.02.tar.gz) = ce84a3b7ecaa792519e56e862ff451e12b8a869d8f650ff5134ec5596723ee7a
+SIZE (Net-GrowlClient-0.02.tar.gz) = 5949
diff --git a/net/p5-Net-GrowlClient/pkg-descr b/net/p5-Net-GrowlClient/pkg-descr
new file mode 100644
index 000000000000..1b5aaf3668b9
--- /dev/null
+++ b/net/p5-Net-GrowlClient/pkg-descr
@@ -0,0 +1,5 @@
+Net::GrowlClient provides a complete object oriented interface
+to send Mac OS X Growl notifications across the network.
+
+Author: Raphael ROULET <raphael@perl-auvergne.com>
+WWW: http://search.cpan.org/~castor/Net-GrowlClient/
diff --git a/net/p5-Net-GrowlClient/pkg-plist b/net/p5-Net-GrowlClient/pkg-plist
new file mode 100644
index 000000000000..265707c1392e
--- /dev/null
+++ b/net/p5-Net-GrowlClient/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GrowlClient/.packlist
+%%SITE_PERL%%/Net/GrowlClient.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GrowlClient
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net