aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-04 17:05:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-04 17:05:50 +0800
commiteb0fbfe7a526473d17e8e920f77998479e43439e (patch)
treee15a07af663ee08f946cd2621065c2f371ba97d8 /net
parent0428618de8f0f3e49af4b26655bb88068b20c979 (diff)
downloadfreebsd-ports-gnome-eb0fbfe7a526473d17e8e920f77998479e43439e.tar.gz
freebsd-ports-gnome-eb0fbfe7a526473d17e8e920f77998479e43439e.tar.zst
freebsd-ports-gnome-eb0fbfe7a526473d17e8e920f77998479e43439e.zip
- Use GNU_CONFIGURE as GNU configure is used
- Strip binaries
Diffstat (limited to 'net')
-rw-r--r--net/rwhoisd/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/net/rwhoisd/Makefile b/net/rwhoisd/Makefile
index 719d20c6ecc5..ad53cee1c867 100644
--- a/net/rwhoisd/Makefile
+++ b/net/rwhoisd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rwhoisd
PORTVERSION= 1.5.9.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://projects.arin.net/rwhois/ftp/ \
http://www.rwhois.net/ftp/ \
@@ -15,13 +15,7 @@ COMMENT= The Internic referral whois server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS_DEFINE= IPV6 LARGEFILE DOCS
-OPTIONS_DEFAULT= IPV6
-IPV6_DESC= Enable IPV6 support
-LARGEFILE_DESC= Enable largefile support (> 2Gb)
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
USE_RC_SUBR= rwhoisd
@@ -36,6 +30,11 @@ ETCFILES= rwhoisd.allow rwhoisd.auth_area rwhoisd.conf rwhoisd.deny \
rwhoisd.dir rwhoisd.root rwhoisd.x.dir
PLIST_SUB+= ETCFILES="${ETCFILES}"
+OPTIONS_DEFINE= IPV6 LARGEFILE DOCS
+OPTIONS_DEFAULT= IPV6
+IPV6_DESC= Enable IPV6 support
+LARGEFILE_DESC= Enable largefile support (> 2Gb)
+
.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MIPV6)
@@ -54,6 +53,8 @@ post-patch:
${WRKSRC}/common/conf.h
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
${INSTALL_MAN} ${WRKSRC}/doc/rwhois_indexer.8 ${STAGEDIR}${PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/doc/rwhoisd.8 ${STAGEDIR}${PREFIX}/man/man8
${MKDIR} ${STAGEDIR}${DOCSDIR}
* - Fix http://trac.edgewall.org/ticket/9439, http://trac.edgewall.org/wiki/Tra...pgollucci2010-10-123-1/+96 * - Update to 0.12clsung2010-07-214-624/+21 * - Chase devel/apr -> devel/apr1 shufflingpgollucci2010-05-181-1/+1 * 4/5: Chase devel/apr shlib bumppgollucci2010-05-061-0/+1 * - Update to 0.11.7clsung2010-04-202-4/+4 * - Update to 0.11.6clsung2009-12-182-4/+4 * - Update to 0.11.5clsung2009-08-173-4/+11 * - Update to 0.11.4clsung2009-04-072-4/+4 * - Update to 0.11.3clsung2009-02-192-4/+4 * - Update to 0.11.2.1clsung2009-01-292-4/+8 * - Update to 0.11.2clsung2008-11-103-7/+8 * - Update to 0.11.1clsung2008-09-082-5/+4 * - Bump PORTREVISION after apr updatemiwi2008-07-071-1/+1 * Bump PORTREVISION due to subversion upgrade.lev2008-06-301-0/+1 * (1) Upgrade subversion to version 1.5.0.lev2008-06-301-1/+1 * - Update to 0.11clsung2008-06-276-477/+651 * - Update to 0.10.5clsung2008-06-242-5/+4 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * - Properly create empty directories when installed from packagepav2007-07-311-0/+2 * - official site recommands the stable pysqlite23clsung2007-06-091-1/+2 * - Update to 0.10.4clsung2007-04-233-5/+8 * - fix portversion (should be 0.10.3.1)clsung2007-04-102-5/+5 * - install examplesclsung2007-04-073-4/+17 * - Update to 0.10.3.1, security fixclsung2007-03-092-4/+4 * - add knobs for compiling with pgsql backend and add knob for compiling withoutclsung2007-03-071-4/+14 * - Update to 0.10.3clsung2006-12-132-4/+4 * - Update to 0.10.2clsung2006-11-142-4/+4 * - Update to 0.10.1clsung2006-11-092-4/+4 * - I'll maintain these two ports from now on.clsung2006-11-061-1/+1 * - Update to 0.10clsung2006-10-313-18/+85 * Update to 0.9.6 to fFixed reStructuredText breach of privacy and denial ofitetcu2006-07-112-4/+4 * - Update to 0.9.5.jmelo2006-04-272-4/+4 * - Update to 0.9.4pav2006-03-272-5/+4 * Update dependencies to moved portmnag2006-01-281-1/+2 * Update to 0.9.3erwin2006-01-242-4/+4 * Add ja-trac-0.9.2 (translated version of www/trac).kuriyama2005-12-181-0/+1 * Update to 0.9.2mnag2005-12-073-5/+7 * Chase some URLs per the distfile survey.linimon2005-11-251-1/+1 * - Update to 0.9garga2005-11-045-238/+354 * - Assign maintainership to volunteerpav2005-07-261-1/+1 * - Reset long term unresponsive maintainerpav2005-07-181-1/+1 * - BUILD_DEPENDS are also RUN_DEPENDSpav2005-07-181-0/+2 * Update to trac 0.8.4. Version < 0.8.4 have a security vulnerability,nik2005-06-222-3/+3 * Update to 0.8.1novel2005-05-063-3/+4 * Fix the py-PySQLite dependency.marcus2005-03-141-1/+1 * Unbreak: Install man-pages into the correct placevs2005-03-023-5/+13