aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2010-12-24 23:15:58 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2010-12-24 23:15:58 +0800
commited19756013ec9e9a76755612cf4c0efb32924753 (patch)
treea05d928cb4a206f1b079df9d3446f8576e1b488f /net
parent06c19e0a94fa9ff93a6aefe7f4bf9fb81149fea1 (diff)
downloadfreebsd-ports-gnome-ed19756013ec9e9a76755612cf4c0efb32924753.tar.gz
freebsd-ports-gnome-ed19756013ec9e9a76755612cf4c0efb32924753.tar.zst
freebsd-ports-gnome-ed19756013ec9e9a76755612cf4c0efb32924753.zip
Fix bug in Makefile which caused a plist issue when python or libzrtp
modules were enabled. Add missing file to plist when python module is enabled. Approved by: Richard E. Neese <r.neese@gmail.com> (maintainer) Pointyhat: jpaetzel
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch-core/Makefile6
-rw-r--r--net/freeswitch-core/pkg-plist1
2 files changed, 4 insertions, 3 deletions
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 9c463bd1deea..8b9d5c057cd7 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freeswitch-core
PORTVERSION= 201044
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ftp://ftp.secure-computing.net/pub/freeswitch/ \
ftp://ftp2.secure-computing.net/pub/freeswitch/ \
@@ -190,7 +190,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/erlang/usr/include/erl_driver.h:${PORTSDIR}/lan
.endif
.if !defined(WITH_ZRTP)
-PLIST_SUB+= WITH_ZRTP="@comment"
+PLIST_SUB+= WITH_ZRTP="@comment "
.else
PLIST_SUB+= WITH_ZRTP=""
CONFIGURE_ARGS+= --enable-zrtp
@@ -199,7 +199,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libzrtp.a:${PORTSDIR}/devel/libzrtp
.endif
.if !defined(WITH_MODPYTHON)
-PLIST_SUB+= WITH_MODPYTHON="@comment"
+PLIST_SUB+= WITH_MODPYTHON="@comment "
.else
PLIST_SUB+= WITH_MODPYTHON=""
USE_PYTHON= yes
diff --git a/net/freeswitch-core/pkg-plist b/net/freeswitch-core/pkg-plist
index 0c339915b3fc..b6f167b6930b 100644
--- a/net/freeswitch-core/pkg-plist
+++ b/net/freeswitch-core/pkg-plist
@@ -351,6 +351,7 @@ lib/freeswitch/mod/mod_native_file.so
%%WITH_MODPASTREAM%%lib/freeswitch/mod/mod_portaudio_stream.so
%%WITH_MODPYTHON%%lib/freeswitch/mod/mod_python.la
%%WITH_MODPYTHON%%lib/freeswitch/mod/mod_python.so
+%%WITH_MODPYTHON%%%%PYTHON_SITELIBDIR%%/freeswitch.py
%%WITH_MODRSS%%lib/freeswitch/mod/mod_rss.la
%%WITH_MODRSS%%lib/freeswitch/mod/mod_rss.so
%%WITH_MODSAYDE%%lib/freeswitch/mod/mod_say_de.la