aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-06-11 03:14:04 +0800
committermarcus <marcus@FreeBSD.org>2006-06-11 03:14:04 +0800
commited3a153959813c03958d39a408e0b5d2f8c18b29 (patch)
treebfbebcb196f1ba741113eba02e78d9a4ff7bcb50 /net
parentee6c5b1b136a3d750112c716488641fe585dacdd (diff)
downloadfreebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.tar.gz
freebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.tar.zst
freebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.zip
Make libdns (aka mDNSResponder) support optional (defaulting to off).
Note: enabling this will add a conflict to mDNSResponder which may interfere with KDE applications. PR: 98566 Submitted by: Kirk Strauser <kirk@strauser.com> (with modifications)
Diffstat (limited to 'net')
-rw-r--r--net/avahi/Makefile12
-rw-r--r--net/avahi/pkg-plist7
2 files changed, 18 insertions, 1 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 192e76fe7200..3e6018853ff5 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -48,7 +48,8 @@ MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
-OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
+OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off \
+ LIBDNS "Enable mDNSResponder compatibility" off
.endif
.include <bsd.port.pre.mk>
@@ -58,6 +59,15 @@ OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
IGNORE= does not work on FreeBSD 4.X
.endif
+.if defined(WITH_LIBDNS)
+CONFIGURE_ARGS+=--enable-compat-libdns_sd
+PLIST_SUB+= LIBDNS=""
+CONFLICTS+= mDNSResponder-[0-9]*
+.else
+CONFIGURE_ARGS+=--disable-compat-libdns_sd
+PLIST_SUB+= LIBDNS="@comment "
+.endif
+
.if defined(WITH_GTK2)
USE_GNOME+= libglade2
PLIST_SUB+= GTK=""
diff --git a/net/avahi/pkg-plist b/net/avahi/pkg-plist
index e915b774b247..386904b8f0c5 100644
--- a/net/avahi/pkg-plist
+++ b/net/avahi/pkg-plist
@@ -51,6 +51,7 @@ include/avahi-compat-howl/salt/salt.h
include/avahi-compat-howl/salt/signal.h
include/avahi-compat-howl/salt/socket.h
include/avahi-compat-howl/salt/time.h
+%%LIBDNS%%include/avahi-compat-libdns_sd/dns_sd.h
include/avahi-core/core.h
include/avahi-core/log.h
include/avahi-core/lookup.h
@@ -74,12 +75,17 @@ lib/libavahi-glib.a
lib/libavahi-glib.la
lib/libavahi-glib.so
lib/libavahi-glib.so.1
+%%LIBDNS%%lib/libdns_sd.a
+%%LIBDNS%%lib/libdns_sd.la
+%%LIBDNS%%lib/libdns_sd.so
+%%LIBDNS%%lib/libdns_sd.so.1
lib/libhowl.a
lib/libhowl.la
lib/libhowl.so
lib/libhowl.so.0
libdata/pkgconfig/avahi-client.pc
libdata/pkgconfig/avahi-compat-howl.pc
+%%LIBDNS%%libdata/pkgconfig/avahi-compat-libdns_sd.pc
libdata/pkgconfig/avahi-core.pc
libdata/pkgconfig/avahi-glib.pc
sbin/avahi-daemon
@@ -101,6 +107,7 @@ sbin/avahi-dnsconfd
@dirrm %%DATADIR%%
@dirrm include/avahi-glib
@dirrm include/avahi-core
+%%LIBDNS%%@dirrm include/avahi-compat-libdns_sd
@dirrm include/avahi-compat-howl/salt
@dirrm include/avahi-compat-howl/rendezvous
@dirrm include/avahi-compat-howl/discovery