aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-10-07 10:17:50 +0800
committerpetef <petef@FreeBSD.org>2001-10-07 10:17:50 +0800
commited7692ba565d79aa405891612218679144d7498f (patch)
treedd8869f4606e16c7f7f06f2539ec6d4f346124ce /net
parentfccfa4d9f3c52be1bb57a2a1eda38bd9be4e0509 (diff)
downloadfreebsd-ports-gnome-ed7692ba565d79aa405891612218679144d7498f.tar.gz
freebsd-ports-gnome-ed7692ba565d79aa405891612218679144d7498f.tar.zst
freebsd-ports-gnome-ed7692ba565d79aa405891612218679144d7498f.zip
Add p5-Net-ParseWhois-0.62, an extendable perl5 module for parsing whois
information PR: 30953 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-ParseWhois/Makefile22
-rw-r--r--net/p5-Net-ParseWhois/distinfo1
-rw-r--r--net/p5-Net-ParseWhois/pkg-comment1
-rw-r--r--net/p5-Net-ParseWhois/pkg-descr6
-rw-r--r--net/p5-Net-ParseWhois/pkg-plist22
6 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bf7c43e21d70..0e7c22f17174 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -272,6 +272,7 @@
SUBDIR += p5-Net-IPv6Addr
SUBDIR += p5-Net-Jabber
SUBDIR += p5-Net-Netmask
+ SUBDIR += p5-Net-ParseWhois
SUBDIR += p5-Net-Patricia
SUBDIR += p5-Net-RawIP
SUBDIR += p5-Net-SNMP
diff --git a/net/p5-Net-ParseWhois/Makefile b/net/p5-Net-ParseWhois/Makefile
new file mode 100644
index 000000000000..ded9f1b3f747
--- /dev/null
+++ b/net/p5-Net-ParseWhois/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-ParseWhois
+# Date created: 30 September 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-ParseWhois
+PORTVERSION= 0.62
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::ParseWhois.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-ParseWhois/distinfo b/net/p5-Net-ParseWhois/distinfo
new file mode 100644
index 000000000000..81fe3411ee51
--- /dev/null
+++ b/net/p5-Net-ParseWhois/distinfo
@@ -0,0 +1 @@
+MD5 (Net-ParseWhois-0.62.tar.gz) = f648a2ba7d9aff1d5d1fdb685ce99bbc
diff --git a/net/p5-Net-ParseWhois/pkg-comment b/net/p5-Net-ParseWhois/pkg-comment
new file mode 100644
index 000000000000..ec8b639d93a6
--- /dev/null
+++ b/net/p5-Net-ParseWhois/pkg-comment
@@ -0,0 +1 @@
+Extendable perl5 module for parsing whois information
diff --git a/net/p5-Net-ParseWhois/pkg-descr b/net/p5-Net-ParseWhois/pkg-descr
new file mode 100644
index 000000000000..17efe6b83531
--- /dev/null
+++ b/net/p5-Net-ParseWhois/pkg-descr
@@ -0,0 +1,6 @@
+Based on Net::Whois, Net::ParseWhois was written with the intent to provide a
+replacement for the (broken) Net::Whois module. It is otherwise different to
+Net::Whois in that it a) is easily extendable b) has a work-around approach
+rather than wanting/expecting/wishing registrars to standardize their output.
+
+WWW: http://dajoba.com/projects/netparsewhois/
diff --git a/net/p5-Net-ParseWhois/pkg-plist b/net/p5-Net-ParseWhois/pkg-plist
new file mode 100644
index 000000000000..043b973fbf7a
--- /dev/null
+++ b/net/p5-Net-ParseWhois/pkg-plist
@@ -0,0 +1,22 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/BulkRegister.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/CoreNic.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/DomainBank.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/DomainDiscover.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Dotster.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Easyspace.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/INameWW.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Netsol.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/OpenSRS.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Register.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Registrars.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar/Unknown.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/ParseWhois/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/ParseWhois
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain/Registrar
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois/Domain
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/ParseWhois
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true