aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1997-11-05 19:38:43 +0800
committerobrien <obrien@FreeBSD.org>1997-11-05 19:38:43 +0800
commitf07f90f7da4a7999ef7ec62a7d99ba3a6180075b (patch)
tree51526ca6598aef38ef06e5917bc30b8d4b7f1f4e /net
parentcf1e72c7ee83d52a8262a8575107d1f510aed4e1 (diff)
downloadfreebsd-ports-gnome-f07f90f7da4a7999ef7ec62a7d99ba3a6180075b.tar.gz
freebsd-ports-gnome-f07f90f7da4a7999ef7ec62a7d99ba3a6180075b.tar.zst
freebsd-ports-gnome-f07f90f7da4a7999ef7ec62a7d99ba3a6180075b.zip
tcpshow reads a tcpdump(1) savefile and provides a reasonably complete
decode of Ethernet, IP, ICMP, UDP and TCP headers. Boolean expressions may also be specified for packet selection. tcpshow's output is simular to Sun Solaris's snoop(1M) command for network packet capture and inspection.
Diffstat (limited to 'net')
-rw-r--r--net/tcpshow/Makefile32
-rw-r--r--net/tcpshow/distinfo2
-rw-r--r--net/tcpshow/pkg-comment1
-rw-r--r--net/tcpshow/pkg-descr10
-rw-r--r--net/tcpshow/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/net/tcpshow/Makefile b/net/tcpshow/Makefile
new file mode 100644
index 000000000000..51fd585e7ee2
--- /dev/null
+++ b/net/tcpshow/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: tcpshow
+# Version required: 1.0
+# Date created: Tue Nov 04, 1997
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+PKGNAME= tcpshow-1.0
+CATEGORIES= net security
+MASTER_SITES= http://www.cs.berkeley.edu/~daw/mike/
+DISTFILES= tcpshow.c tcpshow.1
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+MAN1= tcpshow.1
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/tcpshow.c ${WRKDIR}
+ @${CP} ${DISTDIR}/tcpshow.1 ${WRKDIR}
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -o tcpshow tcpshow.c)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpshow ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tcpshow.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/tcpshow/distinfo b/net/tcpshow/distinfo
new file mode 100644
index 000000000000..b8a933335e35
--- /dev/null
+++ b/net/tcpshow/distinfo
@@ -0,0 +1,2 @@
+MD5 (tcpshow.c) = c6c187faa57e1c842a73cc4e3c0ad0d8
+MD5 (tcpshow.1) = 70021150b1d24b3f0ee6f66c0df673a2
diff --git a/net/tcpshow/pkg-comment b/net/tcpshow/pkg-comment
new file mode 100644
index 000000000000..00f37be8f467
--- /dev/null
+++ b/net/tcpshow/pkg-comment
@@ -0,0 +1 @@
+Decode tcpdump(1) output.
diff --git a/net/tcpshow/pkg-descr b/net/tcpshow/pkg-descr
new file mode 100644
index 000000000000..2fd7ea27ffc8
--- /dev/null
+++ b/net/tcpshow/pkg-descr
@@ -0,0 +1,10 @@
+tcpshow reads a tcpdump(1) savefile and provides a reasonably complete
+decode of Ethernet, IP, ICMP, UDP and TCP headers. Boolean expressions
+may also be specified for packet selection. Data within the packets are
+displayed in ASCII.
+
+tcpshow's output is simular to Sun Solaris's snoop(1M) command for
+network packet capture and inspection.
+
+-- David
+ (obrien@NUXI.com)
diff --git a/net/tcpshow/pkg-plist b/net/tcpshow/pkg-plist
new file mode 100644
index 000000000000..087eab98fd8b
--- /dev/null
+++ b/net/tcpshow/pkg-plist
@@ -0,0 +1,2 @@
+bin/tcpshow
+man/man1/tcpshow.1.gz