aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-04 22:04:14 +0800
committerrafan <rafan@FreeBSD.org>2006-08-04 22:04:14 +0800
commitf0807348f3d98514325d011f7d57737c85a2eca4 (patch)
tree848f7f81c4dbf11d175543cfe76321417c01d01f /net
parentb3f26591768a62824a6473ca98b31c2b5faa4980 (diff)
downloadfreebsd-ports-gnome-f0807348f3d98514325d011f7d57737c85a2eca4.tar.gz
freebsd-ports-gnome-f0807348f3d98514325d011f7d57737c85a2eca4.tar.zst
freebsd-ports-gnome-f0807348f3d98514325d011f7d57737c85a2eca4.zip
- Add two critical patches for MyDoom and Bagle modules
- Pass maintainership to submitter PR: ports/101321 Submitted by: Michael Josic <systemoperator at gmail.com> (new maintainer) Approved by: Ryo Okamoto <ryo at aquahill.net> (old maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/nepenthes/Makefile3
-rw-r--r--net/nepenthes/files/patch-modules-vuln-bagle-BagleDialogue.cpp27
-rw-r--r--net/nepenthes/files/patch-modules-vuln-mydoom-MydoomDialogue.cpp27
3 files changed, 56 insertions, 1 deletions
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 874c3c6ff031..10cacd0f2759 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -7,11 +7,12 @@
PORTNAME= nepenthes
PORTVERSION= 0.1.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nepenthes
-MAINTAINER= ryo@aquahill.net
+MAINTAINER= systemoperator@gmail.com
COMMENT= Determine the malware activity on a network
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
diff --git a/net/nepenthes/files/patch-modules-vuln-bagle-BagleDialogue.cpp b/net/nepenthes/files/patch-modules-vuln-bagle-BagleDialogue.cpp
new file mode 100644
index 000000000000..bde493ded484
--- /dev/null
+++ b/net/nepenthes/files/patch-modules-vuln-bagle-BagleDialogue.cpp
@@ -0,0 +1,27 @@
+--- modules/vuln-bagle/BagleDialogue.cpp.old Sun May 7 16:07:25 2006
++++ modules/vuln-bagle/BagleDialogue.cpp Sun May 7 16:08:14 2006
+@@ -158,6 +158,7 @@
+ m_State = BAGLE_BINARY;
+ m_Download = new Download(m_Socket->getRemoteHost(),"bagle://",m_Socket->getRemoteHost(),"bagle://foo/bar");
+ m_Download->getDownloadBuffer()->addData(msg->getMsg()+4,msg->getSize()-4);
++ return CL_ASSIGN_AND_DONE;
+ }
+ }
+ break;
+@@ -165,6 +166,7 @@
+ case BAGLE_BINARY:
+ // FIXME m_MaxFileSize
+ m_Download->getDownloadBuffer()->addData(msg->getMsg(),msg->getSize());
++ return CL_ASSIGN_AND_DONE;
+ break;
+
+ }
+@@ -232,8 +234,6 @@
+ if ( m_Download->getDownloadBuffer()->getSize() == m_FileSize )
+ {
+ g_Nepenthes->getSubmitMgr()->addSubmission(m_Download);
+- // destructor will delete it
+- return CL_ASSIGN_AND_DONE;
+ }
+ }
+ return CL_DROP;
diff --git a/net/nepenthes/files/patch-modules-vuln-mydoom-MydoomDialogue.cpp b/net/nepenthes/files/patch-modules-vuln-mydoom-MydoomDialogue.cpp
new file mode 100644
index 000000000000..cffca6e73371
--- /dev/null
+++ b/net/nepenthes/files/patch-modules-vuln-mydoom-MydoomDialogue.cpp
@@ -0,0 +1,27 @@
+--- modules/vuln-mydoom/MydoomDialogue.cpp.old Sun May 7 16:03:52 2006
++++ modules/vuln-mydoom/MydoomDialogue.cpp Sun May 7 16:05:33 2006
+@@ -120,7 +120,7 @@
+ m_Download = new Download(msg->getRemoteHost(),"mydoom://foo/bar",msg->getRemoteHost(),"some triggerline");
+ m_Download->getDownloadBuffer()->addData((char *)m_Buffer->getData(),m_Buffer->getSize());
+ m_Buffer->clear();
+- return CL_ASSIGN;
++ return CL_ASSIGN_AND_DONE;
+ }
+ }
+ if (m_Buffer->getSize() > 128 )
+@@ -130,6 +130,7 @@
+ case MYDOOM_FILETRANSFERR:
+ {
+ m_Download->getDownloadBuffer()->addData((char *)msg->getMsg(),msg->getSize());
++ return CL_ASSIGN_AND_DONE;
+ }
+ break;
+
+@@ -196,7 +197,6 @@
+ if (m_Download != NULL)
+ {
+ g_Nepenthes->getSubmitMgr()->addSubmission(m_Download);
+- return CL_ASSIGN_AND_DONE;
+ }
+ return CL_DROP;
+ }