aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-12-21 07:56:40 +0800
committerpav <pav@FreeBSD.org>2005-12-21 07:56:40 +0800
commitf5d86f5dbef0c70c2e5e91ed4603b88eb7923bb9 (patch)
tree4c501f12ee6eb48862f35d19cc9bdef98f9f0abe /net
parentf221d77c60b881fe1ba0ac215057f51d3f63117b (diff)
downloadfreebsd-ports-gnome-f5d86f5dbef0c70c2e5e91ed4603b88eb7923bb9.tar.gz
freebsd-ports-gnome-f5d86f5dbef0c70c2e5e91ed4603b88eb7923bb9.tar.zst
freebsd-ports-gnome-f5d86f5dbef0c70c2e5e91ed4603b88eb7923bb9.zip
SendSNPP is a perl program for sending messages through a RFC1861 compliant
SNPP server. SNPP stands for Simple Network Paging Protocol. It is used by a wide range of paging providers for sending pages. A list of some of the providers that support the SNPP service is on the WWW site below. SendSNPP requires no special modules, and has been tested on Linux and Windows systems. It has a very straight forward interface making it very easy to use. PR: ports/90529 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sendsnpp/Makefile29
-rw-r--r--net/sendsnpp/distinfo3
-rw-r--r--net/sendsnpp/pkg-descr16
4 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0f180f3a7de8..09d72dd3eaf8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -687,6 +687,7 @@
SUBDIR += seda
SUBDIR += sendemail
SUBDIR += sendfile
+ SUBDIR += sendsnpp
SUBDIR += ser
SUBDIR += serveez
SUBDIR += sharity-light
diff --git a/net/sendsnpp/Makefile b/net/sendsnpp/Makefile
new file mode 100644
index 000000000000..e606c66d8884
--- /dev/null
+++ b/net/sendsnpp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: net/sendsnpp
+# Date created: 2005-12-17
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+# $Tecnik: ports/net/sendsnpp/Makefile,v 1.1 2005/12/17 04:05:04 itetcu Exp $
+
+PORTNAME= sendSNPP
+DISTVERSION= v1.03
+CATEGORIES= net perl5
+MASTER_SITES= http://caspian.dotconf.net/menu/Software/SendSNPP/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Tool for sending messages through a RFC1861 compliant SNPP server
+
+NO_BUILD= yes
+USE_PERL_RUN= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/sendSNPP.pl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME}.pl ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/sendsnpp/distinfo b/net/sendsnpp/distinfo
new file mode 100644
index 000000000000..c3280a503cbd
--- /dev/null
+++ b/net/sendsnpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (sendSNPP-v1.03.tar.gz) = 947660c94e336af7baae5a02eca327b3
+SHA256 (sendSNPP-v1.03.tar.gz) = b1b0c21647ec21775b57f1ffa05684168ee9ea9588a425cffd3a81694ee72edd
+SIZE (sendSNPP-v1.03.tar.gz) = 8358
diff --git a/net/sendsnpp/pkg-descr b/net/sendsnpp/pkg-descr
new file mode 100644
index 000000000000..e736ce868a06
--- /dev/null
+++ b/net/sendsnpp/pkg-descr
@@ -0,0 +1,16 @@
+SendSNPP is a perl program for sending messages through a RFC1861 compliant
+SNPP server. SNPP stands for Simple Network Paging Protocol. It is used by a
+wide range of paging providers for sending pages. A list of some of the
+providers that support the SNPP service is on the WWW site below. SendSNPP
+requires no special modules, and has been tested on Linux and Windows systems.
+It has a very straight forward interface making it very easy to use.
+
+Feature List:
+- Easy addition of new service providers by simply editing a hash
+- Supports logging to a file
+- Script returns error status to the system when an error occurs
+- Automatic message truncation when message exceeds providers limit
+- Verbose and descriptive error messages if something goes wrong
+- Multiple debugging levels
+
+WWW: http://caspian.dotconf.net/menu/Software/SendSNPP/