aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-09 04:22:53 +0800
committerantoine <antoine@FreeBSD.org>2014-01-09 04:22:53 +0800
commitf9af30c3e9b9541cd235960f6c5aea473199f558 (patch)
treefb153fe848e8bc9cc5b43265b072007de2f709fd /net
parent8615da09f46a1f11dedc4bab32fcc4e1656f23f3 (diff)
downloadfreebsd-ports-gnome-f9af30c3e9b9541cd235960f6c5aea473199f558.tar.gz
freebsd-ports-gnome-f9af30c3e9b9541cd235960f6c5aea473199f558.tar.zst
freebsd-ports-gnome-f9af30c3e9b9541cd235960f6c5aea473199f558.zip
- Add LICENSE
- Stage support - Fix build with clang PR: ports/185501 Submitted by: KATO Tsuguru
Diffstat (limited to 'net')
-rw-r--r--net/aget/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/net/aget/Makefile b/net/aget/Makefile
index 6f581a85694a..61e8dc26bb7b 100644
--- a/net/aget/Makefile
+++ b/net/aget/Makefile
@@ -7,15 +7,18 @@ CATEGORIES= net
MASTER_SITES= http://www.enderunix.org/aget/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A multithreaded HTTP download accelerator
+COMMENT= Multithreaded HTTP download accelerator
-PLIST_FILES= bin/aget
-MAN1= aget.1
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
-NO_STAGE= yes
-post-patch:
-# fix man prefix and make portlint happy :)
- @${REINPLACE_CMD} -e 's|/usr/share/man/man1/|${MANPREFIX}/man/man1/|g' -e \
- 's|/usr/local/bin/|${PREFIX}/bin/|g' ${WRKSRC}/Makefile
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+LDFLAGS+= -pthread
+
+PLIST_FILES= bin/aget man/man1/aget.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/aget ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/aget.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>