aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-01-15 17:05:37 +0800
committertijl <tijl@FreeBSD.org>2015-01-15 17:05:37 +0800
commitfab688a7c4153e7aad8d81aa6c70167666bae3d8 (patch)
tree03708cdbdeb7094897643531ddd754b2c9a2c51b /net
parent829d284efdd1904e092f24ebc0a79dfa48355de1 (diff)
downloadfreebsd-ports-gnome-fab688a7c4153e7aad8d81aa6c70167666bae3d8.tar.gz
freebsd-ports-gnome-fab688a7c4153e7aad8d81aa6c70167666bae3d8.tar.zst
freebsd-ports-gnome-fab688a7c4153e7aad8d81aa6c70167666bae3d8.zip
Add missing USE_OPENSSL=yes
PR: 195796
Diffstat (limited to 'net')
-rw-r--r--net/bsdec2-image-upload/Makefile2
-rw-r--r--net/crtmpserver/Makefile3
-rw-r--r--net/hostapd/Makefile2
-rw-r--r--net/httping/Makefile3
-rw-r--r--net/kamailio/Makefile11
-rw-r--r--net/l4ip/Makefile2
-rw-r--r--net/libarms/Makefile5
-rw-r--r--net/libexosip2/Makefile3
-rw-r--r--net/miniupnpd/Makefile3
-rw-r--r--net/p5-Net-TCLink/Makefile3
-rw-r--r--net/p5-Socket-Class/Makefile3
-rw-r--r--net/relayd/Makefile2
-rw-r--r--net/ssltunnel-client/Makefile3
-rw-r--r--net/ssltunnel-server/Makefile3
-rw-r--r--net/ssvnc/Makefile4
-rw-r--r--net/svnup/Makefile2
-rw-r--r--net/tinyfugue/Makefile2
-rw-r--r--net/xrdp/Makefile10
18 files changed, 46 insertions, 20 deletions
diff --git a/net/bsdec2-image-upload/Makefile b/net/bsdec2-image-upload/Makefile
index 688131085673..f64e6070639e 100644
--- a/net/bsdec2-image-upload/Makefile
+++ b/net/bsdec2-image-upload/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bsdec2-image-upload
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://freebsd-ec2-dist.s3.amazonaws.com/
@@ -14,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
USES= tar:tgz uidfix
+USE_OPENSSL= yes
# Install into ${STAGEDIR}${PREFIX}; but the build respects ${DESTDIR} so
# all we need to give is the ${PREFIX}/bin part.
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
index 57820e7c84e9..26edefa460f4 100644
--- a/net/crtmpserver/Makefile
+++ b/net/crtmpserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= crtmpserver
PORTVERSION= 0.811
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://rtmpd.com/assets/sources/
@@ -19,6 +19,7 @@ USE_LDCONFIG= yes
USES= cmake:outsource lua
CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${PREFIX} -DTEMP_FRAMEWORK_VER=${PORTVERSION}
+USE_OPENSSL= yes
USERS= crtmpserver
GROUPS= crtmpserver
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 0a4d0b878d22..db561305f869 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hostapd
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://w1.fi/releases/
@@ -12,6 +13,7 @@ COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
LICENSE= BSD3CLAUSE
USES= gmake
+USE_OPENSSL= yes
BUILD_WRKSRC= ${WRKSRC}/hostapd
PLIST_FILES= sbin/hostapd sbin/hostapd_cli man/man1/hostapd_cli.1.gz \
diff --git a/net/httping/Makefile b/net/httping/Makefile
index aebf6d4528a3..dddf3c008044 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -3,7 +3,7 @@
PORTNAME= httping
PORTVERSION= 2.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
LOCAL/ehaupt
@@ -40,6 +40,7 @@ MAKE_ENV+= FW=no
.if ${PORT_OPTIONS:MSSL}
MAKE_ENV+= SSL=yes
+USE_OPENSSL= yes
.else
MAKE_ENV+= SSL=no
.endif
diff --git a/net/kamailio/Makefile b/net/kamailio/Makefile
index a94afc6144de..aad292612c39 100644
--- a/net/kamailio/Makefile
+++ b/net/kamailio/Makefile
@@ -4,6 +4,7 @@
PORTNAME= kamailio
PORTVERSION= 4.2.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.kamailio.org/pub/kamailio/${PORTVERSION}/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
@@ -13,16 +14,15 @@ COMMENT= Very fast and configurable open source SIP proxy
LICENSE= GPLv2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
USES= gmake shebangfix readline
USE_LDCONFIG= yes
SHEBANG_FILES= utils/kamctl/kamctl utils/kamctl/kamdbctl
CFLAGS+= -Wall
-LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
- libxml2.so:${PORTSDIR}/textproc/libxml2
-
-RUN_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_RC_SUBR= kamailio
@@ -41,6 +41,7 @@ PGSQL_USES= pgsql
JITSI_RUN_DEPENDS= jitsi:${PORTSDIR}/net-im/jitsi
UNIXODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
RADIUS_LIB_DEPENDS= libradiusclient-ng.so:${PORTSDIR}/net/radiusclient
+TLS_USE= OPENSSL=yes
.include <bsd.port.options.mk>
diff --git a/net/l4ip/Makefile b/net/l4ip/Makefile
index 23cb6bb2e13b..196e3b0732da 100644
--- a/net/l4ip/Makefile
+++ b/net/l4ip/Makefile
@@ -3,6 +3,7 @@
PORTNAME= l4ip
PORTVERSION= 1.0.294
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.lundman.net/ftp/l4ip/
DISTNAME= ${PORTNAME}-${PORTVERSION:C/([0-9]*)\.([0-9]*)\.([0-9]*)/v\1.\2.b\3/}
@@ -11,6 +12,7 @@ MAINTAINER= leeym@FreeBSD.org
COMMENT= L4 health check daemon for IPFILTER
USES= gmake tar:tgz
+USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/src
post-patch:
diff --git a/net/libarms/Makefile b/net/libarms/Makefile
index 9c44c34b49ea..64d91d8dff77 100644
--- a/net/libarms/Makefile
+++ b/net/libarms/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libarms
PORTVERSION= 5.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net devel
MASTER_SITES= https://dev.smf.jp/dl/ \
http://dev.smf.jp/dl/
@@ -13,9 +13,10 @@ COMMENT= SMFv2/ARMS client library for C
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-USES= gmake libtool
GNU_CONFIGURE= yes
+USES= gmake libtool
USE_LDCONFIG= yes
+USE_OPENSSL= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/libexosip2/Makefile b/net/libexosip2/Makefile
index 1492e06360b3..a8c2a65c7994 100644
--- a/net/libexosip2/Makefile
+++ b/net/libexosip2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libeXosip2
PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SAVANNAH/exosip
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool
USE_LDCONFIG= yes
+USE_OPENSSL= yes
SHLIB_VER= 11
PLIST_SUB+= SHLIB_VER=${SHLIB_VER}
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index d9e8b67e52ec..e7e697c2f3d0 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= miniupnpd
PORTVERSION= 1.9
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -18,7 +19,7 @@ UUID!= uuidgen
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd \
man/man8/miniupnpd.8.gz
MAKE_JOBS_UNSAFE=yes
-
+USE_OPENSSL= yes
USE_RC_SUBR= miniupnpd
OPTIONS_DEFINE= PF_ENABLE_FILTER_RULES CHECK_PORTINUSE IPV6 UPNP_IGDV2 UPNP_STRICT LEASEFILE
diff --git a/net/p5-Net-TCLink/Makefile b/net/p5-Net-TCLink/Makefile
index 11957a0c344c..2f63fe991391 100644
--- a/net/p5-Net-TCLink/Makefile
+++ b/net/p5-Net-TCLink/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Net-TCLink
PORTVERSION= 3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,6 +15,7 @@ COMMENT= Module to for connecting to the TrustCommerce payment gateway
LICENSE= LGPL21
USES= perl5
+USE_OPENSSL= yes
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-Socket-Class/Makefile b/net/p5-Socket-Class/Makefile
index 517b7a762199..1bee0a81b612 100644
--- a/net/p5-Socket-Class/Makefile
+++ b/net/p5-Socket-Class/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Socket-Class
PORTVERSION= 2.258
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,6 +12,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl class to communicate with sockets
USES= perl5
+USE_OPENSSL= yes
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index 63d7d323c890..0d161fac017b 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= relayd
PORTVERSION= 5.5.20140810
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GH
@@ -16,6 +17,7 @@ GH_COMMIT= 49d1afd
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/src/usr.sbin
USES= uidfix
USE_GITHUB= yes
+USE_OPENSSL= yes
USE_RC_SUBR= relayd
CFLAGS+= -Wall
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
index cfafca3ef1d0..a677744b15dc 100644
--- a/net/ssltunnel-client/Makefile
+++ b/net/ssltunnel-client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ssltunnel
PORTVERSION= 1.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
PKGNAMESUFFIX= -client
@@ -19,6 +19,7 @@ GUI_DESC= GTK 1.2 graphical interface
CONFIGURE_ARGS= --disable-server --with-iconv=${ICONV_PREFIX}
GNU_CONFIGURE= yes
USES= iconv
+USE_OPENSSL= yes
.include <bsd.port.options.mk>
diff --git a/net/ssltunnel-server/Makefile b/net/ssltunnel-server/Makefile
index b1b2ed198a18..c3d98026cdc0 100644
--- a/net/ssltunnel-server/Makefile
+++ b/net/ssltunnel-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ssltunnel
PORTVERSION= 1.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
PKGNAMESUFFIX= -server
@@ -21,6 +21,7 @@ USE_RC_SUBR= ${PORTNAME}
SUB_FILES+= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-client
+USE_OPENSSL= yes
.include <bsd.port.options.mk>
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
index 70c0951b8ec9..a52afb803ef7 100644
--- a/net/ssvnc/Makefile
+++ b/net/ssvnc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ssvnc
PORTVERSION= 1.0.29
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= SF
DISTFILES= ${DISTNAME}.src${EXTRACT_SUFX}
@@ -21,8 +22,9 @@ OPTIONS_DEFINE= DOCS ULTRAFTP
ULTRAFTP_DESC= UltraVNC File Transfer support (Java required)
USES= imake:env gmake perl5 tk:wrapper
-USE_XORG= xi xmu xt xaw ice xpm xext sm
+USE_OPENSSL= yes
USE_PERL5= run
+USE_XORG= xi xmu xt xaw ice xpm xext sm
MAKE_ENV+= ROOT=${STAGEDIR}
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
index 511eaa8234f3..6cbc4b03b337 100644
--- a/net/svnup/Makefile
+++ b/net/svnup/Makefile
@@ -2,6 +2,7 @@
PORTNAME= svnup
PORTVERSION= 1.07
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://jcm.dsl.visi.com/freebsd/svnup/ \
LOCAL/jgh/net/${PORTNAME}/
@@ -15,6 +16,7 @@ OPTIONS_DEFINE= DOCS
LDFLAGS+= -lmd -lssl
USES= tar:xz
+USE_OPENSSL= yes
PORTDOCS= ChangeLog
diff --git a/net/tinyfugue/Makefile b/net/tinyfugue/Makefile
index 55496ad515a0..f4696214cef9 100644
--- a/net/tinyfugue/Makefile
+++ b/net/tinyfugue/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tf
PORTVERSION= 5.0b8
+PORTREVISION= 1
CATEGORIES= net games
MASTER_SITES= SF/tinyfugue/tinyfugue/5.0%20beta%208
DISTVERSION= ${PORTVERSION:S/.//}
@@ -13,6 +14,7 @@ COMMENT= Popular programmable MUD client, with macro support and more
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-manpage --enable-version --enable-symlink --datadir=${PREFIX}/lib
+USE_OPENSSL= yes
PLIST_SUB= DISTNAME=${DISTNAME}
diff --git a/net/xrdp/Makefile b/net/xrdp/Makefile
index a0183e598a86..7e47269e6f21 100644
--- a/net/xrdp/Makefile
+++ b/net/xrdp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xrdp
PORTVERSION= 0.6.1
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= GH
@@ -14,11 +14,13 @@ COMMENT= Open source Remote Desktop Protocol (RDP) server
LICENSE= GPLv2
-USES= autoreconf:build libtool pkgconfig
-USE_XORG= x11 xfixes
GNU_CONFIGURE= yes
-USE_RC_SUBR= xrdp
+USES= autoreconf:build libtool pkgconfig
USE_LDCONFIG= ${PREFIX}/lib/xrdp
+USE_OPENSSL= yes
+USE_RC_SUBR= xrdp
+USE_XORG= x11 xfixes
+
USE_GITHUB= yes
GH_ACCOUNT= neutrinolabs
GH_PROJECT= xrdp