aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /net
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadfreebsd-ports-gnome-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
freebsd-ports-gnome-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.zst
freebsd-ports-gnome-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-openid/Makefile5
-rw-r--r--net/rubygem-twitter/Makefile5
-rw-r--r--net/rubygem-twitter4r/Makefile7
-rw-r--r--net/rubygem-yadis/Makefile5
-rw-r--r--net/sipxconfig/Makefile11
-rw-r--r--net/sipxproxy/Makefile10
6 files changed, 25 insertions, 18 deletions
diff --git a/net/rubygem-openid/Makefile b/net/rubygem-openid/Makefile
index 191c150cd678..408b0e24d229 100644
--- a/net/rubygem-openid/Makefile
+++ b/net/rubygem-openid/Makefile
@@ -18,11 +18,10 @@ BUILD_DEPENDS= rubygem-yadis>=0.3.4:${PORTSDIR}/net/rubygem-yadis
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/rubygem-twitter/Makefile b/net/rubygem-twitter/Makefile
index b94e9db06932..231cbab379fd 100644
--- a/net/rubygem-twitter/Makefile
+++ b/net/rubygem-twitter/Makefile
@@ -20,8 +20,7 @@ BUILD_DEPENDS= rubygem-hpricot>0:${PORTSDIR}/www/rubygem-hpricot \
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/rubygem-twitter4r/Makefile b/net/rubygem-twitter4r/Makefile
index ef27c9f82c85..572679f4d4d0 100644
--- a/net/rubygem-twitter4r/Makefile
+++ b/net/rubygem-twitter4r/Makefile
@@ -17,6 +17,7 @@ COMMENT= Twitter client API in pure Ruby
BUILD_DEPENDS= rubygem-json>=0.4.3:${PORTSDIR}/devel/rubygem-json
RUN_DEPENDS= rubygem-json>=0.4.3:${PORTSDIR}/devel/rubygem-json
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-yadis/Makefile b/net/rubygem-yadis/Makefile
index d2c5d52e16bc..b85229cf9895 100644
--- a/net/rubygem-yadis/Makefile
+++ b/net/rubygem-yadis/Makefile
@@ -15,11 +15,10 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A Yadis Service discovery library written in pure Ruby
USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/sipxconfig/Makefile b/net/sipxconfig/Makefile
index b0bba1c0f7df..f0fdc89b7110 100644
--- a/net/sipxconfig/Makefile
+++ b/net/sipxconfig/Makefile
@@ -16,8 +16,6 @@ COMMENT= sipX server for configuring sipX via a web interface
BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant \
${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
- gem:${PORTSDIR}/devel/ruby-gems \
- rake:${PORTSDIR}/devel/rubygem-rake \
zip:${PORTSDIR}/archivers/zip \
ginstall:${PORTSDIR}/sysutils/coreutils
LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
@@ -33,6 +31,7 @@ USE_AUTOTOOLS= autoconf:261:env automake:19:env
USE_JAVA= 1.4+
USE_APACHE= 2.0+
USE_RUBY= yes
+USE_RAKE= yes
GNU_CONFIGURE= yes
LOCALSTATEDIR= /var
CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME} \
@@ -48,6 +47,12 @@ SUB_FILES= pkg-install pkg-deinstall
PKGINSTALL= ${WRKDIR}/pkg-install
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 1.8
+BUILD_DEPENDS+= gem:${PORTSDIR}/devel/ruby-gems
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/web/bin/sipxconfig.sh.in
@${REINPLACE_CMD} -e "s,@PREFIX@,${PREFIX}," ${WRKSRC}/web/bin/sipxconfig.sh.in
@@ -58,4 +63,4 @@ pre-install:
post-install:
@${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/sipxproxy/Makefile b/net/sipxproxy/Makefile
index 49c691416290..a40697b9a673 100644
--- a/net/sipxproxy/Makefile
+++ b/net/sipxproxy/Makefile
@@ -21,8 +21,6 @@ LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
psql:${PORTSDIR}/databases/postgresql81-client
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- gem:${PORTSDIR}/devel/ruby-gems \
- rake:${PORTSDIR}/devel/rubygem-rake \
ginstall:${PORTSDIR}/sysutils/coreutils \
cppunit-config:${PORTSDIR}/devel/cppunit
@@ -43,6 +41,12 @@ SUB_FILES= pkg-install pkg-deinstall
PKGINSTALL= ${WRKDIR}/pkg-install
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 1.8
+BUILD_DEPENDS+= gem:${PORTSDIR}/devel/ruby-gems
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxcallresolver.sh.in
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipproxy.sh.in
@@ -55,4 +59,4 @@ pre-install:
post-install:
@${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>