aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-05-17 21:17:37 +0800
committerFlorian Smeets <flo@FreeBSD.org>2012-05-17 21:17:37 +0800
commitfc1f6932cf3dcfa3b57dc38b53fef057a78a9add (patch)
tree8dbf3d19f319e27e269ba1c0f36217d0983cc7f1 /net
parente38bcd22192353378284567852fec1797256bf3f (diff)
downloadfreebsd-ports-gnome-fc1f6932cf3dcfa3b57dc38b53fef057a78a9add.tar.gz
freebsd-ports-gnome-fc1f6932cf3dcfa3b57dc38b53fef057a78a9add.tar.zst
freebsd-ports-gnome-fc1f6932cf3dcfa3b57dc38b53fef057a78a9add.zip
- Add a few more patches i missed in the original commit.
- Bump PORTREVISION accordingly
Diffstat (limited to 'net')
-rw-r--r--net/php53-soap/Makefile2
-rw-r--r--net/php53-soap/files/patch-soap.c56
2 files changed, 58 insertions, 0 deletions
diff --git a/net/php53-soap/Makefile b/net/php53-soap/Makefile
index 532f4c95be82..537470b1e476 100644
--- a/net/php53-soap/Makefile
+++ b/net/php53-soap/Makefile
@@ -5,6 +5,8 @@
# $FreeBSD$
#
+PORTREVISION= 1
+
CATEGORIES= net
MASTERDIR= ${.CURDIR}/../../lang/php53
diff --git a/net/php53-soap/files/patch-soap.c b/net/php53-soap/files/patch-soap.c
new file mode 100644
index 000000000000..70b84d3a60e9
--- /dev/null
+++ b/net/php53-soap/files/patch-soap.c
@@ -0,0 +1,56 @@
+--- soap.c.orig Tue Oct 3 21:51:01 2006
++++ soap.c Sat Nov 4 11:38:29 2006
+@@ -23,7 +23,7 @@
+ #include "config.h"
+ #endif
+ #include "php_soap.h"
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ #include "ext/session/php_session.h"
+ #endif
+ #ifdef ZEND_ENGINE_2
+@@ -1577,7 +1577,7 @@
+ soap_obj = service->soap_object;
+ function_table = &((Z_OBJCE_P(soap_obj))->function_table);
+ } else if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If persistent then set soap_obj from from the previous created session (if available) */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap;
+@@ -1664,7 +1664,7 @@
+ }
+ efree(class_name);
+ }
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If session then update session hash with new object */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap_pp;
+@@ -1762,7 +1762,7 @@
+ if (service->type == SOAP_CLASS || service->type == SOAP_OBJECT) {
+ call_status = call_user_function(NULL, &soap_obj, &function_name, &retval, num_params, params TSRMLS_CC);
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ zval_ptr_dtor(&soap_obj);
+ soap_obj = NULL;
+@@ -1788,7 +1788,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {
+@@ -1830,7 +1830,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {