aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-12 00:48:03 +0800
committermiwi <miwi@FreeBSD.org>2007-03-12 00:48:03 +0800
commitfd2824758cb12519719cda1ef63554b022575f65 (patch)
tree484b7a90c5e937721679b5d1f62d4aea22e623a2 /net
parent7aaf4603139dbc4132aaf2d0144f0fa044fbf164 (diff)
downloadfreebsd-ports-gnome-fd2824758cb12519719cda1ef63554b022575f65.tar.gz
freebsd-ports-gnome-fd2824758cb12519719cda1ef63554b022575f65.tar.zst
freebsd-ports-gnome-fd2824758cb12519719cda1ef63554b022575f65.zip
- Chase the merged of speex-devel -> speex
- Drop 4.X support PR: 110193 Submitted by: Jean-Baptiste Quenot <jbq@caraldi.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/opal/Makefile6
-rw-r--r--net/opal3/Makefile6
2 files changed, 2 insertions, 10 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 109daf81cc5a..3f9a39f14257 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -34,10 +34,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
-.endif
-
# Avoid build error on 64-bit architectures
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
@@ -50,7 +46,7 @@ CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.ifdef (WITH_SPEEX)
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
-BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex-devel
+BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
CONFIGURE_ARGS+= --enable-localspeex=no
.else
CONFIGURE_ARGS+= --enable-localspeex=yes
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 109daf81cc5a..3f9a39f14257 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -34,10 +34,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
-.endif
-
# Avoid build error on 64-bit architectures
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
@@ -50,7 +46,7 @@ CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.ifdef (WITH_SPEEX)
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
-BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex-devel
+BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
CONFIGURE_ARGS+= --enable-localspeex=no
.else
CONFIGURE_ARGS+= --enable-localspeex=yes