aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-12 00:20:51 +0800
committerpav <pav@FreeBSD.org>2005-03-12 00:20:51 +0800
commitfda32e3eb7153a0efdf3d570cac765cdd48a9b8d (patch)
tree4a6e15b2cbebd63aacfc31f05c2af0ddbc0eab83 /net
parentc59768fc3d8fcedfa09ffafdb222805d3e7c3573 (diff)
downloadfreebsd-ports-gnome-fda32e3eb7153a0efdf3d570cac765cdd48a9b8d.tar.gz
freebsd-ports-gnome-fda32e3eb7153a0efdf3d570cac765cdd48a9b8d.tar.zst
freebsd-ports-gnome-fda32e3eb7153a0efdf3d570cac765cdd48a9b8d.zip
New port: security/pecl-radius Radius client library
This package is based on the libradius of FreeBSD, with some modifications and extensions. This PECL provides full support for RADIUS authentication (RFC 2865) and RADIUS accounting (RFC 2866), works on Unix and on Windows. Its an easy way to authenticate your users against the user-database of your OS (for example against Windows Active-Directory via IAS). PR: ports/78638 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-radius/Makefile30
-rw-r--r--net/pecl-radius/distinfo2
-rw-r--r--net/pecl-radius/pkg-descr9
-rw-r--r--net/pecl-radius/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4c11f04a8cd8..a4574e6a94e7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -565,6 +565,7 @@
SUBDIR += pear-Net_UserAgent_Detect
SUBDIR += pear-SOAP
SUBDIR += pebrot
+ SUBDIR += pecl-radius
SUBDIR += pecl-yaz
SUBDIR += peercast
SUBDIR += pen
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
new file mode 100644
index 000000000000..fc1b4973668b
--- /dev/null
+++ b/net/pecl-radius/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pecl-radius
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= radius
+PORTVERSION= 1.2.4
+CATEGORIES= net security pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= antonio@php.net
+COMMENT= Radius client library for PHP
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-radius
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pecl-radius/distinfo b/net/pecl-radius/distinfo
new file mode 100644
index 000000000000..3b3a193e33ba
--- /dev/null
+++ b/net/pecl-radius/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/radius-1.2.4.tgz) = 3d48ccb9486b9e8839d814d7ff318091
+SIZE (PECL/radius-1.2.4.tgz) = 29599
diff --git a/net/pecl-radius/pkg-descr b/net/pecl-radius/pkg-descr
new file mode 100644
index 000000000000..eb8f79ad997b
--- /dev/null
+++ b/net/pecl-radius/pkg-descr
@@ -0,0 +1,9 @@
+This package is based on the libradius of FreeBSD, with some modifications and
+extensions.
+
+This PECL provides full support for RADIUS authentication (RFC 2865) and
+RADIUS accounting (RFC 2866), works on Unix and on Windows. Its an easy way to
+authenticate your users against the user-database of your OS (for example
+against Windows Active-Directory via IAS).
+
+WWW: http://pecl.php.net/package/radius/
diff --git a/net/pecl-radius/pkg-plist b/net/pecl-radius/pkg-plist
new file mode 100644
index 000000000000..19d3396fde6c
--- /dev/null
+++ b/net/pecl-radius/pkg-plist
@@ -0,0 +1,6 @@
+%%PORTDOCS%%%%EXAMPLESDIR%%/radius-auth.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/radius-acct.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/des.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/mschap.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/mschaptest.php
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%