aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-05-11 20:20:22 +0800
committerxmj <xmj@FreeBSD.org>2015-05-11 20:20:22 +0800
commitfe6b3b6a582f2415dbcda0e0bb485b276e1fdc2d (patch)
tree992c81e0a3fcd7493b8a43f43af09154de45b9cf /net
parent76986305c07845b629dec92e4db87d70dd61a893 (diff)
downloadfreebsd-ports-gnome-fe6b3b6a582f2415dbcda0e0bb485b276e1fdc2d.tar.gz
freebsd-ports-gnome-fe6b3b6a582f2415dbcda0e0bb485b276e1fdc2d.tar.zst
freebsd-ports-gnome-fe6b3b6a582f2415dbcda0e0bb485b276e1fdc2d.zip
net/libnss-cache: Add port.
libnss-cache is a NSS module for reading directory service information for hosts from an indexed, local disk cache of that directory service. nsswitch.conf services provided: passwd and group Add 'nsscache' to the desired service(s) and generate the cache with the net/nsscache port. WWW: https://github.com/google/libnss-cache PR: 200120 Submitted by: Kevin Bowling <k@kev009.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libnss-cache/Makefile32
-rw-r--r--net/libnss-cache/distinfo2
-rw-r--r--net/libnss-cache/pkg-descr9
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 89d443c1b2b9..f7dfa7628b6c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -315,6 +315,7 @@
SUBDIR += libnfs
SUBDIR += libnids
SUBDIR += libnids-libnet11
+ SUBDIR += libnss-cache
SUBDIR += libnss-mysql
SUBDIR += liboauth
SUBDIR += libopennet
diff --git a/net/libnss-cache/Makefile b/net/libnss-cache/Makefile
new file mode 100644
index 000000000000..13f8008dec6c
--- /dev/null
+++ b/net/libnss-cache/Makefile
@@ -0,0 +1,32 @@
+# Created by: Kevin Bowling <k@kev009.com>
+# $FreeBSD$
+
+PORTNAME= libnss-cache
+PORTVERSION= 0.13
+CATEGORIES= net
+
+MAINTAINER= k@kev009.com
+COMMENT= NSS module for directory services using an indexed, local disk cache
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_TAGNAME= 9cacefb1afdeeefcb35c6f363370909692da5203
+
+PLIST_FILES= lib/nss_nsscache.so lib/nss_nsscache.so.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|PREFIX=$$(DESTDIR)/usr|PREFIX=${STAGEDIR}${PREFIX}|g' \
+ -e 's|LIBRARY=libnss_cache.so.2.0|LIBRARY=nss_nsscache.so.1|g' \
+ -e 's|BASE_LIBRARY=libnss_cache.so.2|BASE_LIBRARY=nss_nsscache.so|g' \
+ -e 's|SONAME=libnss_cache.so.2|SONAME=nss_nsscahe.so.1|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/nss_nsscache.so.1
+
+.include <bsd.port.mk>
diff --git a/net/libnss-cache/distinfo b/net/libnss-cache/distinfo
new file mode 100644
index 000000000000..e692928a04a7
--- /dev/null
+++ b/net/libnss-cache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (google-libnss-cache-0.13-9cacefb1afdeeefcb35c6f363370909692da5203_GH0.tar.gz) = d3bf4c06ba165ab8ba8c244487cdf4ada5862b9493c87973a8aadabd48759767
+SIZE (google-libnss-cache-0.13-9cacefb1afdeeefcb35c6f363370909692da5203_GH0.tar.gz) = 17114
diff --git a/net/libnss-cache/pkg-descr b/net/libnss-cache/pkg-descr
new file mode 100644
index 000000000000..60326ec07c91
--- /dev/null
+++ b/net/libnss-cache/pkg-descr
@@ -0,0 +1,9 @@
+libnss-cache is a NSS module for reading directory service information for
+hosts from an indexed, local disk cache of that directory service.
+
+nsswitch.conf services provided: passwd and group
+
+Add 'nsscache' to the desired service(s) and generate the cache with the
+net/nsscache port.
+
+WWW: https://github.com/google/libnss-cache