aboutsummaryrefslogtreecommitdiffstats
path: root/news/husky-hpt/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-01-11 20:14:54 +0800
committerfjoe <fjoe@FreeBSD.org>2003-01-11 20:14:54 +0800
commit342c76ce34e84f3efc6cb274459583fd5f53a09d (patch)
tree7b3f97ce75fac0ed27ce537d9f9c14aee6b5da47 /news/husky-hpt/Makefile
parent8a5eb56d151bde8693169f3176b61d530b035f7b (diff)
downloadfreebsd-ports-gnome-342c76ce34e84f3efc6cb274459583fd5f53a09d.tar.gz
freebsd-ports-gnome-342c76ce34e84f3efc6cb274459583fd5f53a09d.tar.zst
freebsd-ports-gnome-342c76ce34e84f3efc6cb274459583fd5f53a09d.zip
correctly specify path to fidoconfig configuration file in man pages
Diffstat (limited to 'news/husky-hpt/Makefile')
-rw-r--r--news/husky-hpt/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index 430008b4881a..0149998c7fca 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -15,9 +15,19 @@ MAINTAINER= fjoe@FreeBSD.org
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
+USE_REINPLACE= yes
+
MAN1= hpt.1 hptlink.1 hpttree.1 txt2pkt.1
MANCOMPRESSED= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hptlink.1
+ @${REINPLACE_CMD} -e 's^/some/path/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hpttree.1
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/txt2pkt.1
+
post-build:
@cd ${WRKSRC}/doc && ${GMAKE}