aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-08 05:16:16 +0800
committerpav <pav@FreeBSD.org>2006-05-08 05:16:16 +0800
commit67700b23a0e8663259ee4944f5b0ea3545eed0ee (patch)
treec33dceaaf668a9a73006bb81d7870ae4577a619c /news/inn/files
parent8d7c33bc305b31eeeed04f150cfb19f612e6fddd (diff)
downloadfreebsd-ports-gnome-67700b23a0e8663259ee4944f5b0ea3545eed0ee.tar.gz
freebsd-ports-gnome-67700b23a0e8663259ee4944f5b0ea3545eed0ee.tar.zst
freebsd-ports-gnome-67700b23a0e8663259ee4944f5b0ea3545eed0ee.zip
- Update to 2.4.3
- Provide rc_subr startup script - Take maintainership PR: ports/96872 Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'news/inn/files')
-rw-r--r--news/inn/files/innd.sh9
-rw-r--r--news/inn/files/innd.sh.in38
-rw-r--r--news/inn/files/patch-configure10
-rw-r--r--news/inn/files/patch-site::Makefile27
4 files changed, 62 insertions, 22 deletions
diff --git a/news/inn/files/innd.sh b/news/inn/files/innd.sh
deleted file mode 100644
index 1bcc4f7b5ad5..000000000000
--- a/news/inn/files/innd.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-if [ $# -eq 0 -o x$1 = xstart ]; then
- if [ -x !!PREFIX!!/news/bin/rc.news -a -f !!PREFIX!!/news/db/history.dir ]; then
- su -fm news -c !!PREFIX!!/news/bin/rc.news && echo ' inn'
- fi
-fi
-if [ x$1 = xstop ]; then
- su -fm news -c '!!PREFIX!!/news/bin/rc.news stop'
-fi
diff --git a/news/inn/files/innd.sh.in b/news/inn/files/innd.sh.in
new file mode 100644
index 000000000000..94d612dbe42b
--- /dev/null
+++ b/news/inn/files/innd.sh.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+#
+# PROVIDE: innd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# $FreeBSD$
+#
+
+. %%RC_SUBR%%
+
+name=innd
+
+innd_enable=${innd_enable-"NO"}
+innd_user=${innd_user-"news"}
+innd_group=${innd_group-"news"}
+
+required_files="%%PREFIX%%/news/db/history.dir"
+
+load_rc_config ${name}
+
+start_cmd=${name}_start
+stop_cmd=${name}_stop
+
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/news/bin/rc.news
+
+innd_start() {
+ su -fm ${innd_user} -c "${command} start"
+}
+
+innd_stop() {
+ su -fm ${innd_user} -c "${command} stop"
+}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/news/inn/files/patch-configure b/news/inn/files/patch-configure
index efc64a5cee58..cd2f404670e2 100644
--- a/news/inn/files/patch-configure
+++ b/news/inn/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Tue Sep 2 06:39:30 2003
-+++ configure Wed Oct 22 15:23:46 2003
-@@ -5826,36 +5826,9 @@
+--- configure.orig Mon Mar 20 04:14:57 2006
++++ configure Sat May 6 02:32:58 2006
+@@ -7604,36 +7604,9 @@
done
done
fi
- if test x"$BERKELEY_DB_DIR" = xyes ; then
-- for v in db41 db4 db3 db2 ; do
+- for v in db43 db42 db41 db4 db3 db2 ; do
- if test -d "/usr/local/include/$v" ; then
- BERKELEY_DB_LDFLAGS="-L/usr/local/lib"
- BERKELEY_DB_CFLAGS="-I/usr/local/include/$v"
@@ -15,7 +15,7 @@
- fi
- done
- if test x"$BERKELEY_DB_LIB" = x ; then
-- for v in db41 db4 db3 db2 ; do
+- for v in db43 db42 db41 db4 db3 db2 ; do
- if test -d "/usr/include/$v" ; then
- BERKELEY_DB_CFLAGS="-I/usr/include/$v"
- BERKELEY_DB_LIB="-l$v"
diff --git a/news/inn/files/patch-site::Makefile b/news/inn/files/patch-site::Makefile
index 5a22a277e000..f99e162dd478 100644
--- a/news/inn/files/patch-site::Makefile
+++ b/news/inn/files/patch-site::Makefile
@@ -1,8 +1,8 @@
---- site/Makefile.orig Sat Jul 12 21:11:02 2003
-+++ site/Makefile Sun Sep 21 12:53:00 2003
-@@ -23,29 +23,29 @@
- PATH_NNRPAUTH = ${PATHFILTER}/nnrpd_auth.pl
+--- site/Makefile.orig Mon Mar 20 04:14:57 2006
++++ site/Makefile Sat May 6 04:15:50 2006
+@@ -24,29 +24,29 @@
PATH_NNRPYAUTH = ${PATHFILTER}/nnrpd_auth.py
+ PATH_NNRPACCESS = ${PATHFILTER}/nnrpd_access.pl
-PATH_CONFIG = ${PATHETC}/inn.conf
-PATH_CONTROLCTL = ${PATHETC}/control.ctl
@@ -53,7 +53,7 @@
PATH_ACTIVE = ${PATHDB}/active
PATH_ACTIVE_TIMES = ${PATHDB}/active.times
-@@ -71,8 +71,8 @@
+@@ -73,8 +73,8 @@
$D$(PATH_NEWSFEEDS) $D$(PATH_INNDHOSTS) \
$D$(PATH_NNRPDTRACK) $D$(PATH_NNTPPASS) \
$D$(PATH_CONFIG) $D$(PATH_MODERATORS) \
@@ -64,16 +64,27 @@
$D$(PATH_CTLWATCH) $D$(PATH_DISTPATS) $D$(PATH_SCHEMA) \
$D$(PATH_ACTSYNC_CFG) $D$(PATH_ACTSYNC_IGN) \
$D$(PATH_MOTD) $D$(PATH_STORAGECONF) \
-@@ -81,7 +81,7 @@
+@@ -83,7 +83,7 @@
$D$(PATH_PERL_FILTER_INND) $D$(PATH_PERL_FILTER_NNRPD) \
$D$(PATH_PYTHON_FILTER_INND) $D$(PATH_PYTHON_INN_MODULE) \
$D$(PATH_TCL_STARTUP) $D$(PATH_TCL_FILTER) \
- $D$(PATH_NNRPAUTH) $D$(PATHETC)/news2mail.cf $D$(PATH_READERSCONF) \
+ $D$(PATH_NNRPAUTH) $D$(PATHETC)/news2mail.cf.dist $D$(PATH_READERSCONF) \
$D$(PATH_RADIUS_CONF) $D$(PATH_NNRPYAUTH) $D$(PATH_OVDB_CONF) \
- $D$(PATH_SASL_CONF) $D$(PATH_SUBSCRIPTIONS)
+ $D$(PATH_SASL_CONF) $D$(PATH_SUBSCRIPTIONS) $D$(PATH_NNRPACCESS)
-@@ -170,9 +170,9 @@
+@@ -136,8 +136,8 @@
+ chgrp $(NEWSGROUP) $@
+ chmod $(FILEMODE) $@
+ $D$(PATH_HISTORY):
+- touch $@
+- $(PATHBIN)/makedbz -i -o
++# touch $@
++# $(PATHBIN)/makedbz -i -o
+
+ ## Remove files that are unchanged from the release version.
+ clean:
+@@ -176,9 +176,9 @@
$D$(PATH_MODERATORS): moderators ; $(COPY_RPUB) $? $@
$D$(PATH_DISTPATS): distrib.pats ; $(COPY_RPUB) $? $@
$D$(PATH_NNTPPASS): passwd.nntp ; $(COPY_RPRI) $? $@