aboutsummaryrefslogtreecommitdiffstats
path: root/news/newscache
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-05 08:43:42 +0800
committeredwin <edwin@FreeBSD.org>2006-01-05 08:43:42 +0800
commite482d3efad7154cad1a80df426e27c34913c963c (patch)
tree7b0a65bd08fa758da41eb797b1f376f20114cc8d /news/newscache
parent4cebee1d5e8b033764c0ab69c274a904e4392a85 (diff)
downloadfreebsd-ports-gnome-e482d3efad7154cad1a80df426e27c34913c963c.tar.gz
freebsd-ports-gnome-e482d3efad7154cad1a80df426e27c34913c963c.tar.zst
freebsd-ports-gnome-e482d3efad7154cad1a80df426e27c34913c963c.zip
Implement feedback from dougb@
It would be better to replace the SUB_FILES line in the Makefile with: USE_RC_SUBR= ${PORTNAME}.sh This provides several benefits in the short term. It would obviate the need for the post-install target and the pkg-plist entry, as the USE_RC_SUBR macro handles that stuff (as well as the SUB_FILES stuff) for you automatically. In the long term, we're going to add even more support for good things in the USE_RC_SUBR code, so it's a good idea to move that direction now.
Diffstat (limited to 'news/newscache')
-rw-r--r--news/newscache/Makefile5
-rw-r--r--news/newscache/pkg-plist1
2 files changed, 1 insertions, 5 deletions
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index 63d98d6f973a..b1c42bcc4a1c 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -24,7 +24,7 @@ AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
-SUB_FILES= newscache.sh
+USE_RC_SUBR= ${PORTNAME}.sh
MAN5= newscache.conf.5
MAN8= newscache.8 newscacheclean.8 updatenews.8
@@ -36,7 +36,4 @@ post-patch:
pre-configure:
(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen)
-post-install:
- cp ${WRKDIR}/newscache.sh ${PREFIX}/etc/rc.d
-
.include <bsd.port.mk>
diff --git a/news/newscache/pkg-plist b/news/newscache/pkg-plist
index 47ea849c34cc..f6d74ddf91be 100644
--- a/news/newscache/pkg-plist
+++ b/news/newscache/pkg-plist
@@ -1,6 +1,5 @@
bin/updatenews
etc/newscache.conf-dist
etc/newscache.auth-dist
-etc/rc.d/newscache.sh
sbin/newscache
sbin/newscacheclean