aboutsummaryrefslogtreecommitdiffstats
path: root/news/nzbget/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-10-04 23:14:09 +0800
committerMark Felder <feld@FreeBSD.org>2018-10-04 23:14:09 +0800
commit730c9c1c29e5e7c79ae45d0863684e2beedc3222 (patch)
tree72c393bbcd75cbc9ab5167d40b8fd37c609fb4b0 /news/nzbget/Makefile
parent3701c113a6758b3be8cc5ed870c84340acfd219c (diff)
downloadfreebsd-ports-gnome-730c9c1c29e5e7c79ae45d0863684e2beedc3222.tar.gz
freebsd-ports-gnome-730c9c1c29e5e7c79ae45d0863684e2beedc3222.tar.zst
freebsd-ports-gnome-730c9c1c29e5e7c79ae45d0863684e2beedc3222.zip
news/nzbget: Update to 20.0
- Add patches to disable building with optimized CFLAGS by default PR: 228888 Approved by: maintainer (timeout) MFH: 2018Q4
Diffstat (limited to 'news/nzbget/Makefile')
-rw-r--r--news/nzbget/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index 85bab1c53d4d..4c7c208e2399 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= nzbget
-PORTVERSION= 19.1
-PORTREVISION= 2
+PORTVERSION= 20.0
+PORTREVISION= 0
DISTVERSIONPREFIX= v
CATEGORIES= news
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libxml2.so:textproc/libxml2
-USES= compiler:c++14-lang ncurses pkgconfig shebangfix ssl
+USES= autoreconf compiler:c++14-lang gmake localbase ncurses pkgconfig shebangfix ssl
USE_RC_SUBR= nzbget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libcurses-includes=${NCURSESINC} \
@@ -23,10 +23,6 @@ CONFIGURE_ARGS= --with-libcurses-includes=${NCURSESINC} \
--with-openssl-includes=${OPENSSLINC} \
--with-openssl-libraries=${OPENSSLLIB}
-CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
-MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread
BINMODE= 0755
SHEBANG_FILES= scripts/*.py
@@ -34,14 +30,17 @@ SUB_FILES= pkg-message
USE_GITHUB= yes
-OPTIONS_DEFINE= 7Z PYTHON RAR DOCS
+OPTIONS_DEFINE= 7Z OPTIMIZED_FLAGS PYTHON RAR
OPTIONS_DEFAULT= PAR PYTHON RAR 7Z
7Z_DESC= Support extraction of 7z archives
+OPTIMIZED_FLAGS_DESC= Enable optimized CPU instructions (SSE2/SSE3/NEON/etc)
PYTHON_DESC= Support for python post-processing scripts
RAR_DESC= Support extraction of rar archives
7Z_RUN_DEPENDS= 7z:archivers/p7zip
+OPTIMIZED_FLAGS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-disable-optimized-flags.patch
+
PYTHON_USES= python:run
RAR_RUN_DEPENDS= unrar:archivers/unrar